X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox will not load a website (tastytrade), but Chrome will - what's wrong, thanks.

Posted

Last week, Firefox was able to load the website TastyTrade (now it can't) - I have no problem opening other sites. Chrome is able to open the website. Thanks.

Additional System Details

Installed Plug-ins

  • thinkorswim loader
  • thinkDesktop configuration loader
  • Shockwave Flash 11.9 r900
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • iPhoto6
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • NDS Player Plugin
  • RealPlayer Plugin

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

Michalis 18 solutions 193 answers

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

Question owner

Max, I did the suggestions and it did not work. I have a Mac and I get the spinning ball that won't go away. I have to force quit firefox and start up (and restore) and then close the tab that's not working (ie. trying to get on tastytrade) before it engages again.

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97056 answers

Can you access this website via Google Translate with a random source language (e.g. fr)?

  • http://translate.google.com/translate?hl=en&sl=fr&tl=en&u=<append URL>

Question owner

It did not solve the problem. What is about my set up that prevents this particular site from loading, again other sites can load. thanks.

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97056 answers

for more suggestions, see:

BarleySinger 0 solutions 5 answers

Helpful Reply

The problem is that FIREFOX 26 blows great big greasy chunks and you need to roll back (and apologize to the universe) and toss it in the bin....and have a nice long talk with your developers about the definitions of the words:

"stupid" and "broken"

FredMcD
  • Top 25 Contributor
115 solutions 1497 answers

If your Mac Firefox has a safe mode, see if it works. With mine, hold down the shift key before starting FF.

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97056 answers

On Mac, hold down the Options key while starting Firefox to start in Safe Mode.

luxbock 0 solutions 1 answers

I have the same problem. Firefox is unable to load any page but Chrome works without a hitch. What's interesting is that this problem is only present when I use my WiFi at my new apartment. I just tried switching to my tethered connection from my phone, and when I do this then both browsers work the same. It's only when I switch to the new WiFi when Firefox is unable to load any pages (I checked the developer console and the there is the GET request but nothing happens afterwards.)

I'm on Mac and I already tried using Safe Mode without any improvement in the situation. Let me know if there is any additional information about the connection type that I can provide in order to track down the problem.

FredMcD
  • Top 25 Contributor
115 solutions 1497 answers

luxbock; Hmmm. If you can, plug in to the modem using a wire, without using the WiFi? Also, access your WiFi firewall and check it's settings.

blackscott; Try going to Mozilla.org, and download the full installer.