X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I stop yahoo from being my default homepage?

Posted

Over the weekend, Yahoo has somehow been made my default homepage. When I go to Preferences and change it to my desired homepage, it only works for the next launch - then it reverts back to Yahoo. So I uninstalled Firefox and downloaded a new copy. Same thing, so apparently it's a moderation you have made to your browser.

I do not like this. If you don't tell me how to permanently remove Yahoo as my default page, and allow me to PERMANENTLY decide for myself what my default homepage is, I will stop using Firefox altogether, even if it until now has been my favorite browser.

I am on an iMac running OS X 10.6.8

Chosen solution

This is a side effect of the SearchMe extension, which apparently is bundled with some popular torrent software.

You can disable that extension, then restart Firefox and choose your preferred home page again. You'll do that here:

Tools menu > Add-ons > in the left column, click Extensions

It might also be possible to track this extension down on your computer and physically remove it, but as a Windows user, I don't know the ins and outs of how to do that on a Mac.

Read this answer in context 7

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • 5.1.20125.0
  • Version 1.0.20.8768
  • AVX Multimedia Engine
  • iPhoto6
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • npmnqmp 07076003

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/Darwin/en-US/

Extensions

  • Searchme 1.5 (searchme@mybrowserbar.com)
  • SQLite Manager 0.8.1 (SQLiteManager@mrinalkant.blogspot.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x71c5
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon X1600 OpenGL Engine
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.startup.homepage: http://www.google.com/
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 24.0
  • font.internaluseonly.changed: False
  • gfx.blacklist.direct2d: 3
  • gfx.blacklist.layers.direct3d9: 3
  • gfx.blacklist.webgl.msaa: 4
  • keyword.URL: http://search.yahoo.com/search?fr=spigot-adr-ffmac&ei=utf-8&ilc=12&type=967150&p=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1381769461
  • places.history.expiration.transient_current_max_pages: 53688
  • places.history.expiration.transient_optimal_database_size: 85899344
  • places.last_vacuum: 1301272356
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.cpd.cookies: False
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.item.cookies: True
  • privacy.item.offlineApps: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1381366928

Misc

  • User JS: No
  • Accessibility: No

Question owner

Sorry to everyone who finds this. I thought I was sending an email to Mozilla's customer service...

But... if you have a solution, I'd be glad to try it! Nothing I've seen so far has worked.

jscher2000
  • Top 10 Contributor
2346 solutions 20793 answers

Chosen Solution

This is a side effect of the SearchMe extension, which apparently is bundled with some popular torrent software.

You can disable that extension, then restart Firefox and choose your preferred home page again. You'll do that here:

Tools menu > Add-ons > in the left column, click Extensions

It might also be possible to track this extension down on your computer and physically remove it, but as a Windows user, I don't know the ins and outs of how to do that on a Mac.

pooshka 0 solutions 1 answers

What do I do when I get to the Extensions page? There is no "searchme" program there. There is no searchme program in my computer at all.

Modified by pooshka

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes after a restart or otherwise have problems with preferences, see:

jscher2000
  • Top 10 Contributor
2346 solutions 20793 answers

Hi pooshka, the reason I mentioned Searchme was that the original poster had provided a detailed list of their add-ons with the question. This isn't automatic for replies. If you try the steps in cor-el's post but cannot track down the problem, you can paste your settings into a reply, or start a new question.

To extract your settings manually, use the Troubleshooting Information page. Either:

  • Help > Troubleshooting Information
  • type about:support in the address bar and press Enter

Click the "Copy text to clipboard button" and then you can paste all that data into your reply.

If you decide to start a new question, there's an "Ask a question" link at the top of the page. The system will suggest solutions based on your input. If those aren't helpful, scroll down to continue with the form.

vinbju 0 solutions 1 answers

Helpful Reply

If you're using Advanced System Care in Windows, you have to remove homepage protection, then you can change your homepage as you want

gcsimmons 0 solutions 1 answers

Helpful Reply

Thanks Vinbju, My problem was with the Advance System Care. Once I went and turned off the homepage protection I was able to set my homepage back to default.

andy.sc 0 solutions 1 answers

I too have had this problem and proved to be the IOBit Advanced System Care homepage protection. Thanks to Vinbju for finding this one. Why has it not been found before, I wonder, as the IObit software has been around for ages? Actually I like the idea of something protecting my home page so after turning it off in IObit I then made sure Firefox was displaying my proper home page. I then went back to IOBit homepage protection and modified the setting to 'Use Current'. Hey presto it automatically turned itself on and kept the Firefox setting that I wanted. I have tried logging in and out of both firefox and IOBit several times and nothing adverse has happened. I still have my required home page and -hopefully - IOBIt is protecting it. Hope this help someone!!!

hskoppek 0 solutions 7 answers

I am operating OSX 10.8.5 and Firefox 26

Recently (without having installed new software or extensions) my homepage setting in firefox default to yahoo. Yahoo also showed up as one of my search engines w/o me having installed it. I deleted it and everything was fine for a while. But now instead of showing my windows and tabs from last time, it just shows yahoo instead.

This is very annoying, because I keep loosing all my pinned tabs. None of the solution discussed above are helpful and the problem persists even in the safe mode.

Any suggestions what else I can check - and how?

jscher2000
  • Top 10 Contributor
2346 solutions 20793 answers

Hi hskoppek, can you start a new question? Please run the add-on suggested during the process to capture your list of extensions and settings. This should avoid a lot of back and forth asking you to look things up.

You can start a new question at the following link. Scroll down past the suggestions to continue with the form (I think it has 3 different screens). https://support.mozilla.org/questions/new/desktop/fix-problems

hskoppek 0 solutions 7 answers

Thanks jscher2000

Done this and posted as

How do I stop yahoo from re-setting as my default homepage?