X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 24 with up to date vista fails to display icons on new Yahoo Mail and other web sites - especially icons like facebook, twitter WHY?

Posted

Web sites like murraystivoli.com that display the facebook and twitter icons and especially the new Yahoo Mail interface fail to display the icons. I see only a little rectangle. On Yahoo Mail there is a little number inside but instead of this it should be displaying arrows,, or pictures of envelopes or icons that mean "send". The new interface is unusable without proper icon translation - can't see the arrows for "reply" "reply all". It works on Internet explorer on Vista; it works on Firefox on Windows XP (that is way back level) so why do we see this problem with up to date Vista and Firefox (we're at 24.0 but I've seen problems on web sites that I don't care about that much on other levels of Firefox also.)

PLEASE HELP!!

Web sites like murraystivoli.com that display the facebook and twitter icons and especially the new Yahoo Mail interface fail to display the icons. I see only a little rectangle. On Yahoo Mail there is a little number inside but instead of this it should be displaying arrows,, or pictures of envelopes or icons that mean "send". The new interface is unusable without proper icon translation - can't see the arrows for "reply" "reply all". It works on Internet explorer on Vista; it works on Firefox on Windows XP (that is way back level) so why do we see this problem with up to date Vista and Firefox (we're at 24.0 but I've seen problems on web sites that I don't care about that much on other levels of Firefox also.) PLEASE HELP!!

Chosen solution

Same problem here.. I've got no icons or tick boxes at all in Yahoo mail, and it's affecting a good few other websites too, just little square boxes everywhere with numbers in them. It's really annoying!

Here's what it looks like (You may need to zoom-in a little)....

http://img.photobucket.com/albums/v146/orbiter/11-10-201311-48-39AM_zps381dbba9.png

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Shockwave Flash 11.8 r800
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20513.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Picasa plugin
  • CANON iMAGE GATEWAY Mycamera Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

Helpful Reply

changing firefox to "allow pages to choose their own fonts, instead of my selections in tools->options->content-> advanced seems to resolve this problem but it will remain to be seen what THAT messes up.

changing firefox to "allow pages to choose their own fonts, instead of my selections in tools->options->content-> advanced seems to resolve this problem but it will remain to be seen what THAT messes up.
cor-el
  • Top 10 Contributor
  • Moderator
12762 solutions 117263 answers

Those icons are likely characters in a font that is downloaded from the server via @font-face and you need to allow websites to specify their fonts to see such an embedded font.

You can use an extension to set a default font size and other font properties and page zoom on web pages.

Those icons are likely characters in a font that is downloaded from the server via @font-face and you need to allow websites to specify their fonts to see such an embedded font. You can use an extension to set a default font size and other font properties and page zoom on web pages. *NoSquint: https://addons.mozilla.org/firefox/addon/nosquint/ *Default FullZoom Level: https://addons.mozilla.org/firefox/addon/default-fullzoom-level/
paul771 0 solutions 4 answers

I also have this problem specifically with yahoo mail since their refresh today. I use Mac OS 10.7.5 with Firefox 24 and already have "allow pages to choose their own fonts, instead of my selections in tools" selected as suggested in the above reply. The icons do show correctly using the Safari browser. Any help would be appreciated.

I also have this problem specifically with yahoo mail since their refresh today. I use Mac OS 10.7.5 with Firefox 24 and already have "allow pages to choose their own fonts, instead of my selections in tools" selected as suggested in the above reply. The icons do show correctly using the Safari browser. Any help would be appreciated.

Modified by paul771

Question owner

Thank you, cor-el, for the speedy response. Amazingly we had also stumbled into this solution by studying the letters inside the box and eventually following the font trail. Moments later I saw your post and was pleased to see that the experts agree! Changing this setting did solve my problem, but I see other Operating System/Browser combos are still troublesome. Hope there's a MAC solution too.

Thank you, cor-el, for the speedy response. Amazingly we had also stumbled into this solution by studying the letters inside the box and eventually following the font trail. Moments later I saw your post and was pleased to see that the experts agree! Changing this setting did solve my problem, but I see other Operating System/Browser combos are still troublesome. Hope there's a MAC solution too.
cor-el
  • Top 10 Contributor
  • Moderator
12762 solutions 117263 answers

Hi paul771

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.


Do you otherwise have problems with downloadble fonts?

You can check the gfx.downloadable_fonts.enabled pref on the about:config page.


Make sure that you haven't enabled a High Contrast theme in the Mac Accessibility settings (Mac: Command-Option-Control-8).

See also:

Do you see an error message in the Web Console (Firefox/Tools > Web Developer;Command+Shift+K) about downloading this font?
Use "Command + Shift + R" to reload the page if necessary.

Hi paul771 Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem Use a compressed image type like PNG or JPG to save the screenshot. ---- Do you otherwise have problems with downloadble fonts? You can check the gfx.downloadable_fonts.enabled pref on the <b>about:config</b> page. *http://kb.mozillazine.org/about:config ---- Make sure that you haven't enabled a High Contrast theme in the Mac Accessibility settings (Mac: Command-Option-Control-8). *http://support.apple.com/kb/HT1343#odd10 See also: *http://kb.mozillazine.org/Website_colors_are_wrong Do you see an error message in the Web Console (Firefox/Tools > Web Developer;Command+Shift+K) about downloading this font?<br /> Use "Command + Shift + R" to reload the page if necessary.
paul771 0 solutions 4 answers

Thanks for your reply cor- el. I have just signed into mail today and it looks like this issue has been resolved already, either by Mozilla or Yahoo. Everything looks as it should and I'm hoping that it also works as it should.

Thanks for your reply cor- el. I have just signed into mail today and it looks like this issue has been resolved already, either by Mozilla or Yahoo. Everything looks as it should and I'm hoping that it also works as it should.
wlexxx 0 solutions 36 answers

that {" "allow pages to choose their own fonts, instead of my selections in tools->options->content-> advanced"} does NOT work wle

that {" "allow pages to choose their own fonts, instead of my selections in tools->options->content-> advanced"} does NOT work wle
orbiter 1 solutions 3 answers

Chosen Solution

Same problem here.. I've got no icons or tick boxes at all in Yahoo mail, and it's affecting a good few other websites too, just little square boxes everywhere with numbers in them. It's really annoying!

Here's what it looks like (You may need to zoom-in a little)....

http://img.photobucket.com/albums/v146/orbiter/11-10-201311-48-39AM_zps381dbba9.png

Same problem here.. I've got no icons or tick boxes at all in Yahoo mail, and it's affecting a good few other websites too, just little square boxes everywhere with numbers in them. It's really annoying! Here's what it looks like (You may need to zoom-in a little).... http://img.photobucket.com/albums/v146/orbiter/11-10-201311-48-39AM_zps381dbba9.png

Modified by orbiter

paul771 0 solutions 4 answers

After a couple of days problem free, it has now reappeared. I haven't included a screenshot here but it looks exactly the same as the one in orbiter's comment.

After a couple of days problem free, it has now reappeared. I haven't included a screenshot here but it looks exactly the same as the one in orbiter's comment.
ring2 0 solutions 2 answers

Hi, i have the same problem. Changing the options and allowing pages to choose their own fonts helps but it messes up the aspect of other pages. Is there an individual solution that can be applied only for yahoo mail? Thank you!

Hi, i have the same problem. Changing the options and allowing pages to choose their own fonts helps but it messes up the aspect of other pages. Is there an individual solution that can be applied only for yahoo mail? Thank you!

Modified by ring2

cor-el
  • Top 10 Contributor
  • Moderator
12762 solutions 117263 answers

Hi ring2

What goes wrong on other pages with this setting set?

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

Hi ring2 What goes wrong on other pages with this setting set? Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem Use a compressed image type like PNG or JPG to save the screenshot.
jinsta 0 solutions 5 answers

Helpful Reply

Not sure about the rest of them, but for Yahoo Mail...Flick back to basic to sort it!

Yahoo Mail > Settings Icon > Viewing Email, Mail Version – Select BASIC, then Save

Not sure about the rest of them, but for Yahoo Mail...Flick back to basic to sort it! Yahoo Mail > Settings Icon > Viewing Email, Mail Version – Select BASIC, then Save
wlexxx 0 solutions 36 answers

switching to basic only ignores the problem. plus basic is hard to use too, due to missing features

so no one can just get a yahoo account and try it, then tell us what really works?

5 minutes of work....

would save thousands of wasted hours

come on firefoxers...!

wle

switching to basic only ignores the problem. plus basic is hard to use too, due to missing features so no one can just get a yahoo account and try it, then tell us what really works? 5 minutes of work.... would save thousands of wasted hours come on firefoxers...! wle
ring2 0 solutions 2 answers

Hi, it changes fonts in all most all sites (bigger and with bolts) and it messes the page arrangements. I'll try posting some PrintScr

Hi, it changes fonts in all most all sites (bigger and with bolts) and it messes the page arrangements. I'll try posting some PrintScr
wlexxx 0 solutions 36 answers

how does that help me fix my problem though? wle

how does that help me fix my problem though? wle
mkballard 0 solutions 3 answers

I get this problem with Yahoo Mail and Linked In. Linked In has had the problem for a while now, but Yahoo only started about a week or so ago. When I load Yahoo in IE (yuck) I don't see the squares but I don't see any icons at all. Things display normally in Chrome.

I've tried resetting the cookies for Yahoo. Nadda. I've set the setting to let sites choose their own font. Zip. I've thought about beating my computer with a hammer. Tempting. Any ideas on something else to try?

I get this problem with Yahoo Mail and Linked In. Linked In has had the problem for a while now, but Yahoo only started about a week or so ago. When I load Yahoo in IE (yuck) I don't see the squares but I don't see any icons at all. Things display normally in Chrome. I've tried resetting the cookies for Yahoo. Nadda. I've set the setting to let sites choose their own font. Zip. I've thought about beating my computer with a hammer. Tempting. Any ideas on something else to try?
wlexxx 0 solutions 36 answers

all i can figure is, fonts are blocked at work somehow it works ok at home

i have no definitive evidence or tests that work though

wle

all i can figure is, fonts are blocked at work somehow it works ok at home i have no definitive evidence or tests that work though wle
wlexxx 0 solutions 36 answers

not sure how or why a font would be blocked or if that is common, rare, or even possible wle

not sure how or why a font would be blocked or if that is common, rare, or even possible wle
mkballard 0 solutions 3 answers

I wondered about work as well, but like I stated, on Google Chrome, everything displays properly. I have no trouble on my home computer, but since Chrome renders everything properly at work, I'm left to surmise that the cause is in Firefox (and IE).

I wondered about work as well, but like I stated, on Google Chrome, everything displays properly. I have no trouble on my home computer, but since Chrome renders everything properly at work, I'm left to surmise that the cause is in Firefox (and IE).
wlexxx 0 solutions 36 answers

right if it works on chrome at work, why should it not work on FF? unless there is some super geek reason FF & WORK = DEAD

wle

right if it works on chrome at work, why should it not work on FF? unless there is some super geek reason FF & WORK = DEAD wle