Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

All my Yahoo Mail icons disappeared after I installed Firefox 24.0.

  • 51 replies
  • 69 have this problem
  • 21 views
  • Last reply by bobchapman

more options

Immediately after installing Firefox 24.0, the entire look of my Yahoo Mail page changed, and all the usual icons for reply, attach, forward etc. disappeared and were replaced by small boxes with letters in them. I don't have this problem in Safari.

Chosen solution

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.


Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl+0 (zero); Command+0 on Mac)

Try to disable hardware acceleration in Firefox.

Read this answer in context 👍 2

All Replies (20)

more options

i see them there, at the bottom. bunch of them(github fonts). wle

Modified by wlexxx

more options

i see them there, at the bottom. bunch of them wle

more options

Hi wlexxx, when you started Firefox in the new profile, you probably noticed you didn't have your bookmarks and history was empty. That's what I meant about fresh databases.

Since you have the same issue in a new profile, it sounds as though it could be an external filter that is affecting Yahoo Mail. That could be anything from a security suite or parental control software, to entries in the Windows hosts file or a feature of an upstream proxy server/service.

Have you compared IE9/IE10 to confirm that it displays the font normally?

more options

it does work on whatever we have at work here though that is probably ie8 same proxies and firewalls though

is it likely a firewall or corporate filter would block a font?

we do go through zscaler, some kind of cloud based filter/monitor/firewall/porn canceller

but so would the ie8 that works

wle

more options

Hi wlexxx, from what I can see, I'm getting image sprites in both IE8 and Fx24, so I can't tell what triggers the use of downloadable fonts or whether they are used in IE8. Do your colleagues with Firefox have the same issue?

more options

colleagues, don;t know image sprites, dunno what that means wle

more options

i do think the site fonts are not really being downloaded though

at home, it works, if i make 'enable remote site fonts' true

if i make that false, it looks the same as my problem on the work computer

wle

more options

This is done via two @font-face rules. The Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K) doesn't seem to show them for some reason, but Live Http Headers does show the woff files. I have a font that has some characters in the 0xExxx range, so I get a different character when I disable web fonts

This file with a large GET parameter has those @font-face rules.

@font-face{font-family:'mail';src:url("/nq/storm/assets/fonts/mail14.eot");src:url("/nq/storm/assets/fonts/mail14.eot?#iefix") format("embedded-opentype"),url("/nq/storm/assets/fonts/mail14.woff") format("woff"),url("/nq/storm/assets/fonts/mail14.ttf") format("truetype"),url("/nq/storm/assets/fonts/mail14.svg#mail1") format("svg");font-weight:400;font-style:normal}

@font-face{font-family:'envelope';src:url("/nq/storm/assets/fonts/envelope1.eot");src:url("/nq/storm/assets/fonts/envelope1.eot?#iefix") format("embedded-opentype"),url("/nq/storm/assets/fonts/envelope1.woff") format("woff"),url("/nq/storm/assets/fonts/envelope1.ttf") format("truetype"),url("/nq/storm/assets/fonts/envelope1.svg#envelope") format("svg");font-weight:normal;font-style:normal}
more options

Hi wlexxx, I don't suppose your IT would take an interest in figuring out why downloadable fonts are blocked on Yahoo but not on the Github site...

more options

"font-face rules" ok means nothing to me, of course is there some way i can use this information>:?


=

--I don't suppose your IT would take an interest in figuring out why downloadable fonts are blocked on Yahoo but not on the Github site... == == doubt it not really that kind of company or IT dept..

=

wle

more options

it's a font issue

1) Paste the below into the address field and press enter

about:config

2) say yes I will be careful

3) search for this gfx.downloadable_fonts.enabled

4) set this to true (right click choose toggle)

5) refresh yahoo mail page (F5)

more options

" gfx.downloadable_fonts.enabled" no, i think i answered that one already doesn;t change anything wle

more options

You can try to install the Live Http Headers extension and check if Firefox downloads the woff fonts mail14.woff and envelope1.woff.

I don't know which of the two fonts has the icons in the 0xE000-0xEFFF range used to display the icons.

more options

ok i did it i have no idea how to run that or what to look for wle

more options

I had the same problem with Yahoo!.

I found a solution in other forum. It is in brazilian portuguese.

http://forum.clubedohardware.com.br/r.../706241?s=c439889cdc364fad9cc6f6de3c0a6d4c&

Basicly the forum says if your DNS is working automaticaly, you need to configure it manually. For example, using Google's DNS: 8.8.8.8

I did it and all Yahoo's problems were solved.

hugs,

Edwar Saliba Júnior

more options

that page won;t translate, does not appear to resolve to a single issue, i don't see how to make JUST firefox use a 2nd DNS server...

???? wle

more options

also i am at work, and i can;t just change DNS at random

also also, i think it IS configured manually anyway by scripts at login

wle

more options

Does such a font work here on GitHub (scroll down to see the octicons)?

   https://github.com/styleguide/css/7.0 

No, instead of the icons, I see the same error boxes plus some code next to it like "UTF+f09b" where the icons should be. (wlexxx, I'm surprised you can see the icons!)


If you right click on the Yahoo mail page and select "View Page Source" it appears that the s.ymig.com css stylesheet isn't loading properly. Hover a mouse over the red "&" in the first row of code (which does appear to refer to headers and buttons) and the following message appears in a pop up box:

"&" did not start a character reference. ("&" probably should have been escaped as "& amp ; ".)


  • NOTE: The spaces don't appear between the "&" "amp" and ";" at the very end of the last sentence, but the "amp;" disappeared when I previewed this reply - hmm!

Could this be the reason icons aren't loading?


I checked config and favicons are set to 'true', as is gfx.downloadable_fonts.enabled, but there are lots of other gfx lines in there, some set to true, some false... argh...

wlexxx, RE: "can someone just open a yahoo account and see for themselves? i see hundreds of complaints on twitter, FB, etc over this it's virtually unusable", I second your motion!  ;) Wouldn't you think a Firefox tech would have opened a Yahoo account immediately?

Thank you to everyone trying to help!

more options

cor-el provided the fix for me in another thread, as follows:

Note that these icons are actually a custom font that is downloaded.

Make sure that you allow pages to choose their own fonts.

   Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"
more options

no, i think someone suggested that way back. it doesn;t work.

nothing works

wle

  1. 1
  2. 2
  3. 3