Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When creating iframes for htm pages, I pdfs work just fine in all versions of Firefox. However, when I construct an iframe for an htm to be displayed on an htm

  • 6 replies
  • 1 has this problem
  • 75 views
  • Last reply by jscher2000

more options

When creating iframes for htm pages, pdfs work just fine in all versions of Firefox. However, when I construct an iframe for an htm to be displayed on an htm page, the current versions of firefox do not diplay the iframes. Please help?

All Replies (6)

more options

What do you see, if anything -- do you get a blank area where the iframe should be?

If you check the browser console (formerly known as the error console), do you see any errors referring to problems with the framed document? You can open the console by pressing Ctrl+Shift+j, and you can click the CSS button to show or suppress style warnings so you can find the actual errors more easily.

Also, if you see a "shield" icon in the address bar to the left of the URL, it's this: Firefox 23 introduced a new security feature which will block iframes with an HTTP address from displaying in an HTTPS page. This "mixed content blocking" is described in more detail in this article: Mixed content blocking in Firefox

more options

I think you are right. Attached is the screen capture of the blocked mixed content. do you know how I can fix this?

more options

Hi winters_c, is it an option to make all of your content either secure or insecure, and not mix them? Otherwise, users will need to use the "shield" icon to allow it every time they visit the page.

more options

I found the anwser. You guided me correctly... Thank you!

more options

what about the Google Chrome browser? How do I enable the mixed content to be displayed?

more options

Hi winters_c, you wrote:

what about the Google Chrome browser? How do I enable the mixed content to be displayed?

That I do not know, but you might find the answer by searching Google's forum for Chrome: https://productforums.google.com/forum/#!forum/chrome