X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to disable/remove thumbnails?

Posted

I am constantly manually removing the thumbnails of previously visited sites. I am tire of this. Please tell me how to DISABLE the thumbnail feature.

Chosen solution

Attached is the screenshot of my newtab page. It's not showing the images, but is still showing the captions. Does this mean I'm halfway there?

Here are the additions I made to the about:config page browser.pagethumbnails.capturing_disabled userset boolean true pageThumbs.enabled userset boolean false

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Next Generation Java Plug-in 10.40.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.10411.0

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Extensions

  • DownloadTerms 1.0 (cxfnl@nxazbwxrbgsgfqqp.net)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • WebSite Recommendation 1.0.6 (WebSiteRecommendation@weliketheweb.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) 82915G/GV/910GL Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2582
  • adapterDeviceID2:
  • adapterDrivers: ialmrnt5
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 3-23-2006
  • driverDate2:
  • driverVersion: 6.14.10.4543
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'6.1400.1000.4764']
  • numTotalWindows: 2
  • webglRendererMessage: [u'tryNewerDriver', u'6.1400.1000.4764']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: https://www.fastmail.fm/mail/Inbox/?u=84544137
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • extensions.lastAppVersion: 24.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1380871337
  • places.history.expiration.transient_current_max_pages: 53427
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1380871337

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96849 answers

Do you mean the thumbnails that you see on the about:newtab page?

You can create these Boolean prefs on the about:config page to prevent Firefox from generating thumbnails for the about:newtab page.

  • name: browser.pagethumbnails.capturing_disabled with value: true
  • name: pageThumbs.enabled with value: false

You can right-click on the about:config page to open the right-click context menu and choose New > Boolean to create both prefs as a new Boolean type pref.

You need to delete the thumbnails folder in the Firefox profile folder to remove already stored web page thumbnails.

Question owner

browser.pagethumbnails.storage_version;3 That is the ONLY thumbnail reference in my about:config . When I open a new tab, I often get a dozen or so thumbnails, and I can only remove them by clicking the X in each thumbnail. I wish to find a way to DISABLE the thumbnails from generating in the first place.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96849 answers

The prefs that I mentioned are hidden prefs that aren't displayed on the about:config page and have default value in that case.
Like I wrote above, you will have to create new Boolean prefs via the right-click context menu with the names and values that I posted above.

Helpful Reply

Okay, consider me a total dummy. Please tell me each and every step I need to implement, to get this done. I am a good USER, but I am not a programmer. If you tell me exactly what to do, I can do it. Thank you!!!!!

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96849 answers

Helpful Reply

You can right click on the about:config page like you can see in the screenshot on the mozillaZine knowledge base article:

You see a New entry in the right-click context menu that shows three choice for creating a new pref: String, Integer, Boolean.

You need to select the last choice: Boolean

In the dialog that opens you can paste the name of the first pref that you need to create:

browser.pagethumbnails.capturing_disabled

Click OK to proceed to the next dialog where you can select the true value for this pref.

You can repeat this this for the second pref and paste this for the name:

pageThumbs.enabled

Click OK to proceed to the next dialog where you can select the false value for this pref.

Question owner

Thank you VERY much!!!!!!!!!!

) :) :)
cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96849 answers

You're welcome.

Remember that you need to delete the files in the thumbnails folder to remove already stored (created) thumbnails

You can use this button to go to the Firefox profile folder:

Bisclavret 1 solutions 1 answers

I don't know about other versions of Windows, but on XP, the path given in the article to which you linked does not lead to the thumbnails folder. The path in Windows XP to Firefox's thumbnail folder is:

C:\Documents and Settings\[Owner]\Local Settings\Application Data\Mozilla\Firefox\Profiles\z5sep971.default

The above path is the path where the following items are located:

Folder: Cache

Folder: mozilla-media-cache

Folder: OfflineCache

Folder: safebrowsing

Folder: shortcutCache

Folder: startupCache

Folder: thumbnails

File: _CACHE_CLEAN_

File: urlclassifier3.sqlite

File: urlclassifier.pset

The path given in the article for finding and deleting the thumbnails in the thumbnails folder in Windows XP is as follows, and it is wrong:

C:\Documents and Settings\<Windows login/user name>\Application Data\Mozilla\Firefox\Profiles\<profile folder>

The thumbnails folder is not in the profile folder.

Modified by Bisclavret

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96849 answers

You actually need to check the location of the disk cache on the about:cache and go to the parent directory or leave out the trailing Cache.
There you can find the thumbnails folder.

bfloozer 1 solutions 5 answers

This isn't working in Windows 8.1 with Firefox 26.0. There are no stored images there. I've tried changing the browser.newtab.url from about:newtab to about:blank - it doesn't change it. I've tired adding the two new boolean prefs as suggested above - that doesn't work. I can't get rid of the bleeping thumbnails!!!!! It's driving me nuts!!

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96849 answers

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

bfloozer 1 solutions 5 answers

Not sure what you want a screenshot of - the additions to the about:config page or the Thumbnails folder that I found by finding the path from the about:cache page or something else?

"You actually need to check the location of the disk cache on the about:cache and go to the parent directory or leave out the trailing Cache. There you can find the thumbnails folder.

Maybe I didn't completely grok this last post? I went to about:cache, and under Disk Cache Device, I copied the Cache Directory. I then searched for that. I found the Thumbnail folder, but none were in there.

Thanks again!

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96849 answers

If that thumbnails folder is empty then you shouldn't see thumbnails on the about:newtab page.

That is why I'm curious how that new tab page looks in this case.

If you create the pref I mentioned above then the service that manages the thumbnails shouldn't start as well.

bfloozer 1 solutions 5 answers

Chosen Solution

Attached is the screenshot of my newtab page. It's not showing the images, but is still showing the captions. Does this mean I'm halfway there?

Here are the additions I made to the about:config page browser.pagethumbnails.capturing_disabled userset boolean true pageThumbs.enabled userset boolean false

Question owner

This solved my problem! Thank you. I used "Modify" to set the "NewTab" values to Zero. I no longer get the thumbnails. THANK YOU VERY MUCH!

bfloozer 1 solutions 5 answers

Were you able to tell anything by my screenshot? No images, but captions remain...

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96849 answers

you can drag a page like about:blank or another history or bookmark item into the tiles on the about:newtab page to pin such an URI to that tile if you do Not want to see visited web pages.

bfloozer 1 solutions 5 answers

So there's no way to turn off this feature... I'm not feeling any love for Windows 8.1

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96849 answers

You can set another page as the new tab page via the browser.newtab.url pref on the about:config page.
The about:newtab page stays as it is with the 3x3 tiles and visited web pages.