Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Avoid firefox opening 2 tabs on first time

  • 4 replies
  • 2 have this problem
  • 4094 views
  • Last reply by NiteSupport

more options

Hello,

For internal uses at my work place, we use a customized Firefox, All is ok out the fact that the first time we opening customized Firefox on a PC, when no profile folder is existing, firefox open 2 tabs.

And after this first time all is ok, i think this is the "welcome tab". What can i do to avoid this tab opening.

This is our user.js file to overwrite the prefs.js.

If i remove the "user_pref("startup.homepage_welcome_url", "http://10.10.10.11:8008");" It tries to open the mozilla welcome page


user_pref("startup.homepage_override_url", "http://10.10.10.11:8008"); user_pref("startup.homepage_welcome_url", "http://10.10.10.11:8008"); user_pref("javascript.enabled", true); user_pref("app.update.enabled", false); user_pref("browser.startup.homepage", "http://10.10.10.11:8008"); user_pref("accessibility.browsewithcaret", false); user_pref("browser.cache.disk.enable", false); user_pref("browser.popups.showPopupBlocker", false); user_pref("browser.cache.memory.enable", false); user_pref("browser.shell.checkDefaultBrowser", false); user_pref("browser.backspace_action", 2); user_pref("privacy.popups.disable_from_plugins", 0); user_pref("privacy.sanitize.sanitizeOnShutdown", true); user_pref("update_notifications.enabled", false); user_pref("browser.tabs.showSingleWindowModePrefs", true); user_pref("accessibility.browsewithcaret_shortcut.enabled", false); user_pref("plugins.hide_infobar_for_outdated_plugin", true); user_pref("extensions.blocklist.enabled", false); user_pref("browser.newtabpage.enabled", false); user_pref("browser.newtab.url", "http://10.10.10.11:8008"); user_pref("browser.tabs.autoHide", false); user_pref("zoom.minPercent", 100); user_pref("zoom.maxPercent", 100);

Thanks.

Chosen solution

hello NiteSupport, please try to replace those two lines in your user.js file:

user_pref("startup.homepage_override_url", "http://10.10.10.11:8008");
user_pref("startup.homepage_welcome_url", "http://10.10.10.11:8008"); 

with this line instead:

user_pref("browser.startup.homepage_override.mstone", "ignore");
Read this answer in context 👍 2

All Replies (4)

more options

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Chosen Solution

hello NiteSupport, please try to replace those two lines in your user.js file:

user_pref("startup.homepage_override_url", "http://10.10.10.11:8008");
user_pref("startup.homepage_welcome_url", "http://10.10.10.11:8008"); 

with this line instead:

user_pref("browser.startup.homepage_override.mstone", "ignore");
more options

See also:

Note that disabling the memory cache can cause performance issues because Firefox needs some space to cache data (Firefox won't use the disk cache if you clear the cache when you close Firefox, see about:cache)


Note that you can use a mozilla.cfg file in the Firefox program folder to lock prefs or specify new (default) values.

Place a file local-settings.js in the defaults\pref folder where you also find the file channel-prefs.js to specify using mozilla.cfg.

pref("general.config.filename", "mozilla.cfg");

See:

These functions can be used in the mozilla.cfg file:

defaultPref();  // set new default value
pref();         // set pref, but allow changes in current session
lockPref();     // lock pref, disallow changes