Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Right click -> save image keeps saving to wrong location

  • 11 replies
  • 7 have this problem
  • 1155 views
  • Last reply by Question2

more options

I moved my firefox profile over from my old computer.

Now when i do right click -> save image as, it SOMETIMES defaults to C:\Users\test\Documents. Which was my old default location.

I have changed it to C:\Users\Question\Documents on my current computer but it randomly changes back to C:\Users\test\Documents. I cannot find a pattern that causes it to change, but it seems to happen mainly after i restart my computer (not always though).

Can someone please tell me how to get it to change to C:\Users\Question\Documents PERMANENTLY?

All Replies (11)

more options

Hello Question2,

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

Please download the latest version of Firefox.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!

Thank you.

more options

Oh right i forgot the first answer to every problem is "reinstall firefox".

Does anyone have a suggestion that does not involve reinstalling firefox and wiping my profile?

more options

Current Firefox versions remember the download directory based upon the URL, so if the URL changes then the default folder may be chosen if there hasn't been selected a download folder before for that server.

You can disable this feature to remember the download directory via the Boolean pref browser.download.lastDir.savePerSite on the about:config page.

The browser.download.lastDir.savePerSite pref doesn't exist by default (it is a hidden pref), so you need to create it.
Create a new Boolean pref with the name browser.download.lastDir.savePerSite and set the value to false.

If you do not keep changes after a restart or otherwise have problems with preferences, see:

more options

Lets say its a new URL that firefox hasnt encountered before. I right click -> save image as. Which download directory does it go to?

On my old computer, it would always go to my documents, so there were no problems...

more options

Firefox shouldn't be changing the default save location to another Windows account (Question versus test).
That shouldn't be possible unless Firefox is started from that user account.

more options

Well its doing that repeatedly...and fairly random as well.

Is there anything in firefox that defines the default save location?

more options

Using a simple text program take a look at your prefs.js file in your Profile folder for that incorrect preference, and delete that whole line. Then start Firefox.

https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data

more options

There is nothing in my prefs.js file that has the folder of C:\Users\test\Documents though...(at least, right now).

more options

I understand it looks random to you, but did you switch off site-specific path storage as suggested in cor-el's post in case you actually had saved from that domain before but just don't remember? https://support.mozilla.org/en-US/questions/972823#answer-484749

more options

I just did that, but no way to tell if its going to help yet....