X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I set new windows to open my homepage, but new tabs to open blank?

Posted

I have my browser set to restore the previous session when I open Firefox, and new tabs to open blank. With these settings, I used to be able to open new windows and have my homepage load, while keeping the behaviors previously mentioned intact, but when I open a new window now, I get a blank page.

Is there any way to restore the previous behavior, or are all tabs now seen as the same now, whether they're opened as part of new windows or existing windows?

Chosen solution

You must change the string "browser.newtab.url" by clicking twice on it and then write "about:blank"...now the newtab will open with a blank page..To change the homepage will appear in a new window see how to How to set the homepage How to set the home page ~J99 Solved?

Read this answer in context 12

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Shockwave Flash 11.7 r700
  • DivX Web Player version 2.1.0.900
  • npmnqmp 071303000006
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

I have searched in about:config for anything dealing with opening a new window, but nothing I've found is relevant to the problem I've described. I only want my homepage opening when I open a new window (Ctrl+N), and not when I open a new tab (Ctrl+T).
I don't want new tabs opening with content unless I specifically command a page to open in a new tab. I want new windows opening with the homepage unless I specifically command a page to open in a new window.
This behavior was present in previous versions of Firefox. I need to know how to restore it in the current version.

Aniello 75 solutions 633 answers

Helpful Reply

Maybe you are speaking about new tab that you open...try to follow this steps:

# In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear. 
  1. Click I'll be careful, I promise!, to continue to the about:config page.

Then search the string "browser.newtab.url"..what url you see?

Question owner

I want new tabs (Ctrl+T) to open blank, but I want new windows (Ctrl+N) to open in my homepage. I did not make any settings changes before this stopped working. The only changes have been an update to Firefox 24 and just today, the Mac OS installed a security update. The security update may have caused this behavior to change, but I'm not sure.

Aniello 75 solutions 633 answers

Probably the update of firefox have changed some settings...Have you check? On my firefox i change settings and now i can open new tab with blank screen and new windows open my homepage.

Modified by Aniello

Question owner

I've checked the settings, but I'm not seeing anything that specifically applies to new windows and the new page. I have no idea what settings to change.

Aniello 75 solutions 633 answers

Chosen Solution

You must change the string "browser.newtab.url" by clicking twice on it and then write "about:blank"...now the newtab will open with a blank page..To change the homepage will appear in a new window see how to How to set the homepage How to set the home page ~J99 Solved?

Modified by John99

jscher2000
  • Top 10 Contributor
2360 solutions 20907 answers

Helpful Reply

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and change from the default (about:newtab) to about:blank.

You can test immediately by pressing Ctrl+t or clicking the "+" button.

jscher2000
  • Top 10 Contributor
2360 solutions 20907 answers

If the change does not work, one of your extensions might be controlling the new tab page. You can review, configure, disable, and remove most extensions here:

(MAC) Tools menu > Add-ons, on the left side, click the Extensions category

If the change is reverted the next time you start Firefox, a user.js file might be overriding your personal preferences. This article describes how to find and remove that: How to fix preferences that won't save.

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96738 answers

Firefox opens the home page by default in a new window.
So if that new window stays blank then you need to check the home page setting.

Question owner

Thanks, but the problem has already been fixed. That, and I already had the home page set to what I wanted.

Rico64 0 solutions 1 answers

Thank-You Very Much davidkingster! Very easy to understand and exact fix. You're Awesome!

Modified by Rico64

tielfeathers 3 solutions 19 answers

I'm having this problem too, and don't know where to find the string you are talking about. I just want my same tabs to open each time, and when I open a NEW tab, I want it to be blank.

Question owner

To tielfeathers, the fix that worked for me is what is described in the Chosen Solution. Prior to that, you must open a new window or tab and browse to about:config.

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96738 answers

Note tat the about:newtab page can also be disabled and enabled via an icon in the top right corner of that page (pref: browser.newtabpage.enabled).

tielfeathers 3 solutions 19 answers

when I double clicked on that url, a little box came up with a bunch of codes in it and I didn't care change that long url to about:blank in case I was in the wrong spot

Question owner

When you navigate to about:config, there should be a search bar at the top of the page. Type "browser.newtab.url" into that box (or just newtab), then double click on the line with the text "browser.newtab.url" and type "about:blank".

Question owner

Upgrading to Firefox 25.0.1 brought this behavior back. I made no changes from Firefox 24, and opening new windows is again opening blank pages instead of the homepage. "browser.newtab.url" is still set to "about:blank" and "browser.newtabpage.enabled" is true.

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96738 answers

Only a new tab opens with the page as set via the browser.newtab.url pref.
A new window always open with the Home page, so check the home page setting as well (pref: browser.startup.homepage).

If you do not keep changes after a restart or otherwise have problems with preferences, see:

Question owner

I've already checked the Homepage setting. It's set to www.google.com. New windows are not opening with the home page. This behavior only began after I restarted Firefox after a crash today. After opening a new window, I can click 'Home' to open my homepage.

Modified by davidkingster

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96738 answers

If a new window doesn't open with the home page then it is likely that you have an extension that is making this happen.