X
Tap here to go to the mobile version of the site.

Support Forum

Can't get focus to address bar in new tab

Posted

I have tried everything said in previous posts and unfortunately i cant get it to focus the address bar. I have tried uninstalling all adons, restarted in safe mode, this should be like this automatically, but for some reason it isn't. Can i change something in about:config?

Ty

/A.R

I have tried everything said in previous posts and unfortunately i cant get it to focus the address bar. I have tried uninstalling all adons, restarted in safe mode, this should be like this automatically, but for some reason it isn't. Can i change something in about:config? Ty /A.R

Chosen solution

I woke up today and the issue was gone, i have done absolutely nothing since yesterday, so i have no idea why it works, but i does. Thanks everyone for trying!

Sincerely Alex R.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.04

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Are you using the standard Firefox "new tab" page -- the one with 9 thumbnails of frequently/recently visited sites?

Do you have any extensions enabled here:

orange Firefox button (or Tools menu) > Add-ons > Extensions category

If you have any relating to tabs or the new tab page, make sure they are not configured to shift the focus to the page.

Are you using the standard Firefox "new tab" page -- the one with 9 thumbnails of frequently/recently visited sites? Do you have any extensions enabled here: orange Firefox button (or Tools menu) > Add-ons > Extensions category If you have any relating to tabs or the new tab page, make sure they are not configured to shift the focus to the page.

Question owner

i do indeed have the 9 frequently visited sites as new tab. I have nothing like that, and like i said, tried to restart in safe mode, didn't help.

i do indeed have the 9 frequently visited sites as new tab. I have nothing like that, and like i said, tried to restart in safe mode, didn't help.
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

When you open a new tab, either by clicking the + button or pressing Ctrl+t, where is the cursor/focus?

I can't think of any setting in about:config that would shift focus either to or away from the address bar.

When you open a new tab, either by clicking the + button or pressing Ctrl+t, where is the cursor/focus? I can't think of any setting in about:config that would shift focus either to or away from the address bar.
ideato 893 solutions 6250 answers

Hello, usually add-ons (as jscher2000 said) make issue like that !

just an option to do your job without touch the mouse (not really a solution) is to click F6 or Ctrl + L to put the keyboard focus in the address bar, or you can check the next add-on : https://addons.mozilla.org/en-us/firefox/addon/custom-new-tab/

thank you

Hello, usually add-ons (as jscher2000 said) make issue like that ! just an option to do your job without touch the mouse ('''not really a solution''') is to click F6 or Ctrl + L to put the keyboard focus in the address bar, or you can check the next add-on : https://addons.mozilla.org/en-us/firefox/addon/custom-new-tab/ thank you

Question owner

im pressing ctrl + t, but i have tried both, the focus is like nowhere, nothing is focused.

im pressing ctrl + t, but i have tried both, the focus is like nowhere, nothing is focused.

Question owner

ctrl + l works, but thats not what i want to do, i have no addons, like i said. Can anyone pls solve this, its so annoying (stupid mouse, i dont wanna click extra just to type something in my address bar :(. )

ctrl + l works, but thats not what i want to do, i have no addons, like i said. Can anyone pls solve this, its so annoying (stupid mouse, i dont wanna click extra just to type something in my address bar :(. )
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

You might need to reinstall Firefox to repair program files, but first, do you want to try a different new tab page: just a blank page?

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and change from about:newtab to about:blank and OK that change.

You can test immediately with Ctrl+t to see whether that makes any difference.

You might need to reinstall Firefox to repair program files, but first, do you want to try a different new tab page: just a blank page? (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''newtab''' and pause while the list is filtered (3) Double-click the '''browser.newtab.url''' preference and change from ''about:newtab'' to ''about:blank'' and OK that change. You can test immediately with Ctrl+t to see whether that makes any difference.

Question owner

That didn't help unfortunately.

That didn't help unfortunately.
ideato 893 solutions 6250 answers

Any luck if boot the computer in Windows Safe mode with network support (press F8 on the boot screen) ?


thank you

Any luck if boot the computer in [http://windows.microsoft.com/en-hk/windows/start-computer-safe-mode#start-computer-safe-mode=windows-7 Windows Safe mode with network support ](press F8 on the boot screen) ? thank you

Question owner

I just reinstalled windows, so i don't think that is a problem, and like i said, i tried in safe mode for firefox, (that should solve it right? but it didnt.) Just my luck ... thx everyone for trying though.

I just reinstalled windows, so i don't think that is a problem, and like i said, i tried in safe mode for firefox, (that should solve it right? but it didnt.) Just my luck ... thx everyone for trying though.
ideato 893 solutions 6250 answers

Reinstall windows and firefox and the issue still exist ?

'''Reinstall windows and firefox''' and the issue still exist ?
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

My only other thought is that occasionally Firefox behaves strangely with some input devices, such as a wireless mouse or multi-button trackball. If you notice any other issues with mouse behavior such as double-clicks when you only single click, or menus closing instantly after you open them, this might be worth investigating.

Also, if you set your mouse to have the focus follow the mouse pointer position, you might switch that off and see whether it makes any difference.

My only other thought is that occasionally Firefox behaves strangely with some input devices, such as a wireless mouse or multi-button trackball. If you notice any other issues with mouse behavior such as double-clicks when you only single click, or menus closing instantly after you open them, this might be worth investigating. Also, if you set your mouse to have the focus follow the mouse pointer position, you might switch that off and see whether it makes any difference.

Chosen Solution

I woke up today and the issue was gone, i have done absolutely nothing since yesterday, so i have no idea why it works, but i does. Thanks everyone for trying!

Sincerely Alex R.

I woke up today and the issue was gone, i have done absolutely nothing since yesterday, so i have no idea why it works, but i does. Thanks everyone for trying! Sincerely Alex R.
rmancius 0 solutions 1 answers

Hi, I had the same issue. After playing with it for a while I found a remedy that helped for me: I disabled all Extensions, quit and restarted Firefox. The problem was gone: when I opened a new tab with Ctrl+t, the focus was back in the url bar. Then I re-enabled all extensions one-by-one to find out which one caused the problem. But after enabling them all, the problem was still solved. I'm happy not to have to press Ctrl+l anymore :-). I hope this works for you too.

Hi, I had the same issue. After playing with it for a while I found a remedy that helped for me: I '''disabled all Extensions''', quit and restarted Firefox. The problem was gone: when I opened a new tab with Ctrl+t, the focus was back in the url bar. Then I '''re-enabled all extensions one-by-one''' to find out which one caused the problem. But after enabling them all, the '''problem was still solved'''. I'm happy not to have to press Ctrl+l anymore :-). I hope this works for you too.