X
Tap here to go to the mobile version of the site.

Support Forum

Firefox default theme not working on high contrast

Posted

When FF23 upgraded to FF24 the default theme was broken

I usually have white text on black background set for Win8 high contrast theme. It worked fine in FF23

Now the default theme in FF24 is white with white text and the toolbar buttons have black surrounds on white toolbars. The sidebar is unreadable. The toolbar buttons themeselves are OK displaying as pale icons on black.

I have tried to fix by ticking use system colours - no change. Unticked no change.

Safe mode - no change.

Unticked/ticked harware accellaration - no change

I have tried re-installing, plus upgrading for FF25 beta then backdown to FF24.

Hope you can help.

When FF23 upgraded to FF24 the default theme was broken I usually have white text on black background set for Win8 high contrast theme. It worked fine in FF23 Now the default theme in FF24 is white with white text and the toolbar buttons have black surrounds on white toolbars. The sidebar is unreadable. The toolbar buttons themeselves are OK displaying as pale icons on black. I have tried to fix by ticking use system colours - no change. Unticked no change. Safe mode - no change. Unticked/ticked harware accellaration - no change I have tried re-installing, plus upgrading for FF25 beta then backdown to FF24. Hope you can help.

Additional System Details

Installed Plug-ins

  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Shockwave Flash 11.8 r800
  • iTunes Detector Plug-in
  • VLC media player Web Plugin 2.0.6
  • Google Update
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • Foxit Reader Plug-In For Firefox and Netscape
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Citrix Receiver Plugin (Win32)
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-GB/

Extensions

  • about:addons Launcher 1.1 (aboutaddons@about-addons-launcher.org)
  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.9.1 (adblockpopups@jessehakanen.net)
  • Better Gmail 2 1.2 (bettergmail2@ginatrapani.org)
  • Download Manager Tweak 0.9.8 ({F8A55C97-3DB6-4961-A81D-0DE0080E53CB})
  • DownloadHelper 4.9.21 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • DownThemAll! 2.0.16 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • FfChrome 2.2 ({9bc51d13-3849-4541-a69c-da418934ca05})
  • Flagfox 4.2.12 ({1018e4d6-728f-4b20-ad56-37578a4de76b})
  • Flashblock 1.5.17 ({3d7eb24f-2740-49df-8937-200b1cc08f8a})
  • Ghostery 5.0.5beta2 (firefox@ghostery.com)
  • Google/Yandex search link fix 1.4.1 (jid0-XWJxt5VvCXkKzQK99PhZqAn7Xbg@jetpack)
  • IE View 1.5.6 ({6e84150a-d526-41f1-a480-a67d3fed910d})
  • LastPass 2.0.20 (support@lastpass.com)
  • Movable Firefox Button 1.4 (movableAppButton@Merci.chao)
  • NoSquint 2.1.9 (nosquint@urandom.ca)
  • Priv3 0.2 (priv3@icsi.berkeley.edu)
  • Reddit Opener 0.17 (redditopener@johannes-bauer.com)
  • Sidebar Bookmark Selector 3.0 (sidebarBookmarkSelector@alice)
  • Theme Font & Size Changer 7.2 ({f69e22c7-bc50-414a-9269-0f5c344cd94c})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Bitdefender Wallet 1.0 (ffpwdman@bitdefender.com) (Inactive)
  • YouTube Center 1.34.0 (jid1-cwbvBTE216jjpg@jetpack) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 670M
  • adapterDescription2:
  • adapterDeviceID: 0x1213
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 3072
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16581
  • driverDate: 9-12-2013
  • driverDate2:
  • driverVersion: 9.18.13.2723
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 670M Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #000000
  • browser.display.foreground_color: #FFFFFF
  • browser.display.use_document_colors: False
  • browser.display.use_system_colors: True
  • browser.newtab.url: about:blank
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20130917123208
  • browser.startup.homepage: http://www.google.com.au/
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.closeWindowWithLastTab: False
  • browser.tabs.insertRelatedAfterCurrent: False
  • browser.tabs.warnOnClose: False
  • browser.tabs.warnOnOpen: False
  • browser.urlbar.autocomplete.enabled: False
  • browser.zoom.siteSpecific: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 24.0
  • font.size.variable.x-western: 14
  • general.autoScroll: False
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • mousewheel.withcontrolkey.action: 3
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1380009755
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.downloads: False
  • privacy.cpd.extensions-dta: True
  • privacy.cpd.extensions-nosquint: False
  • privacy.cpd.history: False
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1378382181

Misc

  • User JS: No
  • Accessibility: No
Nellus 68 solutions 634 answers

You must follow thi guide: https://support.mozilla.org/en-US/kb/settings-fonts-languages-pop-ups-javascript?esab=a&s=content&r=0&as=s#os=win7&browser=fx23 In this tab you must select on Colors and then check on "Allow pages to choose their own colors, instead of my selections above". By default, Firefox uses the colors specified by the web page author. Disabling this option will force all sites to use your default colors instead.

You must follow thi guide: https://support.mozilla.org/en-US/kb/settings-fonts-languages-pop-ups-javascript?esab=a&s=content&r=0&as=s#os=win7&browser=fx23 In this tab you must select on Colors and then check on "Allow pages to choose their own colors, instead of my selections above". By default, Firefox uses the colors specified by the web page author. Disabling this option will force all sites to use your default colors instead.
John99 971 solutions 13138 answers

Sorry I do not see an answer. I will however add some comments.

In fact you did give system information so I see you prefs and add my comments

  • browser.display.background_color: #000000
    that is black, the default is white,but this seems intentional
  • browser.display.foreground_color: #FFFFFF
    that is white
  • browser.display.use_document_colors: False
  • browser.display.use_system_colors: True

Those seem to be intentional, and will affect the page content.

You seem to have problems with the User Interface display and toolbars. It may be worth resetting your toolbar settings, especially if safemode improves matters see


General information

A standard uninstall and reinstall of Firefox does not change the preferences that you may have changed, so would not necessarily help with this or other issues. (You may need to try a clean reinstall but not just yet)

You could try Firefox's safe mode. That also does not reset preferences but one thing it does change is it disables all addons. I note for instance you are using nosquint, and wonder if that is having any effect on this, although it will not override preferences set already. Other things safemode does include use of the default theme and default toolbar.

The Firefox reset may solve the issue, but other methods are better if you have the time or if you wish to discover the cause of the issue

  1. Read the warnings in the following article first. Note you will lose some information.
  2. You may then wish to close all unnecessary open tabs, and bookmarks the remaining ones. Also bookmark the homesites of all Firefox extensions that you may wish to reinstall after the reset removes them.
  3. See Reset Firefox preferences to troubleshoot and fix problems
  4. Reset Firefox from the button in the troubleshooting page.
    Firefox Button -> Help -> Troubleshooting Information -> [reset]
    Alternatively navigate to about:support for the same page

Carefully creating and using a new profile is a good test and preserves information. For anyone, other than a novice user, it is nearly as quick and easy as the reset IMO.

  1. Use the profile manager see
    Profile Manager - Create, remove, or switch Firefox profiles
  2. Note it is good practice
    • To use only an empty folder for a new profile (the profiles manager's choice should be ok) . This is because deletion removes entire foldersand content. Never nest profiles within one another
  3. NOT to rename profiles. So choose a suitable memorable short new name. e.g. test1-2013. Otherwise because Profiles rename but folders do not it easily becomes confusing
  4. do NOT delete unwanted Profiles just remove shortcuts or links to them. Again this is because mistakes may delete vital information,including passwords and bookmarks.
  5. Those rules may be relaxed once you are able to manually create profiles without using the profile manager until then I suggest taking advice before breaking with good practice.

I can not say I noticed any changes listed in Firefox 24 likely to cause this problem

Sorry I do not see an answer. I will however add some comments. In fact you did give system information so I see you prefs and add my comments *browser.display.background_color: #000000 <br />that is black, the default is white,but this seems intentional *browser.display.foreground_color: #FFFFFF <br /> that is white *browser.display.use_document_colors: False *browser.display.use_system_colors: True Those seem to be intentional, and will affect the page content. * they may be set as Nelus91 explained <br /> [[Settings for fonts, languages, pop-ups, images and JavaScript#w_fonts-colors]]_fonts-colors *You may also view and adjust them (usually in real time without restarts) from ''about:config'' ** see http://kb.mozillazine.org/About:config ** Note it is slightly advanced and may break Firefox, ( for a particular profile <- fixable ) You may get a warning you need to accept. The topbar is a filter. ** and a listing http://kb.mozillazine.org/About:config_entries You seem to have problems with the User Interface display and toolbars.''' It may be worth resetting your toolbar settings,''' especially if safemode improves matters see * http://kb.mozillazine.org/Corrupt_localstore.rdf --------------- ===General information=== A standard uninstall and reinstall of Firefox does not change the preferences that you may have changed, so would not necessarily help with this or other issues. (You may need to try a clean reinstall but not just yet) You could try Firefox's safe mode. That also does not reset preferences but one thing it does change is it disables all addons. I note for instance you are using ''nosquint'', and wonder if that is having any effect on this, although it will not override preferences set already. Other things safemode does include use of the default theme and default toolbar. The Firefox reset may solve the issue, but other methods are better if you have the time or if you wish to discover the cause of the issue # Read the warnings in the following article first. Note you will lose some information. # You may then wish to close all unnecessary open tabs, and bookmarks the remaining ones. Also bookmark the homesites of all Firefox extensions that you may wish to reinstall after the reset removes them. # See [[Reset Firefox preferences to troubleshoot and fix problems]] #Reset Firefox from the button in the troubleshooting page. <br />'''Firefox Button -> Help -> Troubleshooting Information -> [reset]''' <br /> Alternatively navigate to ''about:support'' for the same page Carefully creating and using a new profile is a good test and preserves information. For anyone, other than a novice user, it is nearly as quick and easy as the reset IMO. # Use the profile manager see <br /> [[Use the Profile Manager to create and remove Firefox profiles]] #Note it is good practice #* To '''use only an empty folder''' for a new profile (the profiles manager's choice should be ok) . This is because deletion removes entire foldersand content. Never nest profiles within one another # NOT to rename profiles. So choose a suitable memorable short new name. e.g. test1-2013. Otherwise because Profiles rename but folders do not it easily becomes confusing #do NOT delete unwanted Profiles just remove shortcuts or links to them. Again this is because mistakes may delete vital information,including passwords and bookmarks. # Those rules may be relaxed once you are able to manually create profiles without using the profile manager until then I suggest taking advice before breaking with good practice. I can not say I noticed any changes listed in Firefox 24 likely to cause this problem * http://www.mozilla.org/en-US/firefox/24.0/releasenotes/ and full ([https://bugzilla.mozilla.org/buglist.cgi?bug_status=RESOLVED&bug_status=VERIFIED&bug_status=CLOSED&f1=target_milestone&f2=cf_status_firefox24&o1=anywords&o2=anywords&resolution=FIXED&v1=mozilla24%2C%20Firefox%2024&v2=fixed%2Cverified&order=bug_id&limit=0&list_id=7971455 list])

Question owner

Thanks but the issue is not the web page colours but the toolbar and surround colour (chrome?). I'm using the default but it is white on white for sidebar etc

I have tried safe mode as I said but it does not fix it - so it is unlikely to be an addon.

Thanks but the issue is not the web page colours but the toolbar and surround colour (chrome?). I'm using the default but it is white on white for sidebar etc I have tried safe mode as I said but it does not fix it - so it is unlikely to be an addon.

Modified by Longerhim

Question owner

Thanks I will try resetting the toolbars and then a new separate profile.

I suspect it my be one of the addons as I have a few to help me see the screen. Although the problem remains in safe mode which gives me some doubts.

Thanks I will try resetting the toolbars and then a new separate profile. I suspect it my be one of the addons as I have a few to help me see the screen. Although the problem remains in safe mode which gives me some doubts.

Question owner

It is still broken.

I have tried a new profile.

I have tried FF25 beta.

The toolbar and the sidebar ignore the high contrast colours set by Win8 in the default theme - see the attached image.

Interestingly FF23 is OK - only FF24 and FF25 show this behaviour.

It is still broken. I have tried a new profile. I have tried FF25 beta. The toolbar and the sidebar ignore the high contrast colours set by Win8 in the default theme - see the attached image. Interestingly FF23 is OK - only FF24 and FF25 show this behaviour.

Modified by Longerhim

Question owner

Here is a screenshot of it working - FF23

Here is a screenshot of it working - FF23

Helpful Reply

Firefox 24 has an accessibilty issue for vision impared people.

You cannot use Firefox 24 or Firefox 25 beta with a high contrast black theme on Win 8 64 bit (see the attached images).

The deafult theme becomes unusable (white text on white/silver tabs, menus, sidebar etc).

White text on a black background is easier to see.

It is broken by the upgrade from Firefox 23 to Firefox 24.

This is frustrating as Firefox 23 works correctly.

Safe mode does not fix this.

See the images above.

Firefox 24 has an accessibilty issue for vision impared people. You cannot use Firefox 24 or Firefox 25 beta with a high contrast black theme on Win 8 64 bit (see the attached images). The deafult theme becomes unusable (white text on white/silver tabs, menus, sidebar etc). White text on a black background is easier to see. It is broken by the upgrade from Firefox 23 to Firefox 24. This is frustrating as Firefox 23 works correctly. Safe mode does not fix this. See the images above.
Nellus 68 solutions 634 answers

Normally this happens because of the fact that Internet Explorer and Firefox automatically detects Windows high contrast theme and displays everything in your high contrast color scheme. This overrides all other browser or web page settings, and it affects the Internet Explorer and Firefox interface itself (all menus, windows, and dialog boxes) and the content of any web page you visit.

To fix the issue, change Windows theme to one of the Aero Themes available. The browsers should be back to normal.

For your reference:

Using themes

http://windows.microsoft.com/en-US/windows7/Using-themes

Normally this happens because of the fact that Internet Explorer and Firefox automatically detects Windows high contrast theme and displays everything in your high contrast color scheme. This overrides all other browser or web page settings, and it affects the Internet Explorer and Firefox interface itself (all menus, windows, and dialog boxes) and the content of any web page you visit. To fix the issue, change Windows theme to one of the Aero Themes available. The browsers should be back to normal. For your reference: Using themes http://windows.microsoft.com/en-US/windows7/Using-themes

Question owner

Hi thanks for your reply.

I'm not sure I understand

I want FF24 to use the high contrast theme that is set by Win 8 (high contrast black theme). It is white text on black backgound.

It worked fine (using HC) in FF23 but in FF24 and FF25b it is broken.

The main issue is that the deafult theme it not applying the HC theme.

The buttons become white on black (little black squares) and the text changes to white but the ?chrome? (tabs, menus, surrounds and sidebar) stays silver instead of black. The white text cannot be read - see the above images for an example.

It works fine in non-HC theme and I can apply skins/themes/personas etc to all versions of FF.

But when I use HC it stops working. I only use the default theme.

Firefox 23 behaved correctly with the default theme when using a HC theme. So I expect something is broken in FF24 onwards.

Hi thanks for your reply. I'm not sure I understand I want FF24 to use the high contrast theme that is set by Win 8 (high contrast black theme). It is white text on black backgound. It worked fine (using HC) in FF23 but in FF24 and FF25b it is broken. The main issue is that the deafult theme it not applying the HC theme. The buttons become white on black (little black squares) and the text changes to white but the ?chrome? (tabs, menus, surrounds and sidebar) stays silver instead of black. The white text cannot be read - see the above images for an example. It works fine in non-HC theme and I can apply skins/themes/personas etc to all versions of FF. But when I use HC it stops working. I only use the default theme. Firefox 23 behaved correctly with the default theme when using a HC theme. So I expect something is broken in FF24 onwards.
weirdhamster 0 solutions 3 answers

I have this same issue on Windows 8 with Firefox 24. I tried Firefox 25 beta, which did not fix the problem. Firefox 23 worked great. The background color of the tab colors, navigation toolbar, and other items are a white color and entirely ignores my High Contrast Theme.

Furthermore, I have my text color in my High Contrast Theme as gray, which Firefox picks up and applies to the tab text etc. However, since the background is white, it is impossible to read. See the attached image for the example.

I have this same issue on Windows 8 with Firefox 24. I tried Firefox 25 beta, which did not fix the problem. Firefox 23 worked great. The background color of the tab colors, navigation toolbar, and other items are a white color and entirely ignores my High Contrast Theme. Furthermore, I have my text color in my High Contrast Theme as gray, which Firefox picks up and applies to the tab text etc. However, since the background is white, it is impossible to read. See the attached image for the example.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158934 answers

Note that you are in Private Browsing mode according to the purple mask on the Navigation Toolbar and that can have effect because a persona is applied to the user interface area.

Does this also happen in normal mode?

Note that you are in Private Browsing mode according to the purple mask on the Navigation Toolbar and that can have effect because a persona is applied to the user interface area. Does this also happen in normal mode?
weirdhamster 0 solutions 3 answers

Thanks for your reply! It also happens in normal mode. Also, I have never used a persona in Firefox 23 or 24. When I change to a high contrast theme in Windows, Firefox 23 changes its colors with it (background colors, including the navigation, tabs, etc., go black), but Firefox 24 keeps some background colors as white and simply ignores the high contrast theme. I think this is a bug.

Thanks for your reply! It also happens in normal mode. Also, I have never used a persona in Firefox 23 or 24. When I change to a high contrast theme in Windows, Firefox 23 changes its colors with it (background colors, including the navigation, tabs, etc., go black), but Firefox 24 keeps some background colors as white and simply ignores the high contrast theme. I think this is a bug.

Modified by weirdhamster

FDinolfo 0 solutions 2 answers

Helpful Reply

I'm having this issue as well. Found a side effect of it too. Have a look at the image below. Notice how the highlighter has painted the menu as it's gone by.

Accidentally removed an image. Just re-added it.

I'm having this issue as well. Found a side effect of it too. Have a look at the image below. Notice how the highlighter has painted the menu as it's gone by. Accidentally removed an image. Just re-added it.

Modified by FDinolfo

cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158934 answers

Maybe someone should file a regression bug report about reverse high contrast (i.e white text and black background) being broken in Firefox 24 and later.

Maybe someone should file a regression bug report about reverse high contrast (i.e white text and black background) being broken in Firefox 24 and later.

Modified by cor-el

jscher2000
  • Top 10 Contributor
8790 solutions 71881 answers

The browser.css style sheet applies the white background to the two-column menu when Firefox determines that one of the default Windows themes is in use. I wonder whether the definition of that set of themes might have changed? Or maybe the problem lies somewhere else in the stylesheet?

Users generally can override built-in style rules in either of two ways: (1) create or edit a userChrome.css file, or (2) create rules using the Stylish extension. Something like the following might be sufficient to black out the menu background, but isn't a complete solution:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
#appmenu-popup, #appmenuPrimaryPane, #appmenuSecondaryPane {
  background-color: #000 !important; /* solid black */
}

I haven't tried using a high contrast theme myself (too many other things going on with Windows at the moment...).

The browser.css style sheet applies the white background to the two-column menu when Firefox determines that one of the default Windows themes is in use. I wonder whether the definition of that set of themes might have changed? Or maybe the problem lies somewhere else in the stylesheet? Users generally can override built-in style rules in either of two ways: (1) create or edit a userChrome.css file, or (2) create rules using the Stylish extension. Something like the following might be sufficient to black out the menu background, but isn't a complete solution: @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); #appmenu-popup, #appmenuPrimaryPane, #appmenuSecondaryPane { background-color: #000 !important; /* solid black */ } I haven't tried using a high contrast theme myself (too many other things going on with Windows at the moment...).

Question owner

Back from work ... thanks to everyone who has contributed 8)

I would be willing to 'file a regression bug report' but don't know how.

I had hoped it might be picked up by the devs by me logging the original issue.

I would also be willing to test any fixes in a beta etc

Let me know what I can do as I want this accessibilty bug fixed for everyone as well as myself.

If anyone has any other ideas or fixes they would be welcome.

Back from work ... thanks to everyone who has contributed 8) I would be willing to 'file a regression bug report' but don't know how. I had hoped it might be picked up by the devs by me logging the original issue. I would also be willing to test any fixes in a beta etc Let me know what I can do as I want this accessibilty bug fixed for everyone as well as myself. If anyone has any other ideas or fixes they would be welcome.

Question owner

I have tried the latest beta for FF25b this weekend and it has the same problem.

I would like to log it but don't know how.

Perhaps someone could post it to the twitter support to see if anyone knows how to fix or bring it the attention of the devs.

High contrast default theme is broken in Firefox 24 and up. Worked in FF23. #firefox #accessibility #bugs # support http://mzl.la/161nD1o

I have tried the latest beta for FF25b this weekend and it has the same problem. I would like to log it but don't know how. Perhaps someone could post it to the twitter support to see if anyone knows how to fix or bring it the attention of the devs. High contrast default theme is broken in Firefox 24 and up. Worked in FF23. #firefox #accessibility #bugs # support http://mzl.la/161nD1o

Modified by Longerhim

Question owner

Small url http://mzl.la/161nD1o
weirdhamster 0 solutions 3 answers

I also just updated to Thunderbird v24, which has the same bug as Firefox v24. I had to revert to v23 in Thunderbird as well. I really hope these bugs can be filed soon and fixed, as I may have to use other software otherwise.

I also just updated to Thunderbird v24, which has the same bug as Firefox v24. I had to revert to v23 in Thunderbird as well. I really hope these bugs can be filed soon and fixed, as I may have to use other software otherwise.

Question owner

I have just upgraded to the latest release, Firefox 25, and the problem still occurs.

This remains an accessibilty issue. High contrast black windows theme is broken on the fire firefox default theme.

I have also tried Firefox 26 beta and it's broken too.

FF23 worked fine in high contrast black so not sure why Firefox 24, Firefox 25 and Firefox 26 beta are not working in high contrast mode.

I also upgraded to Win 8.1 - that did not change anything.

I have just upgraded to the latest release, Firefox 25, and the problem still occurs. This remains an accessibilty issue. High contrast black windows theme is broken on the fire firefox default theme. I have also tried Firefox 26 beta and it's broken too. FF23 worked fine in high contrast black so not sure why Firefox 24, Firefox 25 and Firefox 26 beta are not working in high contrast mode. I also upgraded to Win 8.1 - that did not change anything.