X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 24.0 keeps crashing

Posted

After Firefox auto updated to version 24.0, it has been consistently crashing. I tried unchecking "Use hardware acceleration when available" and making javascript.options.baselinejit.content, javascript.options.baselinejit.chrome, and javascript.options.ion.content false but that did not solve my problem. I don't want to have to switch to a different browser but I can't get anything done with how often Firefox is crashing.

bp-886eb5d0-cf86-412b-a1f6-747282130919 bp-0e9e5bd4-1f9b-4e61-88d0-c94002130919 bp-e4a92dc8-5bc0-479e-9b96-9ee072130919 bp-0f1b04ae-b6b1-4058-9558-a7ef32130918 bp-1c984e4c-6556-4294-9a0f-fa53f2130918

Chosen solution

Deserin, Apologies, this is your own thread!

You have already tried turning off JS compilers and hardware acceleration, but are crash free in Firefox's safe mode. It is probably some extension or toolbar,and in fact we know from other threads that Norton related software has been causing Firefox 24 crashes and you have Norton software per your system information aside.

Sorry I missed that. It will almost certainly be he cause of your crashes. Note the core Norton AV software will continue to function and protect your system. Disable the other Norton Software. Note also that Norton usually synchronises update with Firefox Releases and so it is usually expected that the software only needs updating.

At present there is a known problem see

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.5.3.14917
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Amazon MP3 Downloader Plugin 1.0.17
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • npmnqmp 989898989877
  • npybrowserplus_2.4.17
  • Yahoo Application State Plugin version 1.0.0.7
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b})
  • Norton Toolbar 2013.4.3.4 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62})
  • Norton Vulnerability Protection 12.0.0.380 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Yahoo! Toolbar 2.5.9.20130418100420 ({635abd67-4fe9-1b23-4f01-e679fa7484c1})
  • Move Media Player 7 (moveplayer@movenetworks.com) (Inactive)
  • Skype Click to Call 6.9.0.12585 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Mobile Intel(R) 4 Series Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2a42
  • adapterDeviceID2:
  • adapterDrivers: igxprd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 10-31-2011
  • driverDate2:
  • driverVersion: 6.14.10.5390
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Mobile Intel(R) 4 Series Express Chipset Family Direct3D9 vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.search.param.yahoo-fr: chrf-ytbm
  • browser.search.param.yahoo-fr-cjkt: chrf-ytbm
  • browser.search.param.yahoo-type: ${8}
  • browser.startup.homepage: www.msn.com
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.onTop: False
  • dom.max_chrome_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 24.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1379551525
  • places.history.expiration.transient_current_max_pages: 92912
  • places.history.expiration.transient_optimal_database_size: 148658420
  • places.last_vacuum: 1300494353
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1378323390

Misc

  • User JS: Yes
  • Accessibility: No
Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please report back soon.

Question owner

I tried running Firefox in Safe Mode last night and didn't have any crashes. I will try to run it in Safe Mode for a longer time soon and see if anything happens. I will post with an update once I have done that.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

please run a full scan of your system with different security tools like the free version of malwarebytes and adwcleaner.

in case you have trusteer rapport installed on your pc, please update it to the latest version available since it is also known to cause the exact same type of crashes as you're experiencing.

fahad19 0 solutions 6 answers

I also installed firefox 24.0 on windows 8 . While I was looking for solutions on how to speed up firefox, I unchecked the "Use hardware acceleration when available" option. When restarted and logged in linkedin and facebook, the system hangs. Now I am restarting the system windows 8 and its taking a century to reboot , although windows 8 is updated and there is no plugin in firefox , every plugin/addon is disabled. Firefox 24.0 crashes especially when I log into Linkedin and facebook.

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hello fahad19, your problem is sounding quite different from that of the topic owner - please open a new question for your issue and include the troubleshooting information and the latest few crash ids - this will make troubleshooting your issue & hopefully finding a solution much easier!
thank you

fahad19 0 solutions 6 answers

ok I'll open a new thread. Just for the record, I restarted firefox in safe mode with all plugins disabled and checked back the "Use hardware acceleration" , and when i opened the linked in and facebook login pages, the same thing happened. Now restarting windows 8 again . This is very painful .

Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

If no crashes are occurring in Firefox's Safe Mode, than the issue is caused by an add-on, plugin, theme or Firefox setting.

You can try trail-and-error for troubleshooting add-ons. Just disable one extension and restart Firefox. If that one doesn't fix the issue, enable it and try another add-on.

Please make sure that all of your plugins are up-to-date. This can be done by using the Mozilla Plugin Check.

Please report back soon.

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96836 answers

In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • default toolbar layout is used (localstore-safe.rdf)
  • Javascript JIT compilers are disabled (javascript.options.*jit)
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected
fahad19 0 solutions 6 answers

Hi , I think i am having a problem with windows 8, the same thing happened with IE and chrome . I have tried the safe mode option as well, still the same things happen. all plugins are disabled and when Linkedin or Facebook login page appears it just hangs the entire system.

I tried updating windows 8 but now its reverting the changes. If it reverts the changes i'll give a try to nightly and check but this is going really painful with windows 8. If this keeps happening, i'll just install windows 7 again.

Modified by fahad19

Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

@ fahad19

If you have tried all of the above steps and still haven't solved the issue, please consider creating a new thread with the specifics of your issue. This will ensure that you will receive customized and accurate support based upon your issue.

Helpful Reply

I am trying Firefox in Safe Mode today so we'll see if I have any crashes. I haven't had as frequent of crashes the past couple days as when I first downloaded 24.0 but I am still getting daily crashes. The crashes usually occur when I am using Google Images or Google Maps. However, I have left Firefox open with just a few tabs up and been away from the computer for a few hours and come back to a crashed Firefox.

Question owner

Here are the crash reports from today and yesterday:

bp-673d67eb-0804-4ec2-b743-44b892130921 bp-e2cb82ac-e0f6-4568-9eef-7e5362130921 bp-293fa4f6-8631-4b1f-bd59-ff6fa2130920

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8032 answers

Please start your own thread then post back here to confirm you have done that. That makes it much easier to give you the correct advice, and anyone who wishes may follow your progress.

Please
  1. Use this special quick direct link to start your own thread.
  2. Follow the prompts to include full troubleshooting information when you write the question
  3. In the new thread
    • Say whether you still get crashes in Firefox's safemode
    • see Troubleshoot Firefox issues using Safe Mode
    • If you do get crashes please post the new Crash IDs
    • Also say whether you use any Norton software or Trusteer Rapport.

Question owner

Firefox did not crash while it was in Safe Mode.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8032 answers

Chosen Solution

Deserin, Apologies, this is your own thread!

You have already tried turning off JS compilers and hardware acceleration, but are crash free in Firefox's safe mode. It is probably some extension or toolbar,and in fact we know from other threads that Norton related software has been causing Firefox 24 crashes and you have Norton software per your system information aside.

Sorry I missed that. It will almost certainly be he cause of your crashes. Note the core Norton AV software will continue to function and protect your system. Disable the other Norton Software. Note also that Norton usually synchronises update with Firefox Releases and so it is usually expected that the software only needs updating.

At present there is a known problem see

Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

Since Firefox didn't crash while in Safe Mode, it is an add-on causing the issue.

Use trial and error to figure out which add-on is causing the issue.

  1. Disable an add-on
  2. Restart Firefox
  3. If the issue occurs, enable the disabled add-on then restart from step 1

Please report back soon.

Question owner

Disabling the Norton toolbar did the trick. Thanks everyone!

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8032 answers

Glad we helped & that it is working. Thanks for posting back.

I see on the Norton forum thread has now reached 9 pages but it is getting attention from their developers and there is mention of news soon, with a fix being tested.


For forum cross referencing purposes

  • Some of your Reports for Crash IDs
    1. bp-0e9e5bd4-1f9b-4e61-88d0-c940021309194
      bp-e4a92dc8-5bc0-479e-9b96-9ee072130919 &
      bp-0f1b04ae-b6b1-4058-9558-a7ef32130918
    2. bp-886eb5d0-cf86-412b-a1f6-747282130919 &
      bp-1c984e4c-6556-4294-9a0f-fa53f2130918
    3. bp-673d67eb-0804-4ec2-b743-44b892130921
  • Crash signatures
    1. js::GCMarker::processMarkStackTop(js::SliceBudget&)
    2. ScanRope
    3. XPC_WN_NoHelper_Trace
  • Includes related bugs
    1. Bug 719114 - Firefox Crash @ js::GCMarker::processMarkStackTop
      Bug 817342 !
    2. Bug 668583 NEW --- crash @ js::gc::ScanRope
    3. Bug 752845 NEW --- Crash in XPC_WN_NoHelper_Trace

There are other threads where Norton software is involved, and possibly additional crash signatures. ( edit includes thread /questions/971603 )

Modified by John99

JPpsew8Le4CI 0 solutions 2 answers

Hi guys

Good it got fixed, a little note on Firefox not working in safe mode is add-on related. My FireFox did crash over and over, and in my case it did not always work in safe mode either. After several days testing, it seems to be one or more of the Updates in Windows Update as of late the makes this happen. Simply uninstalling those fixed the problem.