Search Support

Downloads do not appear in assigned folder

  • 14 replies
  • 11 have this problem
  • 14280 views
  • Last reply by jscher2000

more options

FF 23.0.1 Windows XP.

I can download fine and they show up in the little window on Firefox, but they are not being saved to the My Documents - Downloads folder, which is where I assigned them to go in Tools-Options-General.

Since I'm on XP, there are no User files so I can't look in Users/XXX/Temp/Appdata or any of those locations.

I can double click on the downloaded file in the little Firefox window and the file opens, so I know they are saved somewhere on my computer, but where????

Chosen solution

The download panel and the download history both should have the icon (see attached screen shot).

However, I noticed you have an extension named Open Download2. This might change the way downloads work (I haven't tried it myself). You could try disabling it and see whether that affects the dialogs.

Another way to find a PDF is to use File > Properties or File > Document Properties from inside Adobe Reader.


I'm not sure what directions you are following for a LOCAL folder. That might be for Windows Vista and later. On Windows XP, perhaps you want to look in the Local Settings folder? One way to locate it would be to access the Windows TEMP folder and navigate upwards from there. You can type or paste the following into the Windows Explorer address bar, or the Start > Run dialog, and then press Enter:

%TEMP%

If you choose Open instead of Save in the Open/Save/Cancel dialog, then Firefox will use the TEMP folder.

Read this answer in context 👍 1

All Replies (14)

more options

That's strange. If you use the icon toward the right side of the download list to "Open Containing Folder" can you discover the true location?

By the way, these are roughly equivalent:

Vista-7-8: C:\Users\username\

Windows XP: C:\Documents and Settings\username\

In both cases, various folders and files are hidden by default. If you don't see Application Data, for example, check out this article: http://www.microsoft.com/resources/do.../win_fcab_show_file_extensions.mspx

Modified by jscher2000

more options

There is no icon toward the right side of the download list to "Open Containing Folder". There is just a list of the downloaded files.

There is no LOCAL folder in C:\Documents and Settings\username\

Note: Just found out some of the files are appearing in the Downloads folder - a .txt file I downloaded today made it there, but all the pdf's on the list are not in the folder.

Where are they?

more options

Chosen Solution

The download panel and the download history both should have the icon (see attached screen shot).

However, I noticed you have an extension named Open Download2. This might change the way downloads work (I haven't tried it myself). You could try disabling it and see whether that affects the dialogs.

Another way to find a PDF is to use File > Properties or File > Document Properties from inside Adobe Reader.


I'm not sure what directions you are following for a LOCAL folder. That might be for Windows Vista and later. On Windows XP, perhaps you want to look in the Local Settings folder? One way to locate it would be to access the Windows TEMP folder and navigate upwards from there. You can type or paste the following into the Windows Explorer address bar, or the Start > Run dialog, and then press Enter:

%TEMP%

If you choose Open instead of Save in the Open/Save/Cancel dialog, then Firefox will use the TEMP folder.

more options

You can also right-click an entry in the Downloads drop-down list (Library and icon on the Navigation Toolbar) to see those menu items to open the containing folder.

more options

What is the "Library and icon on the Navigation Toolbar".

I don't see anything like that.

more options

The Library is the Bookmarks/History Manager (History > Show All History).

The icon on the Navigation Toolbar that I meant is the Download toolbar icon that shows as a Down arrow that turn to green if there are downloads that haven't been viewed yet.
Show All Downloads in that drop-down list opens the History manager with the Downloads folder selected.

more options

Sorry if my screenshot was confusing, I moved my download arrow to the Add-on bar. By default, it appears on the main Navigation Toolbar.

To open your download history, you also can use the keyboard shortcut Ctrl+j (or History>Show All History and switch categories by clicking Downloads in the left pane).

more options

Open Download2 just changes it back to the older way of handling downloads. I couldn't stand the flashing green arrow all the time.

I opened the PDF and clicked on File-Properties and it did point to the storage location, which is C:\Documents and Settings/<username>/Local Settings/Temp - all the PDF's I've downloaded over the past few months are in there. Not sure why they won't go to the My Docs/Downloads folder, but at least I know where to find them now. I put the path on a sticky note on my board so I don't have to memorize it.

So yeah, solved good enough, thanks.

more options

Hmmm, I don't think the Windows TEMP folder is a safe location for files you want to keep, since Windows and other software may clean it from time to time. If it's not too much hassle, I recommend moving them to a better place.

Also, if that's Firefox's default, I suggest changing it in the Options dialog: Startup, home page, tabs, and download settings. (Or if Open Download2 has its own setting for this, you would update that instead or in addition.)

more options

I already have that setting pointing to my Downloads folder in My Docs, but for some reason the PDF's are not going there.

more options

It is possible that anti-virus software is corrupting downloaded files or is interfering otherwise.

Try to disable the real-time (live) scanning of files in your anti-virus software temporarily to see if that makes downloading work.

See:

more options

It's not my anti-virus. I think it's a problem with Adobe Reader.

When I click on a PDF file on the Internet, it starts a download, even though I did not request it to download. The little download window opens and I can see the progress.

When it's done I double-click on the file in the little Firefox download window and the PDF opens so I can read it.

The file stays in the list in the Firefox download window unless I "Clear All" or "Remove" the individual file.

I want all downloads including these PDF's to go to the My Documents - Downloads folder, not the temporary folder it's currently going to.

How do I do that?

more options

Files that will be passed to an external program will be stored in the OS temp folder, so that might happen in your case.

Is the built-in PDF viewer enabled (pdfjs.disabled pref = true)?

You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu.

See also:

You can also try to delete the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

more options

If you chose the "Use Adobe Reader" setting, I think that might bypass the downloads folder. You might need to choose Save or Always Ask.