X
Tap here to go to the mobile version of the site.

Support Forum

No Audio on Web Pages (cannot play audio on Tumblr, audio clips in messages on facebook play but you hear nothing, etc).

Posted

I have already gone through the processes here: http://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues Which helped a single issue, when firefox stopped playing audio for me period. I can now get audio on youtube videos, after a lot of updating/fiddling with my add-ons.

But I cannot get audio elsewhere, and it's not my computer as on Chrome, I do not have these problems. Audio post on tumblr will not play, and facebook audio clips will not, along with it not even making the new message ping sound. I've run out of troubleshooting options to help.

Any and all input would be grateful - this sound problem initially started some time ago, and the inability to fix it is what made me move to chrome. Now that I've come back and tried to fix the problem, with some success, I'd love to finish fixing said problem.

I have already gone through the processes here: http://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues Which helped a single issue, when firefox stopped playing audio for me period. I can now get audio on youtube videos, after a lot of updating/fiddling with my add-ons. But I cannot get audio elsewhere, and it's not my computer as on Chrome, I do not have these problems. Audio post on tumblr will not play, and facebook audio clips will not, along with it not even making the new message ping sound. I've run out of troubleshooting options to help. Any and all input would be grateful - this sound problem initially started some time ago, and the inability to fix it is what made me move to chrome. Now that I've come back and tried to fix the problem, with some success, I'd love to finish fixing said problem.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.5.3.14917
  • Google Update
  • 5.1.20513.0
  • DivX Web Player version 2.0.3.4
  • Wacom Dynamic Link Library

Application

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0.1/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • ShopperReports 3.0.517.0 (ShopperReports@ShopperReports.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 7050 / NVIDIA nForce 620i
  • adapterDescription2:
  • adapterDeviceID: 0x07e5
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvd3dum
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 1-31-2013
  • driverDate2:
  • driverVersion: 9.18.13.783
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 7050 / NVIDIA nForce 620i)
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.resume_from_crash: False
  • browser.startup.homepage: http://en-US.start3.mozilla.com/firefox?client=firefox-a&rls=org.mozilla:en-US:official
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 23.0.1
  • keyword.URL: http://slirsredirect.search.aol.com/redirector/sredir?sredir=2706&invocationType=tb50-ff-aim-ab-en-us&tb_uuid=100000000000000002&tb_oid=02-05-2010&tb_mrud=02-05-2010&query=
  • network.cookie.prefsMigrated: True
  • network.protocol-handler.warn-external.dnupdate: False
  • places.history.expiration.transient_current_max_pages: 73800
  • places.last_vacuum: 1361743294
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.flash: 2
  • plugin.state.java: 2
  • plugin.state.np32dsw: 0
  • plugin.state.npamazonmp3downloaderplugin: 0
  • plugin.state.npctrl: 2
  • plugin.state.npdeployjava: 0
  • plugin.state.npdivx: 2
  • plugin.state.npgoogletalk: 2
  • plugin.state.npgoogleupdate: 2
  • plugin.state.npgtpo3dautoplugin: 2
  • plugin.state.npitunes: 0
  • plugin.state.npnxgameus: 0
  • plugin.state.npo1d: 2
  • plugin.state.nppdf: 0
  • plugin.state.npqtplugin: 2
  • plugin.state.npwacom: 2
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: Yes
  • Accessibility: No
Waka_Flocka_Flame 441 solutions 5048 answers

Reset firefox prefrences (will keep bookmarks etc.).

Or reset all the below values to defualt in about:config.

plugin.importedState: True plugin.state.flash: 2 plugin.state.java: 2 plugin.state.np32dsw: 0 plugin.state.npamazonmp3downloaderplugin: 0 plugin.state.npctrl: 2 plugin.state.npdeployjava: 0 plugin.state.npdivx: 2 plugin.state.npgoogletalk: 2 plugin.state.npgoogleupdate: 2 plugin.state.npgtpo3dautoplugin: 2 plugin.state.npitunes: 0 plugin.state.npnxgameus: 0 plugin.state.npo1d: 2 plugin.state.nppdf: 0 plugin.state.npqtplugin: 2 plugin.state.npwacom: 2

Also if you attempt the first idea, delete the user.js file too.

Reset firefox prefrences (will keep bookmarks etc.). * [[Reset Firefox preferences to troubleshoot and fix problems]] Or reset all the below values to defualt in about:config. plugin.importedState: True plugin.state.flash: 2 plugin.state.java: 2 plugin.state.np32dsw: 0 plugin.state.npamazonmp3downloaderplugin: 0 plugin.state.npctrl: 2 plugin.state.npdeployjava: 0 plugin.state.npdivx: 2 plugin.state.npgoogletalk: 2 plugin.state.npgoogleupdate: 2 plugin.state.npgtpo3dautoplugin: 2 plugin.state.npitunes: 0 plugin.state.npnxgameus: 0 plugin.state.npo1d: 2 plugin.state.nppdf: 0 plugin.state.npqtplugin: 2 plugin.state.npwacom: 2 Also if you attempt the first idea, delete the user.js file too.

Question owner

I tried the first one, and reset everything that way - still no luck.

I'd try your second suggestion but all I can find is about:buildconfig and frankly, I'm not sure how to go about doing what you're suggesting there. I'll admit I'm not the most tech savvy.

I tried the first one, and reset everything that way - still no luck. I'd try your second suggestion but all I can find is about:buildconfig and frankly, I'm not sure how to go about doing what you're suggesting there. I'll admit I'm not the most tech savvy.
cor-el
  • Top 10 Contributor
  • Moderator
12922 solutions 118515 answers

If you have reset Firefox then all pref setting are set the default, so you need not change them anymore on the about:config page.


Did you check the volume setting in the Windows volume mixer (click volume icon to Windows taskbar)?

Try to clear the Flash local storage and settings.

  • Windows Control Panel > Flash Player > Storage: Local Storage Settings
    • Remove a specific domain: Local Storage Settings by site
    • Remove all domains: Delete All and Delete Data

Flash Website Storage Settings panel:

Global Storage Settings Panel:

If you have reset Firefox then all pref setting are set the default, so you need not change them anymore on the <b>about:config</b> page. ---- Did you check the volume setting in the Windows volume mixer (click volume icon to Windows taskbar)? Try to clear the Flash local storage and settings. *Windows Control Panel > Flash Player > Storage: Local Storage Settings **Remove a specific domain: Local Storage Settings by site **Remove all domains: Delete All and Delete Data Flash Website Storage Settings panel: *http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager07.html Global Storage Settings Panel: *http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager03.html
Waka_Flocka_Flame 441 solutions 5048 answers

If you have reset Firefox then all pref setting are set the default, so you need not change them anymore on the about:config page.

Yes i understand, I provided the about:config solution in case the user didnt want to lose the rest of the prefs.

''If you have reset Firefox then all pref setting are set the default, so you need not change them anymore on the about:config page.'' Yes i understand, I provided the about:config solution in case the user didnt want to lose the rest of the prefs.

Question owner

Yes, I checked the windows volume mixer - multiple times, to be safe. It's certainly not the issue, hah.

And I just tried both of those, and checked afterwards - still no sound.

Yes, I checked the windows volume mixer - multiple times, to be safe. It's certainly not the issue, hah. And I just tried both of those, and checked afterwards - still no sound.
Waka_Flocka_Flame 441 solutions 5048 answers

Have you tried resetting the prefs?

Is there Mixed Content on the page being blocked?

If so you need a addon to toggle that pref.

Have you tried resetting the prefs? * [[Reset Firefox preferences to troubleshoot and fix problems]] Is there Mixed Content on the page being blocked? * [[How does content that isn't secure affect my safety?]] If so you need a addon to toggle that pref. * https://addons.mozilla.org/en-US/firefox/addon/toggle-mixed-active-content/

Question owner

Yes, I've reset the prefs when you first suggested it. And no, there doesn't appear to be any mixed content being blocked on any of the pages I'm checking, so I don't think that's the problem, either.

Yes, I've reset the prefs when you first suggested it. And no, there doesn't appear to be any mixed content being blocked on any of the pages I'm checking, so I don't think that's the problem, either.
cor-el
  • Top 10 Contributor
  • Moderator
12922 solutions 118515 answers

Did you try to clear the Flash local settings like I wrote above?

Did you try to clear the Flash local settings like I wrote above?

Question owner

Yes, as I said after also rechecking the volume mixer, I tried that as well. ):

Yes, as I said after also rechecking the volume mixer, I tried that as well. ):
Kadir Topal
  • Administrator
  • Moderator
26 solutions 188 answers

Hi Brogan, is your Flash player up to date? You can check that easily by following this link: Plugin checker

Hi Brogan, is your Flash player up to date? You can check that easily by following this link: [https://www.mozilla.org/en-US/plugincheck/ Plugin checker]
cor-el
  • Top 10 Contributor
  • Moderator
12922 solutions 118515 answers
See also: *http://www.adobe.com/software/flash/about/ *http://helpx.adobe.com/flash-player/kb/find-version-flash-player.html