X
Tap here to go to the mobile version of the site.

Support Forum

Java WILL NOT work. I cant read my emails. I cannot activate Javascript.

Posted

Somehow, someway my Java, Javascript IS Not working in Firefox. Ive tried going back to all original settings and that didnt work. Ive installed and re-installed Java twice, that didnt work. Ive gone to my control panel and add/remove and java is there so I know its on my computer. But no matter what I do I cant open or start it. And I cant read ANY email without it. videos dont work, many websites arent working right either. :( I just followed These instructions http://www.enable-javascript.com/ But I dont have the box/option of checking/unchecking Javascript Under the "Options" tab. I did system restore twice for two different dates and that didnt work either. U have WIndows Vista Home premium. There is nothing in my Add Ons about Java. Emails & videos and all websites works fine in Chrome & Internet Explorer. Please someone help. I LOVE Firefox. But it is useless to me like this. Help!!

Somehow, someway my Java, Javascript IS Not working in Firefox. Ive tried going back to all original settings and that didnt work. Ive installed and re-installed Java twice, that didnt work. Ive gone to my control panel and add/remove and java is there so I know its on my computer. But no matter what I do I cant open or start it. And I cant read ANY email without it. videos dont work, many websites arent working right either. :( I just followed These instructions http://www.enable-javascript.com/ But I dont have the box/option of checking/unchecking Javascript Under the "Options" tab. I did system restore twice for two different dates and that didnt work either. U have WIndows Vista Home premium. There is nothing in my Add Ons about Java. Emails & videos and all websites works fine in Chrome & Internet Explorer. Please someone help. I LOVE Firefox. But it is useless to me like this. Help!!

Chosen solution

Also... your system information (thank you for including that) shows that you have a user.js file in your settings folder (also known as your Firefox profile folder). This file can override your settings every time you restart Firefox and you probably want to remove it. Please see this article for tips on that: How to fix preferences that won't save.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.57 Safari/537.36

More Information

Application Basics
Name
Firefox
Version
23.0.1
User Agent
Mozilla/5.0 (Windows NT 6.0; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
CleanPrint
4.7.0
true
cleanprint@formatdynamics.com
Tab Mix Plus
0.4.1.0
true
{dc572301-7619-498c-a57d-39143191b318}
TinEye Reverse Image Search
1.1
true
tineye@ideeinc.com
Yahoo! Toolbar
2.5.9.20130418100420
true
{635abd67-4fe9-1b23-4f01-e679fa7484c1}
HP Smart Web Printing
4.60
false
smartwebprinting@hp.com
Microsoft .NET Framework Assistant
0.0.0
false
{20a82645-c095-46ed-80e3-08825760534b}
Norton IPS
3.0
false
{BBDA0591-3099-440a-AA10-41764D9DB4DB}
Norton Toolbar
2010.9.0.6
false
{2D3F3651-74B9-4795-BDEC-6DA2F431CB62}
Tidy Network
5.0
false
tidynetwork@tidynetwork
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.startup.homepage
www.yahoo.com
browser.startup.homepage_override.buildID
20130814063812
browser.startup.homepage_override.mstone
23.0.1
browser.tabs.loadInBackground
false
dom.mozApps.used
true
extensions.lastAppVersion
23.0.1
javascript.enabled
false
keyword.URL
http://search.conduit.com/ResultsExt.aspx?ctid=CT3309350&SearchSource=2&CUI=UN98159538592423507&UM=2&q=
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1377778199
places.history.expiration.transient_current_max_pages
103956
plugin.disable_full_page_plugin_for_types
application/pdf
plugin.importedState
true
privacy.sanitize.migrateFx3Prefs
true
storage.vacuum.last.index
1
storage.vacuum.last.places.sqlite
1377299210
user.js Preferences
Your profile folder contains a
user.js file, which includes preferences that were not created by Firefox.
Graphics
Adapter Description
NVIDIA GeForce 6150SE nForce 430
Adapter Drivers
nvd3dumx,nvd3dum nvwgf2umx,nvwgf2um
Adapter RAM
128
Device ID
0x03d0
Direct2D Enabled
Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.
DirectWrite Enabled
false (7.0.6002.23097)
Driver Date
3-8-2009
Driver Version
7.15.11.8214
GPU #2 Active
false
GPU Accelerated Windows
0/1 Basic Blocked for your graphics driver version. Try updating your graphics driver to version 182.65 or newer.
Vendor ID
0x10de
WebGL Renderer
Blocked for your graphics driver version. Try updating your graphics driver to version 182.65 or newer.
AzureCanvasBackend
skia
AzureContentBackend
none
AzureFallbackCanvasBackend
cairo
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.10
4.10
NSS
3.15 Basic ECC
3.15 Basic ECC
NSSSMIME
3.15 Basic ECC
3.15 Basic ECC
NSSSSL
3.15 Basic ECC
3.15 Basic ECC
NSSUTIL
3.15
3.15

jscher2000
  • Top 10 Contributor
3003 solutions 27892 answers

Helpful Reply

Sorry for the confusion, but JavaScript and Java are not really related. The Java plugin is used by some sites for games or scientific applets, but it isn't necessary to runs the kinds of scripts that appear on most site. JavaScript is handled by Firefox itself.

You can access the global on/off switch for JavaScript using Firefox's about:config preferences editor. This is a change in Firefox 23, so that website will need to be updated.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste java and pause while the list is filtered

(3) If javascript.enabled is bold, says "user set" and "false", double-click it to re-enable JavaScript.

There are some add-ons that create a toolbar button for this if you think you might want to switch JavaScript off and on regularly. Otherwise, you can keep this post handy for future reference.

Sorry for the confusion, but JavaScript and Java are not really related. The Java plugin is used by some sites for games or scientific applets, but it isn't necessary to runs the kinds of scripts that appear on most site. JavaScript is handled by Firefox itself. You can access the global on/off switch for JavaScript using Firefox's about:config preferences editor. This is a change in Firefox 23, so that website will need to be updated. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box that appears above the list, type or paste '''java''' and pause while the list is filtered (3) If '''javascript.enabled''' is bold, says "user set" and "false", double-click it to re-enable JavaScript. There are some add-ons that create a toolbar button for this if you think you might want to switch JavaScript off and on regularly. Otherwise, you can keep this post handy for future reference.
jscher2000
  • Top 10 Contributor
3003 solutions 27892 answers

Chosen Solution

Also... your system information (thank you for including that) shows that you have a user.js file in your settings folder (also known as your Firefox profile folder). This file can override your settings every time you restart Firefox and you probably want to remove it. Please see this article for tips on that: How to fix preferences that won't save.

Also... your system information (thank you for including that) shows that you have a user.js file in your settings folder (also known as your Firefox profile folder). This file can override your settings every time you restart Firefox and you probably want to remove it. Please see this article for tips on that: [[How to fix preferences that won't save]].

Question owner

Jscher2000 I Love You!! well ok not really LOL But you rock Buddy. that worked. Thank You!! :D

I followed the instructions and deleted the file you said. I also noticed a profile.js file. I should keep that one?

Again Thank You very much. :)

John

Jscher2000 I Love You!! well ok not really LOL But you rock Buddy. that worked. Thank You!! :D I followed the instructions and deleted the file you said. I also noticed a profile.js file. I should keep that one? Again Thank You very much. :) John

Modified by trekman

Waka_Flocka_Flame 441 solutions 5048 answers
See * [[Profiles - Where Firefox stores your bookmarks, passwords and other user data]] For locating the profile....

Question owner

Thank You Waka, that will help in the future Im sure. :)

Thank You Waka, that will help in the future Im sure. :)
jscher2000
  • Top 10 Contributor
3003 solutions 27892 answers

Deleting the prefs.js file would return you to Firefox "default" settings. Not the end of the world if you have to go throug the dialogs and reselect your preferences, but at this point, I don't think it's necessary.

Deleting the prefs.js file would return you to Firefox "default" settings. Not the end of the world if you have to go throug the dialogs and reselect your preferences, but at this point, I don't think it's necessary.