X
Tap here to go to the mobile version of the site.

Support Forum

Firefix 23.0.1 is freezing requiring a hard restart to the computer.

Posted

I am running an older machine, but with a fresh install of Windows 7. Until the latest update, I had no issues with the versions of Firefox since my last OS install. Now when I am in the latest Firefox 23.0.1, I get occasional freezing that will lock the entire machine and need a hard restart. I am still diagnosing, but to date the only constant I know is Firefox. I have not experienced the same freezes using IE.

Occasionally I will think the freeze is happening when I lose both keyboard and mouse control during a Firefox session, but after 1 to 2 seconds, they both return. Typically though, it just freezes. Most times it occurs while I am away from the keyboard getting coffee or something. It is so transparent, the only thing that tells me the freeze occurred (other than loss of mouse and keyboard) is the system time still being several minutes ago.

I have seen the other forum message regarding Firefox 21 and Firefox 22, but I figured I ask in a new message regarding Firefox 23.

I have done the reset to Firefox as of last night. I reloaded Ghostery as my only Add-On, which was the only Add-On running during earlier versions of Firefox. Already this morning I have had the 1 to 2 second pause, but no freezing yet. (Now Troubleshooter has been added due to this message.)

I am running an older machine, but with a fresh install of Windows 7. Until the latest update, I had no issues with the versions of Firefox since my last OS install. Now when I am in the latest Firefox 23.0.1, I get occasional freezing that will lock the entire machine and need a hard restart. I am still diagnosing, but to date the only constant I know is Firefox. I have not experienced the same freezes using IE. Occasionally I will think the freeze is happening when I lose both keyboard and mouse control during a Firefox session, but after 1 to 2 seconds, they both return. Typically though, it just freezes. Most times it occurs while I am away from the keyboard getting coffee or something. It is so transparent, the only thing that tells me the freeze occurred (other than loss of mouse and keyboard) is the system time still being several minutes ago. I have seen the other forum message regarding Firefox 21 and Firefox 22, but I figured I ask in a new message regarding Firefox 23. I have done the reset to Firefox as of last night. I reloaded Ghostery as my only Add-On, which was the only Add-On running during earlier versions of Firefox. Already this morning I have had the 1 to 2 second pause, but no freezing yet. (Now Troubleshooter has been added due to this message.)

Chosen solution

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Read this answer in context 17

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Google Update
  • GEPlugin
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • NPWLPG
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • CANON iMAGE GATEWAY Album Plugin Utility Module

Application

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0.1/WINNT/en-US/

Extensions

  • Ghostery 5.0.3 (firefox@ghostery.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 460
  • adapterDescription2:
  • adapterDeviceID: 0x0e22
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 6-21-2013
  • driverDate2:
  • driverVersion: 9.18.13.2049
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 460)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 23.0.1
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1377767837
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 0
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1377767837

Misc

  • User JS: No
  • Accessibility: No
Waka_Flocka_Flame 441 solutions 5048 answers

Chosen Solution

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Hello, Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back to us! Thank you.

Question owner

So far so good! I haven't had a freeze since disabling the acceleration. My fingers are crossed this is the answer, at least until the next version comes out.

Up to this point I was having no problems!

So far so good! I haven't had a freeze since disabling the acceleration. My fingers are crossed this is the answer, at least until the next version comes out. Up to this point I was having no problems!
Keithj 0 solutions 1 answers

Helpful Reply

I've been wrestling with this problem for a couple of weeks (ever since Firefox updated to the latest version, I now realise) but only gradually worked out what was causing the freezes. It took a day of using Chrome (ugh!) to decide to Google "Firefox crashes PC".

Thank you for the solution! If it doesn't work, I'll report back...

I've been wrestling with this problem for a couple of weeks (ever since Firefox updated to the latest version, I now realise) but only gradually worked out what was causing the freezes. It took a day of using Chrome (ugh!) to decide to Google "Firefox crashes PC". Thank you for the solution! If it doesn't work, I'll report back...