Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Private Browsing Tab is not opening in a New Window

  • 1 reply
  • 15 have this problem
  • 19 views
  • Last reply by cor-el

more options

I have a issue When ever i click to private browsing All the open windows are close and make one only one window which is private Browsing i don't want this I using windows7 32bit when i have xp i simply open a new firefox window and make them private and later i see the feature add in firefox which is select a private browsing and its automatically open new window(Private Browsing) this is all fine but now in win7 this is not happening when ever i select a private browsing it will close all tabs and make new window Errrr I hate this!! The all tabs are gone i even try to open a new window and make a private it but the other open windows are closing Don't know why is this happening??

I have a issue When ever i click to private browsing All the open windows are close and make one only one window which is private Browsing i don't want this I using windows7 32bit when i have xp i simply open a new firefox window and make them private and later i see the feature add in firefox which is select a private browsing and its automatically open new window(Private Browsing) this is all fine but now in win7 this is not happening when ever i select a private browsing it will close all tabs and make new window Errrr I hate this!! The all tabs are gone i even try to open a new window and make a private it but the other open windows are closing Don't know why is this happening??

All Replies (1)

more options

Firefox should open a new window if you use Firefox > New Private window and not close windows that are currently open.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.