X
Tap here to go to the mobile version of the site.

Support Forum

why do you put a restriction on facebook in my browser as not recognised as its driving me nuts. Its facebook and bigger than anything

Posted

lately i notice when i log into facebook there is an icon near the lock at the top bar which restricts facebook. you need to tell it not to work on every fb page you log into. facebook is so big yet it says the icon is there as the https for facebook does not register as a secure enough site. how rediculous. its facebook as big as the planet. can firefox fix this and remove it and somehow accomodate facebook better because if its not fixed i will have to go to use google chrome and i dont want to. its driving me nuts. thanks

lately i notice when i log into facebook there is an icon near the lock at the top bar which restricts facebook. you need to tell it not to work on every fb page you log into. facebook is so big yet it says the icon is there as the https for facebook does not register as a secure enough site. how rediculous. its facebook as big as the planet. can firefox fix this and remove it and somehow accomodate facebook better because if its not fixed i will have to go to use google chrome and i dont want to. its driving me nuts. thanks

Chosen solution

This thread is a little confusing! I'll try to summarize.

Blocking certain insecure content in secure pages is a trend; I think Internet Explorer has been doing this for a while.

Content embedded in Facebook pages is supposed to already have a secure URL, according to FB's developer guidelines, but that isn't being enforced or this problem would not exist. Hopefully over time this problem will go away.

For now, you can use the Toggle Mixed Active Content extension to quickly turn your protection against insecure content on and off. This is a global setting, not site specific, so it's best to leave it on as much as possible.

After you install the extension, you should find a new icon on the Add-on bar: an "A" on a green or red square. Green means Firefox is protecting you, and Red means it isn't.

If the icon is not on the Add-on bar (which you also can show or hide by pressing Ctrl+/ ), you may need to drag it out of the Customize dialog and drop it in a convenient location. You can open that using either of these:

  • right-click a blank area of the tab bar > Customize
  • tap the Alt key > View menu > Toolbars > Customize

Can you get it set up the way you want it?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • np-mswmp
  • Google Update
  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • Yahoo Application State Plugin version 1.0.0.7
  • ActiveTouch General Plugin Container Version 105
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • ABR_AUSkey Plugin Mozilla Component
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • CSI Plugin Mozilla Component
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Npdsplay dll
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

kobe 441 solutions 5048 answers

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you!

Helpful Reply

hi, thanks for your fast response. i hope i did the file right. its in the attachment. i have circled the problem icon. its to the left of https facebook login. thanks for your help

hi, thanks for your fast response. i hope i did the file right. its in the attachment. i have circled the problem icon. its to the left of https facebook login. thanks for your help
kobe 441 solutions 5048 answers

See

And to disable it go to about:config and disable (false) security.mixed_content.block_active_content.

See * [[How does content that isn't secure affect my safety?]] And to disable it go to about:config and disable (false) '''security.mixed_content.block_active_content'''. * kb.mozillazine.org/About:config

Question owner

it says in about config not to fiddle with it unless you know what you are doing. i dont really know what i am doing. thanks though for the info on why mozilla did this. i can see how they want to protect us but its a problem because when i go to load my history etc on my timeline or other pages that icon wont let it all load and when i take it off as instructed in the first section you sent me all the history loads and i can read it. but then i go into another page and its back on again and it becomes a nuicance. thanks for your help tho.

it says in about config not to fiddle with it unless you know what you are doing. i dont really know what i am doing. thanks though for the info on why mozilla did this. i can see how they want to protect us but its a problem because when i go to load my history etc on my timeline or other pages that icon wont let it all load and when i take it off as instructed in the first section you sent me all the history loads and i can read it. but then i go into another page and its back on again and it becomes a nuicance. thanks for your help tho.
cor-el
  • Top 10 Contributor
  • Moderator
17689 solutions 160039 answers
You can look at this extension: *https://addons.mozilla.org/firefox/addon/toggle-mixed-active-content/ ----- *https://developer.mozilla.org/en/Security/MixedContent

Question owner

thanks for your reply, its an add on then. how do i get RID of it. it must have come when i updated my firefox

thanks for your reply, its an add on then. how do i get RID of it. it must have come when i updated my firefox
kobe 441 solutions 5048 answers

There should be a button on the screen, like on the addon bar.

There should be a button on the screen, like on the addon bar. * [[The Add-on Bar gives you quick access to add-on features]]
cor-el
  • Top 10 Contributor
  • Moderator
17689 solutions 160039 answers

No. This extension allows to handle the blocked content more easily (you can temporarily toggle/disable this block) and isn't causing this issue.

Seeing the shield in the location bar is a build-in Firefox security feature to disable content coming from an insecure connection. Firefox also can block display content (e.g. images) in addition to blocking active content, but this is still set to false by default.

  • security.mixed_content.block_active_content (default: true)
  • security.mixed_content.block_display_content (default: false)

No. This extension allows to handle the blocked content more easily (you can temporarily toggle/disable this block) and isn't causing this issue. Seeing the shield in the location bar is a build-in Firefox security feature to disable content coming from an insecure connection. Firefox also can block display content (e.g. images) in addition to blocking active content, but this is still set to false by default. *security.mixed_content.block_active_content (default: true) *security.mixed_content.block_display_content (default: false) ----- *http://kb.mozillazine.org/about:config

Question owner

thanks cor-el - what i dont understand is how a https namely facebook should be blocked. facebook has its own security so i should be safe. its a pain to have to disable this built in security. by the way Waka, it says Right-click on an empty section of the Tab Strip, what is a tab strip? thanks for trying to help you guys :) but it looks like i cant get rid of that icon permanently

thanks cor-el - what i dont understand is how a https namely facebook should be blocked. facebook has its own security so i should be safe. its a pain to have to disable this built in security. by the way Waka, it says Right-click on an empty section of the Tab Strip, what is a tab strip? thanks for trying to help you guys :) but it looks like i cant get rid of that icon permanently
kobe 441 solutions 5048 answers

Or you could go to FIrefox button => Options => Addon bar <= Check That.

Or you could go to FIrefox button => Options => Addon bar <= Check That.
philipp
  • Top 25 Contributor
  • Moderator
5330 solutions 23537 answers

"what i dont understand is how a https namely facebook should be blocked. facebook has its own security so i should be safe. " only the parts of the page which are not loaded through a secured connection by facebook are blocked. Waka_Flocka_Flame has already posted a link to the article which explains this: Mixed content blocking in Firefox

''"what i dont understand is how a https namely facebook should be blocked. facebook has its own security so i should be safe. "'' only the parts of the page which are not loaded through a secured connection by facebook are blocked. Waka_Flocka_Flame has already posted a link to the article which explains this: [[How does content that isn't secure affect my safety?]]
cor-el
  • Top 10 Contributor
  • Moderator
17689 solutions 160039 answers

Helpful Reply

This is a problem with those Facebook pages that include insecure content.
Current Firefox versions only expose such content that comes via an HTTP connection and blocks some of it.

It is up to Facebook to correct this or you need to click the shield icon in Firefox or disable this security feature via the above mentioned extension or by (temporarily) toggling the security.mixed_content.block_active_content pref.

This is a problem with those Facebook pages that include insecure content.<br /> Current Firefox versions only expose such content that comes via an HTTP connection and blocks some of it. It is up to Facebook to correct this or you need to click the shield icon in Firefox or disable this security feature via the above mentioned extension or by (temporarily) toggling the security.mixed_content.block_active_content pref.

Question owner

thanks guys. i can see from your answers that firefox has this built in. no, firefox needs to accomodate facebook because facebook is bigger than firefox. we can live with another browser but we won't give up our facebook so its up to firefox to sort their act out. much easier for me to use google chrome where i dont have that hassle. thanks for the help all :)

thanks guys. i can see from your answers that firefox has this built in. no, firefox needs to accomodate facebook because facebook is bigger than firefox. we can live with another browser but we won't give up our facebook so its up to firefox to sort their act out. much easier for me to use google chrome where i dont have that hassle. thanks for the help all :)

Question owner

hey wacka. where is the firefox button?

hey wacka. where is the firefox button?

Question owner

sorry Waka..spelt it wrong :)

sorry Waka..spelt it wrong :)
kobe 441 solutions 5048 answers

Where it says "Firefox" on the top-left corner of the window or View menu => Toolbars => Addon Bar

Where it says "Firefox" on the top-left corner of the window or View menu => Toolbars => Addon Bar

Question owner

waka i found the add on bar. what is 'check that'. check what? all i get down the bottom when it displays is finger fox se in the bottom right hand corner and when i open it it says

global automatic popup and show in status bar

and nothing else.

thanks for your help :)

waka i found the add on bar. what is 'check that'. check what? all i get down the bottom when it displays is finger fox se in the bottom right hand corner and when i open it it says global automatic popup and show in status bar and nothing else. thanks for your help :)
jscher2000
  • Top 10 Contributor
8838 solutions 72234 answers

Chosen Solution

This thread is a little confusing! I'll try to summarize.

Blocking certain insecure content in secure pages is a trend; I think Internet Explorer has been doing this for a while.

Content embedded in Facebook pages is supposed to already have a secure URL, according to FB's developer guidelines, but that isn't being enforced or this problem would not exist. Hopefully over time this problem will go away.

For now, you can use the Toggle Mixed Active Content extension to quickly turn your protection against insecure content on and off. This is a global setting, not site specific, so it's best to leave it on as much as possible.

After you install the extension, you should find a new icon on the Add-on bar: an "A" on a green or red square. Green means Firefox is protecting you, and Red means it isn't.

If the icon is not on the Add-on bar (which you also can show or hide by pressing Ctrl+/ ), you may need to drag it out of the Customize dialog and drop it in a convenient location. You can open that using either of these:

  • right-click a blank area of the tab bar > Customize
  • tap the Alt key > View menu > Toolbars > Customize

Can you get it set up the way you want it?

This thread is a little confusing! I'll try to summarize. Blocking certain insecure content in secure pages is a trend; I think Internet Explorer has been doing this for a while. Content embedded in Facebook pages is supposed to already have a secure URL, according to FB's developer guidelines, but that isn't being enforced or this problem would not exist. Hopefully over time this problem will go away. For now, you can use the [https://addons.mozilla.org/firefox/addon/toggle-mixed-active-content/ Toggle Mixed Active Content] extension to quickly turn your protection against insecure content on and off. This is a global setting, not site specific, so it's best to leave it on as much as possible. After you install the extension, you should find a new icon on the Add-on bar: an "A" on a green or red square. Green means Firefox is protecting you, and Red means it isn't. If the icon is not on the Add-on bar (which you also can show or hide by pressing Ctrl+/ ), you may need to drag it out of the Customize dialog and drop it in a convenient location. You can open that using either of these: * right-click a blank area of the tab bar > Customize * tap the Alt key > View menu > Toolbars > Customize Can you get it set up the way you want it?

Question owner

thanks everyone. and especially for the summary at the end. i think i know what to do now. :)

thanks everyone. and especially for the summary at the end. i think i know what to do now. :)