X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox keep asking to open or save pdf files which are already in my disk.

Posted

Hi all,

Firefox build in function to open pdf files was working ok.

Lately when i try to open a .PDF file which is already in my disk i get a window asking me :

"What should firefox do with this file? -Open with (firefox default) -Save the file"

Since the .PDF is already in my disk , i want to open it but firefox keeps asking in that window so i have to cancel and a new blank tab stays there.

What should i do to open the .PDF file?

BTW,i tried to delete the mimetypes.rdf file as read on a message here in order to Reset download actions but in vain.

Thank you for your time reading this.

Regards, the_observer.

Additional System Details

Installed Plug-ins

  • VLC media player Web Plugin 2.0.6
  • Shockwave Flash 11.8 r800
  • Google Update
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20513.0
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Windows Activation Technologies Plugin for Mozilla

Application

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Add Bookmark Here ² 17.0.20121128 (abhere2@moztw.org)
  • AutoCopy 2 1.2.7 (autocopy2@teo.pl)
  • ColorZilla 2.8.1 ({6AC85730-7D0F-4de0-B3FA-21142DD85326})
  • feedly 16.0.528 (feedly@devhd)
  • Firebug 1.12.0 (firebug@software.joehewitt.com)
  • FoxTrick 0.12.1.1 ({9d1f059c-cada-4111-9696-41a62d64e3ba})
  • Ghostery 5.0.3 (firefox@ghostery.com)
  • LastPass 2.0.20 (support@lastpass.com)
  • Tab Mix Plus 0.4.1.0 ({dc572301-7619-498c-a57d-39143191b318})
  • TabGroups Manager 2011.11.28.1 ({ca526f8b-9e0a-4756-9077-19d6f3e64ea8})
  • TranslateMenu 1.51 (transmenu@ahmeda.net)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Wappalyzer 2.7.2 (wappalyzer@crunchlabz.com)
  • WOT 20130515 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})
  • avast! Online Security 8.0.1489 (wrc@avast.com) (Inactive)
  • Freemake Video Converter Plugin 1.0.0 (fmconverter@gmail.com) (Inactive)
  • MeasureIt 0.4.12 ({75CEEE46-9B64-46f8-94BF-54012DE155F0}) (Inactive)
  • Web Developer 1.2.5 ({c45c406e-ab73-11d8-be73-000a95be3b12}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 3870
  • adapterDescription2:
  • adapterDeviceID: 0x9501
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 3000 Pixel Structure: RGB ClearType Level: 0 Enhanced Contrast: 400
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 11-16-2012
  • driverDate2:
  • driverVersion: 8.970.100.7000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 3870)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0.1
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1377260537
  • places.history.expiration.transient_current_max_pages: 91603
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npgeplugin: 0
  • plugin.state.npwlpg: 0
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.extensions-tabmix: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1376077562

Misc

  • User JS: No
  • Accessibility: Yes
philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

hello, please try it with the following addon installed: https://addons.mozilla.org/firefox/addon/inlinedisposition/

Question owner

Thank you for your answer philipp.

Firefox is supposed to open the .pdf files without add-on .Isn't it? I bet the add on is working but then there is another add on specifically for opening pdf files.

I would like to correct the faulty behavior in my firefox if possible.

Regards, the_observer.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You can change the action for Portable Document Format (PDF) from Preview in Firefox to use another application like the Adobe Reader or set to Always Ask in "Firefox > Options/Preferences > Applications".

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu.

See also:

Question owner

Hi cor-el,

I used your suggestions and i have the below results:

1. "You can change the action for Portable Document Format (PDF) from Preview in Firefox to use another application like the Adobe Reader or set to Always Ask in "Firefox > Options/Preferences > Applications"

This is not satisfactory because i don't want to use it.I just want the internal viewer for PDF's of Firefox.

2. "You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer."

I set the pdfjs.disabled pref to true and after firefox restart it kept opening empty tabs (weird)

3. "You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu."

I did that and just keeps me asking in new tabs what to do with pdf (open or save)

Then i thought maybe another addon conflicted with firefox PDF viewer so i started it in safe mode.Tried to open a pdf and started to open empty tabs...

Finally i installed this addon and pdf open ok now.

Still i had to use an addon to make them open. It was running correctly with out add on.

Is there something else to try since i dont want addon? Firefox pdf internal viewer was very satisfactory for me...

Thank you for your time reading this.

Regards, the_observer.

jscher2000
  • Top 10 Contributor
2368 solutions 20957 answers

Hi the_observer, go ahead and re-enable pdf.js if you want to use the internal viewer.

I can open PDFs from my desktop in the viewer using either

  • File menu > Open File
  • drag and drop onto a new tab

Do those work for you?

Note that Firefox will not apply its application preferences to files on disk that you launch from your download history. Instead, those will be handled according to the preferences in the Windows registry for the relevant file extensions.

Question owner

Hi jscher.

No it does not help me.

The problem persist as i described it in my 1st post.

Only with the installation of an add on i can open .pdf files with out problem.

Regards, the_observer.