X
Tap here to go to the mobile version of the site.

Support Forum

Start page loads instead of homepage

Posted

I am using firefox ESR v17.0.8 on Windows 7 with the firefox.adm policy template to customize some of my browser settings. I have specified a homepage to load on startup but whenever I start firefox the default firefox start page loads instead.

If I click the home button the correct page loads and if I look under Tools/Options/General it is set to load my home page and the correct home page URL is specified.

I have tried starting without any addins loaded but it doesn't make a difference. Suggestions?

I am using firefox ESR v17.0.8 on Windows 7 with the firefox.adm policy template to customize some of my browser settings. I have specified a homepage to load on startup but whenever I start firefox the default firefox start page loads instead. If I click the home button the correct page loads and if I look under Tools/Options/General it is set to load my home page and the correct home page URL is specified. I have tried starting without any addins loaded but it doesn't make a difference. Suggestions?

Modified by cornishc

Additional System Details

Application

  • User Agent: Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; Trident/6.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; VER#6A#80848369486745484849484878; .NET4.0C; InfoPath.2; Tablet PC 2.0)

More Information

brunohaxes 6 solutions 38 answers

Helpful Reply

Try the following:

1) Go to about:config (type it in the adress bar).

2) Enter.

3) Search for browser.startup.homepage.

4) This variable controls what page is loaded when you start Firefox.

According to your post its value should be about:home. Change this value to the website you'd like to load on start.

To change what website it opens when you open a new tab, do the same but with browser.newtab.url.

Try the following: 1) Go to '''about:config''' (type it in the adress bar). 2) Enter. 3) Search for '''browser.startup.homepage'''. 4) This variable controls what page is loaded when you start Firefox. According to your post its value should be '''about:home'''. Change this value to the website you'd like to load on start. To change what website it opens when you open a new tab, do the same but with '''browser.newtab.url'''.

Helpful Reply

browser.startup.homepage was set for the homepage I wanted.

browser.newtab.url was set to about:blank which is what I wanted.

Changing newtab only loads my homepage when I open a new tab.

browser.startup.homepage was set for the homepage I wanted. browser.newtab.url was set to about:blank which is what I wanted. Changing newtab only loads my homepage when I open a new tab.
cor-el
  • Top 10 Contributor
  • Moderator
12522 solutions 115465 answers

Did you check the target line in the Properties of the Firefox desktop shortcut?

What is the startup setting?

  • Tools > Options > General > Startup: "When Firefox Starts":
  • "Show my windows and tabs from last time"
  • "Show my home page"
  • "Show a blank page"
Did you check the target line in the Properties of the Firefox desktop shortcut? What is the startup setting? *Tools > Options > General > Startup: "When Firefox Starts": *"Show my windows and tabs from last time" *"Show my home page" *"Show a blank page"

Question owner

The properties of the desktop shortcut point to the firefox.exe.

The startup setting is set to "Show my home page" and my home Page is locked through policy and set to my homepage.

The policy does seem to work on Windows XP so it may be an issue with the policy template.

The properties of the desktop shortcut point to the firefox.exe. The startup setting is set to "Show my home page" and my home Page is locked through policy and set to my homepage. The policy does seem to work on Windows XP so it may be an issue with the policy template.
cor-el
  • Top 10 Contributor
  • Moderator
12522 solutions 115465 answers

See also:

These functions can be used in the mozilla.cfg file:

defaultPref();  // set new default value
pref();         // set pref, but allow changes in current session
lockPref();     // lock pref, disallow changes

With that setting the home page should load on startup.

It is possible that session restore is reloading a specific page if extensions aren't the culprit.

You can check if you have an user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

You can check for problems with the sessionstore.js and sessionstore.bak files in the Firefox profile folder that store session data.

Delete the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox profile folder.

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

If you have problems with preferences, see:

See also: *http://kb.mozillazine.org/Locking_preferences These functions can be used in the mozilla.cfg file: defaultPref(); // set new default value pref(); // set pref, but allow changes in current session lockPref(); // lock pref, disallow changes ----- With that setting the home page should load on startup. It is possible that session restore is reloading a specific page if extensions aren't the culprit. You can check if you have an user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true. *http://kb.mozillazine.org/browser.sessionstore.resume_session_once You can check for problems with the sessionstore.js and sessionstore.bak files in the Firefox profile folder that store session data. Delete the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox profile folder. *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) If you have problems with preferences, see: *http://kb.mozillazine.org/Preferences_not_saved

Question owner

Ok, I've made some changes to my policies and what seems to be happening is that it is reading the homepage setting from the local default user profile first.

But now if I close Firefox and open it again it loads the homepage set in group policy but the home button now takes me to the homepage that I have set in the local default user profile.

Ok, I've made some changes to my policies and what seems to be happening is that it is reading the homepage setting from the local default user profile first. But now if I close Firefox and open it again it loads the homepage set in group policy but the home button now takes me to the homepage that I have set in the local default user profile.
ghilbers 0 solutions 1 answers

My problem is similar. I have tried everything posted here and it works as long as I have firefox up. But when I shut it down and reopen it, it's the same thing.

My problem is similar. I have tried everything posted here and it works as long as I have firefox up. But when I shut it down and reopen it, it's the same thing.