X
Tap here to go to the mobile version of the site.

Support Forum

How can I get the 'Remember Password' prompt to display again after deleting a saved password before?

Posted

My username and password for my university website: https://www.bb.reading.ac.uk/ stopped appearing automatically, and the password only appeared when I typed in my username. I couldn't bothered to type the username every time, so I deleted the website in the 'Saved Password...' section thinking I would be prompted to remember the password again. But it never came up and cannot seem to find a function that would allow me to remember a password for the website.

My username and password for my university website: https://www.bb.reading.ac.uk/ stopped appearing automatically, and the password only appeared when I typed in my username. I couldn't bothered to type the username every time, so I deleted the website in the 'Saved Password...' section thinking I would be prompted to remember the password again. But it never came up and cannot seem to find a function that would allow me to remember a password for the website.

Chosen solution

Some web sites, including many banks and a few other sites, tell browsers not to remember passwords for visitors by using autocomplete="off".
Which is what that page does, Firefox respects the web page author's coding in pages like that.

This bookmarklet makes the browser ignore autocomplete="off" temporarily, allowing you to save passwords even on sites that use autocomplete="off".

Remember Password bookmarklet:
https://www.squarefree.com/bookmarklets/forms.html#remember_password

Or, you can use the Saved Passwords Editor extension for web sites where Firefox doesn't offer to save the Username /Password.
https://addons.mozilla.org/en-US/firefox/addon/60265/

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • ACE Stream Plug-in Version 2.1.5.3, Copyright (c) 2012-2013 Innovative Digital Technologies
  • Shockwave Flash 11.8 r800
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • VLC media player Web Plugin 2.0.6
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • iTunes Detector Plug-in
  • Website Logon Plugin
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • Unity Player 4.0.1f2
  • Facebook Video Calling Plugin
  • NPWLPG
  • EA SPORTS Game Face Plugin 1.8.0.0
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components

Application

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Download Statusbar 0.9.10 ({D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389})
  • Speed Dial 0.9.6.15 ({64161300-e22b-11db-8314-0800200c9a66})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • TS Magic Player 1.1.29 (magicplayer@torrentstream.org)
  • Freemake Video Converter Plugin 1.0.0 (fmconverter@gmail.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 3000
  • adapterDescription2: NVIDIA GeForce GT 630M
  • adapterDeviceID: 0x0126
  • adapterDeviceID2: 0x0de9
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 1023
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 1-18-2012
  • driverDate2: 3-14-2013
  • driverVersion: 8.15.10.2626
  • driverVersion2: 9.18.13.1422
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: http://arsenal.com/
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0.1
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1376899747
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1376573213

Misc

  • User JS: Yes
  • Accessibility: No
John99
  • Top 25 Contributor
  • Moderator
683 solutions 9468 answers

See

With luck all you need to do is find and delete the exception that you have made. But other possibilities include: that you are using private browsing or the site is preventing saving of usernames.

See * http://kb.mozillazine.org/Password_Manager#Exceptions <br/>It is a long article and probably worth scrolling through. * and [[Password manager - Remember, delete and change saved passwords in Firefox]] ** [[Usernames and passwords are not saved#w_password-manager-settings]]_password-manager-settings With luck all you need to do is find and delete the exception that you have made. But other possibilities include: that you are using private browsing or the site is preventing saving of usernames.
the-edmeister
  • Top 10 Contributor
  • Moderator
3864 solutions 29249 answers

Chosen Solution

Some web sites, including many banks and a few other sites, tell browsers not to remember passwords for visitors by using autocomplete="off".
Which is what that page does, Firefox respects the web page author's coding in pages like that.

This bookmarklet makes the browser ignore autocomplete="off" temporarily, allowing you to save passwords even on sites that use autocomplete="off".

Remember Password bookmarklet:
https://www.squarefree.com/bookmarklets/forms.html#remember_password

Or, you can use the Saved Passwords Editor extension for web sites where Firefox doesn't offer to save the Username /Password.
https://addons.mozilla.org/en-US/firefox/addon/60265/

Some web sites, including many banks and a few other sites, tell browsers not to remember passwords for visitors by using autocomplete="off". <br />'''Which is what that page does,''' Firefox respects the web page author's coding in pages like that. This bookmarklet makes the browser ignore autocomplete="off" temporarily, allowing you to save passwords even on sites that use autocomplete="off". Remember Password bookmarklet: <br /> https://www.squarefree.com/bookmarklets/forms.html#remember_password Or, you can use the Saved Passwords Editor extension for web sites where Firefox doesn't offer to save the Username /Password. <br /> https://addons.mozilla.org/en-US/firefox/addon/60265/

Question owner

Thanks the extension worked well

Thanks the extension worked well
WhereIsMyMindAt 1 solutions 16 answers

Helpful Reply

You may also use the "Bookmarklet" to reset your Password Saving Options. (EX re-force/"Force" Firefox to save Passwords

Found Here: http://kb.mozillazine.org/User_name_and_password_not_remembered

Scroll down the page to "Bookmarklet", follow the instructions.




.......................... Also, remember some websites by design will not allow saving of a Password (common with banking,etc.) It's not germane to this thread, but you can look up on the web "URL Hacking" (and save password) or some combination thereof. The word "Hacking" is FAR from "True"---all you're doing is changing a "false" to "true" or "true to false" or 0 to 1,etc. That may or may not work if you REALLY want to save a PW for the site. (however, like Banking,etc.), probably best not to keep saved. Your call hope the fix above works.

You may also use the "Bookmarklet" to reset your Password Saving Options. (EX re-force/"Force" Firefox to save Passwords Found Here: http://kb.mozillazine.org/User_name_and_password_not_remembered Scroll down the page to "Bookmarklet", follow the instructions. .......................... Also, remember some websites by design will not allow saving of a Password (common with banking,etc.) It's not germane to this thread, but you can look up on the web "URL Hacking" (and save password) or some combination thereof. The word "Hacking" is FAR from "True"---all you're doing is changing a "false" to "true" or "true to false" or 0 to 1,etc. That may or may not work if you REALLY want to save a PW for the site. (however, like Banking,etc.), probably best not to keep saved. Your call hope the fix above works.