X
Tap here to go to the mobile version of the site.

Support Forum

How can I disable tabs?

Posted

I can't find the setting in 23.0.1 to disable tabs. I don't like using tabs and have always had them disabled but for some reason they've activated and I don't know how to shut them off. Advice?

I can't find the setting in 23.0.1 to disable tabs. I don't like using tabs and have always had them disabled but for some reason they've activated and I don't know how to shut them off. Advice?

Chosen solution

Hello,

In Firefox 23, as part of an effort to simplify the Firefox options set and facilitate future improvements to Firefox, the option to hide the tab bar was removed.

Fortunately, this can easily be resolved if you desire the keep tabs hidden. You can install "Hide tab bar with one tab", an extension hosted on Mozilla's add-ons site, which will restore the ability to hide the tab bar.

Thank you and I hope this helps!

Read this answer in context 12

Additional System Details

Installed Plug-ins

  • Version 4.4.2.14502
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Shockwave Flash 11.8 r800
  • Widevine Media Optimizer 6.0.0.12607
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.7
  • 5.1.20125.0
  • Garmin Communicator Plug-in Version 4.0.4.0
  • Amazon MP3 Downloader Plugin 1.0.17
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • iPhoto6

Application

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0.1/Darwin/en-US/

Extensions

  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom)
  • Garmin Communicator 4.0.4 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 8a0
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce 320M OpenGL Engine
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.link.open_newwindow: 2
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.restore_on_demand: False
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • browser.tabs.autoHide: True
  • browser.tabs.warnOnClose: False
  • browser.tabs.warnOnOpen: False
  • dom.disable_open_during_load: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0.1
  • font.internaluseonly.changed: False
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1376694580
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 100664
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1374722485

Misc

  • User JS: No
  • Accessibility: No
kobe 441 solutions 5048 answers

Chosen Solution

Hello,

In Firefox 23, as part of an effort to simplify the Firefox options set and facilitate future improvements to Firefox, the option to hide the tab bar was removed.

Fortunately, this can easily be resolved if you desire the keep tabs hidden. You can install "Hide tab bar with one tab", an extension hosted on Mozilla's add-ons site, which will restore the ability to hide the tab bar.

Thank you and I hope this helps!

Hello, In Firefox 23, as part of an effort to simplify the Firefox options set and facilitate future improvements to Firefox, the option to hide the tab bar was removed. Fortunately, this can easily be resolved if you desire the keep tabs hidden. You can install "[https://addons.mozilla.org/firefox/addon/hide-tab-bar-with-one-tab/ Hide tab bar with one tab]", an extension hosted on Mozilla's add-ons site, which will restore the ability to hide the tab bar. Thank you and I hope this helps!

Question owner

Thanks! That solved the dilemma but it does make me wonder why the kids at Mozilla would force that feature on us.

Thanks! That solved the dilemma but it does make me wonder why the kids at Mozilla would force that feature on us.
hunterws 0 solutions 1 answers

Helpful Reply

Mozilla, you may want to notify people about changes like this, if I hadn't found this thread, I was ready to give Chrome a try. In this latest update I can see my Yahoo! mail doesn't work as well as it did just yesterday. When a new version comes out, I expect improvements, not have to jump through hoops to get back what I had (add-on to remove tabs bar, come on).

This is the same reason I cannot stand IE, because of the lack of USER control, keep that in mind!

Mozilla, you may want to notify people about changes like this, if I hadn't found this thread, I was ready to give Chrome a try. In this latest update I can see my Yahoo! mail doesn't work as well as it did just yesterday. When a new version comes out, I expect improvements, not have to jump through hoops to get back what I had (add-on to remove tabs bar, come on). This is the same reason I cannot stand IE, because of the lack of USER control, keep that in mind!
careca 0 solutions 9 answers

Helpful Reply

Totally agree, the best browser possible is one that suits everyone's needs, not one that forces something on everyone, simplify options my ass! then why is it that i can't turn tabs off even thru about:config? You could've just remove it from the options menu, but seems you did more than that.

Totally agree, the best browser possible is one that suits everyone's needs, not one that forces something on everyone, simplify options my ass! then why is it that i can't turn tabs off even thru about:config? You could've just remove it from the options menu, but seems you did more than that.
paulsep 0 solutions 1 answers

I suggest, to give users a warning, just like using about:config, for options, mozilla sorts as "for experianced users".

I suggest, to give users a warning, just like using about:config, for options, mozilla sorts as "for experianced users".
kobe 441 solutions 5048 answers

Paulsep, They mostly removed it from every where because it had glitches with Mozilla's new Chrome theme. (Note that most of the contributors on here DO not work for mozilla, That means you will get no developer attention here.)

You can post feedback that developers take as a whole and see what the biggest problems are (if this is no1 i would still be slightly surprised if they put it back in there).

Paulsep, They mostly removed it from every where because it had glitches with Mozilla's new Chrome theme. (Note that most of the contributors on here '''DO not work for mozilla''', That means you will get no developer attention here.) You can post feedback that developers take as a whole and see what the biggest problems are (if this is no1 i would still be slightly surprised if they put it back in there). * input.mozilla.org
jordanbrown 0 solutions 2 answers

SeaMonkey (http://www.seamonkey-project.org/) will let you disable tabs more completely than Firefox ever did. (For instance, Tools/Add-ons ends up in a separate window instead of a tab.)

These are the settings that seem to work for me:

In Browser/Tabbed Browsing:

  Hide the tab bar when only one tab is open - check

In Browser/Link Behavior:

  Open links means to open a new window in... a new window.
  Open links passed from other applications in... a new window.
SeaMonkey (http://www.seamonkey-project.org/) will let you disable tabs more completely than Firefox ever did. (For instance, Tools/Add-ons ends up in a separate window instead of a tab.) These are the settings that seem to work for me: In Browser/Tabbed Browsing: Hide the tab bar when only one tab is open - check In Browser/Link Behavior: Open links means to open a new window in... a new window. Open links passed from other applications in... a new window.