X
Tap here to go to the mobile version of the site.

Support Forum

Firefox blocks NYTimes as "not secure" - must "allow" each time.

Posted

"This website does not supply identity information." "Your connection is only partially encrypted ..." This is the New York Times website, for heaven's sake. This extremely annoying Firefox behavior is new in Firefox 23.0.

"This website does not supply identity information." "Your connection is only partially encrypted ..." This is the New York Times website, for heaven's sake. This extremely annoying Firefox behavior is new in Firefox 23.0.

Chosen solution

hello, for details on why this blocking mechanism was introduced in firefox please refer to How does content that isn't secure affect my safety?.
for a demo on how the mixed content blocking can protect you in the wild you could see the following demo/sample page by microsoft: https://ie.microsoft.com/testdrive/browser/mixedcontent/assets/woodgrove.htm

if you'd like to generally turn of mixed content blocking nevertheless, enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named security.mixed_content.block_active_content. double-click it and change its value to false.

Read this answer in context 8

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Google Update
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Picasa plugin
  • NPWLPG

Application

  • Firefox 23.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • BetterPrivacy 1.68 ({d40f5e7b-d2cf-4856-b441-cc613eeffbe3})
  • Ghostery 2.9.6 (firefox@ghostery.com)
  • HTTPS-Everywhere 3.3.1 (https-everywhere@eff.org)
  • Single Key Tab Switch 0.2.5 ({a66191d8-898b-4a66-89be-d5b279477a54})
  • TinEye Reverse Image Search 1.1 (tineye@ideeinc.com)
  • Toggle Mixed Active Content 1.0.rev14 (jid0-LfpuGtyvjqw5JxLBjdCjX5Fzorw@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7470
  • adapterDescription2:
  • adapterDeviceID: 0x6778
  • adapterDeviceID2:
  • adapterDrivers: atiu9p64 atiuxp64 atiuxp64 atiu9pag atiuxpag atiuxpag atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 12-6-2011
  • driverDate2:
  • driverVersion: 8.922.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7470)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: https://www.nytimes.com/
  • browser.startup.homepage_override.buildID: 20130730113002
  • browser.startup.homepage_override.mstone: 23.0
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.cookieBehavior: 3
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1376260674
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.clearOnShutdown.passwords: True
  • privacy.clearOnShutdown.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1374733627

Misc

  • User JS: No
  • Accessibility: No
philipp
  • Top 10 Contributor
  • Moderator
2971 solutions 13817 answers

Chosen Solution

hello, for details on why this blocking mechanism was introduced in firefox please refer to How does content that isn't secure affect my safety?.
for a demo on how the mixed content blocking can protect you in the wild you could see the following demo/sample page by microsoft: https://ie.microsoft.com/testdrive/browser/mixedcontent/assets/woodgrove.htm

if you'd like to generally turn of mixed content blocking nevertheless, enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named security.mixed_content.block_active_content. double-click it and change its value to false.

hello, for details on why this blocking mechanism was introduced in firefox please refer to [[How does content that isn't secure affect my safety?]]. <br>for a demo on how the mixed content blocking can protect you in the wild you could see the following demo/sample page by microsoft: https://ie.microsoft.com/testdrive/browser/mixedcontent/assets/woodgrove.htm if you'd like to generally turn of mixed content blocking nevertheless, enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''security.mixed_content.block_active_content'''. double-click it and change its value to '''false'''.
cor-el
  • Top 10 Contributor
  • Moderator
12269 solutions 113635 answers

Helpful Reply

See: *https://support.mozilla.org/kb/how-does-content-isnt-secure-affect-my-safety *https://developer.mozilla.org/en/Security/MixedContent