Search Support

web pages incomplete in Firefox but work in Google chrome

more options

I have the latest version of Firefox and Windows 7. For the past fortnight or so web pages have been incomplete in Firefox but work in Google chrome. eg: if I open the Amazon site and wish to purchase an item the frames on the right named Add to Basket or add to wish list are completely missing. If I pass the mouse pointer over where they should be, the pointer changes to the hand symbol but no details appear.

I have completely reset Firefox and then opened in safe mode but the fault remains.

I have checked every option in the Tools / option section that seem appropriate but with no luck.

Can you advise please

All Replies (20)

more options

Weird, inexplicable display artifacts make me think of potential graphics drivers incompatibilities. You can minimize this issue by disabling Firefox's use of hardware graphics acceleration.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the issue resolved (or at least improved)?

more options

Thanks for suggestion but no luck. I tried 2 web sites but there is no improvement at all.

more options

Note that a reset tries to import cookies.

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

more options

Thanks for more detailed help but still no improvement at all. I followed every suggestion you made.

Is there anything else I can try?

more options
more options

Thanks for continued help and support.

I have removed (2) old profiles, after saving them and created a completely new one with no bookmarks. This I am afraid has made no difference to the appearance of websites.

Is there anything else I can try?

more options

boot into windows safe mode.

and see if it resovles.

more options

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

more options

Hopefully I have provided an image showing an incomplete Amazon web page. This shows how the information on the right hand side of the page relating to adding to the basket and purchase, are missing.

I have not yet tried to open in safe mode.

more options

Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

See also:

more options

Note that some of those images are sprites that contains several of them.

If images are missing then check that you aren't blocking images from some domains.

  • Press the F10 key or tap the Alt key to bring up the hidden "Menu Bar" temporarily.
  • Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load images > Exceptions"
  • Check "Tools > Page Info > Media" for blocked images
  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a check-mark then remove this check-mark to unblock images from this domain.

Make sure that you do not block third-party images, the permissions.default.image pref on the about:config page should be 1.


Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

See also:


There are extensions like Adblock Plus (Firefox/Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also:

Modified by cor-el

more options

If I override page colors, I get a very similar display.

more options

By the way, I'm a bit concerned that your address bar has a green background but it is not secure connection to the site. Is it always green, or is there a problem with an add-on that is supposed to color secure site addresses differently?

more options

I haven't yet had time to work through all the latest suggestions .

Regarding the green colouring, this was my choice when I recently amended several size and colour settings in Windows display.

I do not understand the remark that my address bar is not a secure connection to the site. How doI correct that please?

more options

Hi Keith, regarding the connection to the site, I'm sure you've noticed that on some sites Firefox displays a lock icon to the left of the URL in the address bar. That happens on this site, for example.

Occasionally you see not just a gray padlock, but a green one with a company name. This is because the site has an EV (extended validation) certificate assuring you that the site is under the control of a particular company.

Some browsers put a green background color in the address bar when you are viewing a secure page on a site with an EV certificate. So I just wanted to note that if the bar is always that color, you can't rely on that background color to determine how secure your connection is with the site.

As for whether you can connect more securely, the answer is, "sometimes." On many sites you visit, you probably don't care about a secure connection, i.e., your submissions and the pages you get in return don't need to be confidential. If it's a site you think should use a secure connection, you can try changing the HTTP to HTTPS in the address bar. Many sites will error out if you do that, but it might work for the ones that are more privacy conscious.

more options

I am still working my way through other helpful suggestions.

I opened in Safe Mode (with networking) as I could not get web connection in pure safe mode, but the fault was still there.

more options

Did you check the high contrast setting in the Windows Accessibility settings in case the setting in "Options > Content > Colors" is correct?

more options

I have checked to ensure that high contrast setting is NOT operating

more options

But did you turn on the option shown in the screen shot in this post? https://support.mozilla.org/questions/967382#answer-466864

more options

I am sorry but I don't understand the option I should have turned on before checking the high contrast setting.

I have however carried out all the earlier instructions ending with the about:config setting which is 1.

  1. 1
  2. 2