X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

bookmarks dropdown menu disappeared

Posted

I have a row of icons visible that are in my bookmarks toolbar. And this row "used" to have a drop-down arrow for the bookmarks toolbar and another for all my other bookmarks. As of this morning, the arrow for the bookmarks has disappeared.

How do I get it back?

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.7 r700
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.03
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • Open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please report back with your results.

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

The Bookmarks menu drop-down icon will automatically hide if the classic menu bar is displayed, i.e., the full menu bar with the Bookmarks menu.

Another Mac user reported that moving the icon to a different bar and then back again stopped the auto-hiding behavior. Do you want to try that?

Start up the Customize feature using either of the following:

  • View menu > Toolbars > Customize
  • right-click a blank area of the tab bar > Customize

Drag the icon from the right end of the Bookmarks Toolbar to another bar, then click Done in the dialog.

Repeat the process, this time moving the icon back to the Bookmarks Toolbar. Does that work??

(It didn't work on Windows 7, but Windows and Mac have different menus.)

Question owner

Thanks guys. I tried the first suggestion I received, and while in safe mode, all my toolbar bookmarks disappeared.

But then I noticed there was a star with a drop-down box at the end of the URL box. I honestly don't know how long it's been there, but I never noticed it before. And my bookmarks drop-down was in my toolbar until yesterday.

I found out this star is my bookmarks. So I'm good. But is there a way to move it down to my toolbar bookmarks? When I try to drag it, it simply opens. Thanks again.

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96833 answers

On Mac you can't hide the menu bar and as long as you have the Bookmarks Toolbar visible with the bookmarks then you should have the icon on that toolbar AFAIK.

Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible.

Use Toolbar Layout (Customize) to open the Customize window and set which toolbar items to display.

  • View > Toolbars > Customize
  • check that "Bookmarks Toolbar items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the toolbar palette into the Customize window to the Bookmarks Toolbar
  • if missing items are in the toolbar palette then drag them back from the Customize window on the toolbar
  • if you do not see an item on a toolbar and in the toolbar palette then click the "Restore Default Set" button to restore the default toolbar setup

You can check for problems caused by a corrupted localstore.rdf file if this didn't help.

PhineasBoggs 1 solutions 8 answers

My eyes are crossing and I'm in overwhelm. Any way mozilla could provide a fix? E.g., a mini program that I can run and do all that?

What causes this drop down menu to disappear?

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi PhineasBoggs, what OS are you running?

On Windows, you can switch between the compact two-column menu (accessed with the orange Firefox button) and the classic menu bar that uses its own row. When using the compact menu, the Bookmarks drop-down will appear on the bar. When using the classic menu bar, the Bookmarks drop-down will be hidden.

On Mac, apparently you only have one option for the menu bar, consistent with Mac interface guidelines. Please see cor-el's post above. Although it might hurt your eyes at first, the steps only take a minute.

Einstein47 0 solutions 3 answers

I am a Windows user. I have used the Classic Menu Toolbar with the Bookmarks drop-down icon together for years and have never had an issue. Now, it seems that a poor decision was made by some developer that has removed my ability to use Firefox the way I want.

Is there a hack, registry change, or some other adjustment I can make so that I can use the Bookmarks drop-down icon while also using the Classic Menu Toolbar? Why can't I have both the Classic Menu Toolbar and the Bookmarks drop-down icon? It seems foolish to show the icon in the desired location while in "customize" mode but then hide it without any explanation.

Any help or suggestions would be appreciated.

-- Einy

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi Einstein47, as with many aspects of the UI, you can unhide the Bookmarks menu button with a custom style rule:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
#PersonalToolbar #bookmarks-menu-button {display:-moz-box !important}

This rule can be saved in a userChrome.css file or in a rule you create using the Stylish extension.

(I realize this is a bit like saying you can write Greek or Latin but I don't have time to go into the details now.)

Modified by jscher2000

jaybs 0 solutions 4 answers

My bookmark dropdown on the bar has disappeared today, I have been using this for years, please lets us have a fix!

StivBG 0 solutions 1 answers

Its not missing it just changed to icon in the uper right corner next to download history and home butons :)))

Modified by StivBG

jaybs 0 solutions 4 answers

I don't have that on the latest Firefox I have?

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi jaybs, the button is coded to appear when no other Bookmarks menu is displayed, and to hide otherwise. If you use the classic menu bar (this is optional on Windows, might not be optional on other OSes) with the same Bookmarks menu a little higher up on the screen, then the icon will be suppressed.

jaybs 0 solutions 4 answers

Thanks for your replies, they are much appreciated. I'm one of those who have used computers right back from the start, but I am no tech expert. I always had file, edit, history, bookmarks, tools, help on top and still the drop down bookmark menu on the right.

Now it seems if I have the drop down menu on the right, I can't have the toolbar options above, this only happened yesterday? So is it one or the other?

Thanks once more.

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi jaybs, this is a change in Firefox 23.

Prior to Firefox 23, when you displayed the classic menu bar, the icon would hide if it had been placed on the Navigation Toolbar, but it would not hide if it had been placed on the Bookmarks Toolbar. Someone made this consistent and now it hides wherever you place it.

I've attached a Windows 7 screen shot for reference.

As noted above, you can create a style rule to force the button to always be visible. However, I have to find a little time to document the steps to do that.

Einstein47 0 solutions 3 answers

I have been trying to "teach myself Greek", but the userChrome.css is a little more involved than the simple style sheets that I'm used to - custom objects, etc. I copy/pasted your example, but it didn't work. At least it got me a starting point where to look.

If (maybe when) I get my userChrome.css working, I'll post here. Otherwise, if someone is already fluent in Greek, if they could take a look at post an update. I bet there would be a lot of happy Foxers.

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Helpful Reply

Maybe this will help.

(1) Find (or create) the chrome folder. This is a folder in your currently active Firefox settings folder, also known as your Firefox profile folder.

  • Open the your profile folder using: Help > Troubleshooting Information
    • Windows: Click the Show Folder button
    • Mac: Click the Show in Finder button
  • Check for a chrome folder.
    • If it exists, double-click it to open it.
    • If it does not exist, create a chrome folder, then double-click it to open it.

(2) Create or Edit a userChrome.css file by adding a bookmark button rule.

  • Check for a userChrome.css file in the chrome folder.
    • If it exists, open it in a text editor and add the following lines, then save:

      /* Force bookmark drop-down button display even with classic menu bar */
      #bookmarks-menu-button {display:-moz-box !important}
       
    • If it does not exist, right-click the following link > Save Link As, and save into your chrome folder (or save in Downloads and drag to your chrome folder): http://www.jeffersonscher.com/res/userChrome-bookmarksbutton.css.

      Then rename the file to userChrome.css.

The rule change should take effect the next time you start Firefox.

Modified by jscher2000

Einstein47 0 solutions 3 answers

jscher2000 - you are a Genius!!! Thanks for the help with this - and the detailed explanation.

echo2uuc 0 solutions 5 answers

Yes he helped me and yes he is a genius. He helped and He gets 10stars out of five. I don't think anybody could have fixed my problem better the him..yes I'm talking about jscher2000

Modified by echo2uuc

Greg_Beau 0 solutions 2 answers

I did this, restarted Firefox, rebooted the PC, and no change. Running FF24.

I used to have a Bookmarks dropdown button on the Bookmarks bar. That now seems to be impossible to restore. I do not even know how I put it there originally; it no longer seems to exist. Is that true? It will allow a button to be added that gives a largely useless sidebar function, but I hate sidebars generally and this implementation specifically, and do not want that.

This kind of arbitrary change for change's sake is really frustrating.

Modified by Greg_Beau

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Helpful Reply

Hi Greg_Beau, you could try turning off the classic menu bar and restoring the default toolbar layout:

  • right-click a blank area of the tab bar (or the new tab "+" button) > uncheck Menu Bar
  • right-click a blank area of the tab bar (or the new tab "+" button) > Customize, in the dialog, click Restore Default Set

After this, the Bookmarks Menu button should appear on your main Navigation Toolbar next to the Downloads button and the Home button. Any luck?