X
Tap here to go to the mobile version of the site.

Support Forum

I cannot see any captcha, therefore the form does not work: https://www.mozilla.org/en-US/legal/fraud-report/index.html

Posted

I cannot see any captcha, therefore the form does not work: https://www.mozilla.org/en-US/legal/fraud-report/index.html

I cannot see any captcha, therefore the form does not work: https://www.mozilla.org/en-US/legal/fraud-report/index.html

Chosen solution

Hmmm, could it be...

The script that creates the CAPTCHA is on an insecure (HTTP) URL. Firefox 23 implements a new feature of blocking certain insecure content on secure pages ("mixed content blocking").

Two ways to check for that:

  • On the left side of the address bar where you normally see a lock or globe, is there a shield icon? If so, click that and (based on what I have read) you should be able to approve the insecure content.
  • Or if you manually edit the address bar from HTTPS to HTTP and load it that way, can you see the ReCaptcha box?

If this is the problem, then someone needs to fix that page ASAP!

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • VLC media player Web Plugin 2.0.6
  • SumatraPDF Browser Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

Question owner

Update: I see the captcha with IE. Will try with safe mode.

General info. OS: Windows 7. Main browser: Firefox beta (23b10 right now).

Update: I see the captcha with IE. Will try with safe mode. General info. OS: Windows 7. Main browser: Firefox beta (23b10 right now).

Question owner

Not even on safe mode. Will go to bed and restart myself... :-)

Not even on safe mode. Will go to bed and restart myself... :-)
jscher2000
  • Top 10 Contributor
8687 solutions 71011 answers

Chosen Solution

Hmmm, could it be...

The script that creates the CAPTCHA is on an insecure (HTTP) URL. Firefox 23 implements a new feature of blocking certain insecure content on secure pages ("mixed content blocking").

Two ways to check for that:

  • On the left side of the address bar where you normally see a lock or globe, is there a shield icon? If so, click that and (based on what I have read) you should be able to approve the insecure content.
  • Or if you manually edit the address bar from HTTPS to HTTP and load it that way, can you see the ReCaptcha box?

If this is the problem, then someone needs to fix that page ASAP!

Hmmm, could it be... The script that creates the CAPTCHA is on an insecure (HTTP) URL. Firefox 23 implements a new feature of blocking certain insecure content on secure pages ("mixed content blocking"). Two ways to check for that: * On the left side of the address bar where you normally see a lock or globe, is there a shield icon? If so, click that and (based on what I have read) you should be able to approve the insecure content. * Or if you manually edit the address bar from HTTPS to HTTP and load it that way, can you see the ReCaptcha box? If this is the problem, then someone needs to fix that page ASAP!
kobe 441 solutions 5048 answers
Hi, i reported a bug here. * https://bugzilla.mozilla.org/show_bug.cgi?id=900817 please dont comment in bug reports * https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Question owner

It worked by clicking the shield icon and selecting the option to show insecure content. Thank you!

It worked by clicking the shield icon and selecting the option to show insecure content. Thank you!