X
Tap here to go to the mobile version of the site.

Support Forum

Java keeps making Firefox crash despite restart and updates.

Posted
bp-e76e56ea-d036-4535-83fe-5ed442130801
bp-d2f76567-8f46-4dd8-ae6e-aa1182130801
bp-1fdcfb23-6f30-4c83-a654-959202130801
bp-d143ef12-e11b-48b2-baf8-f1d582130801
bp-c52f2552-f381-4f20-ad09-061d52130801
bp-5ea9ee54-e6b8-443d-b284-a1b442130801
bp-e46d4217-886a-4ffb-8273-a417b2130801

All of these crash reports and dozens more are what I've been experiencing within the past few days of Firefox crashing. It has gotten to the point now that I'm nearly about to give up using Firefox.

Please, if there's anyone who can help me out as soon as possible, I gotta know what's going on.

I've done the reset of Firefox, I've done the Safe Mode with Firefox, I've even uninstalled and reinstalled Firefox. This....just...keeps...HAPPENING!!! Same deal with Java itself, I've uninstalled, reinstalled, and tried to even go with an older version. This....just...keeps...HAPPENING!!!

Anytime I go to a Java-used site like Facebook, this keeps happening, and has been frustrating to no end.

Please, if anyone can figure this out as soon as possible, I really appreciate this, but I'm now at my wits end and I need to use this browser instead of Chrome or any other one since I'm trying to look for employment.

<pre><nowiki>bp-e76e56ea-d036-4535-83fe-5ed442130801 bp-d2f76567-8f46-4dd8-ae6e-aa1182130801 bp-1fdcfb23-6f30-4c83-a654-959202130801 bp-d143ef12-e11b-48b2-baf8-f1d582130801 bp-c52f2552-f381-4f20-ad09-061d52130801 bp-5ea9ee54-e6b8-443d-b284-a1b442130801 bp-e46d4217-886a-4ffb-8273-a417b2130801 </nowiki></pre> All of these crash reports and dozens more are what I've been experiencing within the past few days of Firefox crashing. It has gotten to the point now that I'm nearly about to give up using Firefox. Please, if there's anyone who can help me out as soon as possible, I gotta know what's going on. I've done the reset of Firefox, I've done the Safe Mode with Firefox, I've even uninstalled and reinstalled Firefox. This....just...keeps...HAPPENING!!! Same deal with Java itself, I've uninstalled, reinstalled, and tried to even go with an older version. This....just...keeps...HAPPENING!!! Anytime I go to a Java-used site like Facebook, this keeps happening, and has been frustrating to no end. Please, if anyone can figure this out as soon as possible, I really appreciate this, but I'm now at my wits end and I need to use this browser instead of Chrome or any other one since I'm trying to look for employment.

Modified by cor-el

Chosen solution

Try to set the Boolean pref media.windows-media-foundation.enabled to false on the about:config page to disable the built-in HTML5 media player.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Google Update
  • A plugin to detect whether the Adobe Creative Cloud is installed on this machine.v_2_0_0_0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.3.133
  • VLC media player Web Plugin 2.0.6
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Unity Player 4.1.2f1
  • iTunes Detector Plug-in
  • Pando Web Plugin
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 1.138.0
  • NPWLPG
  • Version 0.9.19, Copyright 2006-2012 Veetle Inchttp://www.veetle.com/
  • Version 0.9.18, copyright 2006-2010 Veetle Inchttp://www.veetle.com/
  • EA SPORTS Game Face Plugin 1.5.3.0
  • 0.70.4
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • Firefox 23.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 9800 GT
  • adapterDescription2:
  • adapterDeviceID: 0x0605
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 3-14-2013
  • driverDate2:
  • driverVersion: 9.18.13.1422
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 9800 GT )
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.animenewsnetwork.com/
  • browser.startup.homepage_override.buildID: 20130718163513
  • browser.startup.homepage_override.mstone: 23.0
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 23.0
  • gfx.direct3d.last_used_feature_level_idx: 1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1375323191
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.expose_full_path: True
  • plugin.importedState: True
  • plugin.state.java: 0
  • plugin.state.npdeployjava: 0
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0

Misc

  • User JS: No
  • Accessibility: No
kobe 441 solutions 5048 answers

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Hello, Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back to us! Thank you.

Question owner

Sorry, it did not help. Even with the update that I did do, I'm still getting some more crashes on the Java-used sites. I'm now doing this through Chrome since even to get to this point on Firefox, I'm having major issues.

These were my last 4 crashes since the update I was able to do... https://crash-stats.mozilla.com/report/index/bp-bce4247e-faf8-4363-b88b-e804b2130801

https://crash-stats.mozilla.com/report/index/bp-1840ac6c-13b2-45fb-bebe-77e7d2130801

https://crash-stats.mozilla.com/report/index/bp-8998cdc0-ab61-4329-bd22-dbfc42130801

https://crash-stats.mozilla.com/report/index/bp-1afe3465-ad43-4079-be5d-60c2b2130801

I'm definitely now at my limit....it's either help me find out what's going on with Java, or I'm out.

Sorry, but I've been patient as long as I can be, but I can't be patient anymore.

Sorry, it did not help. Even with the update that I did do, I'm still getting some more crashes on the Java-used sites. I'm now doing this through Chrome since even to get to this point on Firefox, I'm having major issues. These were my last 4 crashes since the update I was able to do... https://crash-stats.mozilla.com/report/index/bp-bce4247e-faf8-4363-b88b-e804b2130801 https://crash-stats.mozilla.com/report/index/bp-1840ac6c-13b2-45fb-bebe-77e7d2130801 https://crash-stats.mozilla.com/report/index/bp-8998cdc0-ab61-4329-bd22-dbfc42130801 https://crash-stats.mozilla.com/report/index/bp-1afe3465-ad43-4079-be5d-60c2b2130801 I'm definitely now at my limit....it's either help me find out what's going on with Java, or I'm out. Sorry, but I've been patient as long as I can be, but I can't be patient anymore.
kobe 441 solutions 5048 answers

Can you reproduce this in Windows safe mode.

If you still can you may have to disable Silverlight and or Real Player (if you have them).

To do this go to Firefox button > Addons > Plugins.

Can you reproduce this in Windows safe mode. * windows.microsoft.com/en-us/windows/start-computer-safe-mode If you still can you may have to disable Silverlight and or Real Player (if you have them). To do this go to Firefox button > Addons > Plugins.

Question owner

In Windows Safe Mode, it works just fine.

In Windows Safe Mode, it works just fine.
kobe 441 solutions 5048 answers

It could anti-virus software, or actual malware. Also, go to the control panel and uninstall any suspicious programs.

It could anti-virus software, or actual malware. Also, go to the control panel and uninstall any suspicious programs.
cor-el
  • Top 10 Contributor
  • Moderator
17583 solutions 159079 answers

Chosen Solution

Try to set the Boolean pref media.windows-media-foundation.enabled to false on the about:config page to disable the built-in HTML5 media player.

Try to set the Boolean pref <b>media.windows-media-foundation.enabled</b> to <i>false</i> on the <b>about:config</b> page to disable the built-in HTML5 media player.

Question owner

Looks like that could be the issue here with that Boolean pref. So far, no issues with Facebook, but will continue to run and see if anything else occurs.

Looks like that could be the issue here with that Boolean pref. So far, no issues with Facebook, but will continue to run and see if anything else occurs.

Question owner

Yep, it was definitely something with that Boolean pref so I'm now back to "normal" for now at least. Many thanks for the help here. Just really freaky that all this was happening at once for it to be getting worse and worse like that.

Yep, it was definitely something with that ''' Boolean pref ''' so I'm now back to "normal" for now at least. Many thanks for the help here. Just really freaky that all this was happening at once for it to be getting worse and worse like that.