X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I can see the background through the top of firefox.

Posted

My tabs frequently become transparent like the rest of the window. I have checked enable transparency in the personalization settings because that's how I like it set up and this does not make the tabs always transparent, just suddenly for no apparent reason I can't see what they are anymore.

Chosen solution

Sometimes inexplicable graphical glitches are the result of graphics driver incompatibilities. You can minimize these issues by disabling Firefox's use of hardware graphics acceleration.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the issue resolved (or at least improved)?

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.7 r700
  • Nexon Game Controller
  • Pando Web Plugin
  • VLC media player Web Plugin 2.0.6
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 5.1.10411.0
  • NPWLPG
  • OGPlanet Game Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

Is the Firefox window currently maximized?

If that is the case and you want to keep the maximized setting the try to set the browser.tabs.drawInTitlebar pref to false on the about:config page.

Question owner

The top bar is how it looks when it happens, the bottom bar is how it normally looks.

Also Cor-el, I tried changing the setting as you suggested, then restarted firefox and it happened again after a few minutes though thanks for the response.

Modified by KlawReiFon

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Chosen Solution

Sometimes inexplicable graphical glitches are the result of graphics driver incompatibilities. You can minimize these issues by disabling Firefox's use of hardware graphics acceleration.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the issue resolved (or at least improved)?

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

Helpful Reply

You have the menu bar visible instead of the Firefox menu button and in that case what I posted above doesn't apply.

If Safe Mode didn't help then try to disable transparency in Windows.
Right click in a free space on your desktop.
Left click on Personalization.
There are four options at the bottom of the screen, choose "Window Color and Appearance".
Select a border color
Uncheck: "Enable transparency"

Question owner

cor-el I have tried that changing that setting after finding a similar post, but it doesn't solve the issue. In my screenshot, the bottom bar is how it looks normally. The top bar will just happen suddenly with no changing of any settings. It usually happens when I open another tab. After a while it sometimes fixes itself and goes back to normal, otherwise I have to restart firefox. I would rather find a way to keep my settings and stop this happening than disable transparency as I find it terrible to look at, but thanks for your input.

jscher2000 I have followed your advice, but I won't know if it has worked immediately as the problem is sporadic. I will get back to you after I've tested it for a while.