X
Tap here to go to the mobile version of the site.

Support Forum

Untrusted Connection - when I try to add a security exception, NOTHING happens

Posted

A game company Web site I go to all the time has just started giving me Untrusted Connection messages. I was able to visit it with no problems as recently as a few hours ago, but now I just get a page that says "You have asked Firefox to connect securely to [site], but we can't confirm that your connection is secure" and goes on to explain about security certificates and so on.

When I click "I understand the risks" then "Add exception", an "Add Security Exception" dialog box comes up as expected. However, when I click "Confirm Security Exception" on that dialog box (with or without clicking "Get Certificate" first), LITERALLY NOTHING happens. I don't mean I get an error message, or some result I'm not expecting, or even that the dialog box disappears. When I say nothing happens, I mean quite literally NOTHING happens. The button is not greyed out, yet clicking it has absolutely no effect. This leaves me with no means of closing the dialog box except clicking "Cancel", and therefore no means of accessing the site.

I've seen similar problems mentioned on this site, but mostly they either have the button greyed out (mine isn't) or they get a conflicting message saying the certificate is fine and doesn't need replacing (I don't). I have not seen anyone else post about my version, where everything looks normal and internally consistent yet the "Confirm Security Exception" button is non-functional.

This is not the first time I've had this problem, but it's the most annoying in that this time, it's affecting a site I normally visit several times a day rather than one I don't care that much about. As far as I recall, in my hands the "Confirm Security Exception" button has NEVER functioned, with the problem even surviving a near-total replacement of the hardware including the hard drive Firefox lives on.

A game company Web site I go to all the time has just started giving me Untrusted Connection messages. I was able to visit it with no problems as recently as a few hours ago, but now I just get a page that says "You have asked Firefox to connect securely to [site], but we can't confirm that your connection is secure" and goes on to explain about security certificates and so on. When I click "I understand the risks" then "Add exception", an "Add Security Exception" dialog box comes up as expected. However, when I click "Confirm Security Exception" on that dialog box (with or without clicking "Get Certificate" first), LITERALLY NOTHING happens. I don't mean I get an error message, or some result I'm not expecting, or even that the dialog box disappears. When I say nothing happens, I mean quite literally NOTHING happens. The button is not greyed out, yet clicking it has absolutely no effect. This leaves me with no means of closing the dialog box except clicking "Cancel", and therefore no means of accessing the site. I've seen similar problems mentioned on this site, but mostly they either have the button greyed out (mine isn't) or they get a conflicting message saying the certificate is fine and doesn't need replacing (I don't). I have not seen anyone else post about my version, where everything looks normal and internally consistent yet the "Confirm Security Exception" button is non-functional. This is not the first time I've had this problem, but it's the most annoying in that this time, it's affecting a site I normally visit several times a day rather than one I don't care that much about. As far as I recall, in my hands the "Confirm Security Exception" button has NEVER functioned, with the problem even surviving a near-total replacement of the hardware including the hard drive Firefox lives on.

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.7 r700
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • VLC media player Web Plugin 2.0.6
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • DownloadHelper 4.9.15 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • DownThemAll! 2.0.16 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7660D
  • adapterDescription2:
  • adapterDeviceID: 0x9901
  • adapterDeviceID2:
  • adapterDrivers: aticfx32 aticfx32 aticfx32 atiumdag atidxx32 atiumdva
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 7-27-2012
  • driverDate2:
  • driverVersion: 8.982.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedDriver']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7660D)
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.zoom.full: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 22.0
  • font.internaluseonly.changed: False
  • font.name.sans-serif.x-western: Calibri
  • font.size.fixed.x-western: 12
  • gfx.blacklist.direct2d: 3
  • gfx.blacklist.layers.direct3d9: 3
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1374118400
  • places.history.expiration.transient_current_max_pages: 66024
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1373433429

Misc

  • User JS: No
  • Accessibility: No
MDSms 0 solutions 4 answers

In Firefox, click on Tools/Options/Advanced/Encryption......Below "When a server requests my personal certificate:", is the "Select one automatically" button checked?

In Firefox, click on Tools/Options/Advanced/Encryption......Below "When a server requests my personal certificate:", is the "Select one automatically" button checked?

Question owner

For whatever it's worth, Chrome raises no objection when I go to the exact same site.

For whatever it's worth, Chrome raises no objection when I go to the exact same site.

Question owner

"In Firefox, click on Tools/Options/Advanced/Encryption......Below "When a server requests my personal certificate:", is the "Select one automatically" button checked? "

No, it says "Ask me every time". To be honest I have no idea which setting I should prefer there.

(Is that option even relevant? Isn't this error a case of asking for the *site's* certificate, not mine?)

"In Firefox, click on Tools/Options/Advanced/Encryption......Below "When a server requests my personal certificate:", is the "Select one automatically" button checked? " No, it says "Ask me every time". To be honest I have no idea which setting I should prefer there. (Is that option even relevant? Isn't this error a case of asking for the *site's* certificate, not mine?)

Question owner

Retried with "Select one automatically" checked - it made no apparent difference.

Retried with "Select one automatically" checked - it made no apparent difference.

Question owner

Any other ideas on what's going on here? This is still happening - it seems to affect this site (only) for a few hours every day, mostly in the wee hours of the morning. The above suggestion made no visible difference.

Any other ideas on what's going on here? This is still happening - it seems to affect this site (only) for a few hours every day, mostly in the wee hours of the morning. The above suggestion made no visible difference.
cor-el
  • Top 10 Contributor
  • Moderator
12902 solutions 118344 answers

Make sure that you do not run Firefox in (permanent) Private Browsing mode (Never Remember History).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

Check out why the site is untrusted (click "Technical Details to expand that section) and if this is caused by a missing intermediate certificate then see if you can install this intermediate certificate from another source.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer of the certificate.

You can see more Details like intermediate certificates that are used in the Details pane.

If "I Understand the Risks" is missing then this page may be opened in an (i)frame and in that case try the right-click context menu and use "This Frame: Open Frame in New Tab".

Note that some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.

Make sure that you do not run Firefox in (permanent) Private Browsing mode (Never Remember History). *https://support.mozilla.org/kb/Private+Browsing *Tools > Options > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use private browsing mode" ---- Check out why the site is untrusted (click "Technical Details to expand that section) and if this is caused by a missing intermediate certificate then see if you can install this intermediate certificate from another source. You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates. *Click the link at the bottom of the error page: "I Understand the Risks" Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate". *Click the "View..." button and inspect the certificate and check who is the issuer of the certificate. You can see more Details like intermediate certificates that are used in the Details pane. If "I Understand the Risks" is missing then this page may be opened in an (i)frame and in that case try the right-click context menu and use "This Frame: Open Frame in New Tab". Note that some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.

Modified by cor-el