X
Tap here to go to the mobile version of the site.

Support Forum

Disable untrusted connection warning

Posted

There's a particular internal site that I am working on. it has a valid self signed SSL certificate.

When I go to this site in Firefox I get this message under "technical details"

   The certificate is not trusted because it is self-signed.
   (Error code: sec_error_ca_cert_invalid)

Then I click on "add exception" because, yes, I know it is self signed. The "certificate status" section says

   Valid Certificate
   This site provides valid, verified identification.  There is no need to add an exception

And the confirm button is greyed out. So I can't go to the site because it is self signed and I cant add an exception because it's properly self signed.

There's a particular internal site that I am working on. it has a valid self signed SSL certificate. When I go to this site in Firefox I get this message under "technical details" The certificate is not trusted because it is self-signed. (Error code: sec_error_ca_cert_invalid) Then I click on "add exception" because, yes, I know it is self signed. The "certificate status" section says Valid Certificate This site provides valid, verified identification. There is no need to add an exception And the confirm button is greyed out. So I can't go to the site because it is self signed and I cant add an exception because it's properly self signed.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.71 Safari/537.36

More Information

jscher2000
  • Top 10 Contributor
3255 solutions 29690 answers

The following approaches have been suggested in past threads and bug reports:

  • Clear Firefox's cache (not sure this works)
    Edit menu > Preferences > Advanced
    On the Network mini-tab > Cached Web Content : "Clear Now"
    If you have a large hard drive, this might take a few minutes
  • "Forget about this site" - this will clear cache, history, bookmarks, and permissions for the site, and apparently also a saved certificate
    Open History > Show All History, right-click an entry for the site > "Forget about this site" or
    Type or paste about:permissions in the address bar and press Enter > select the site > click the "Forget about this site" button
The following approaches have been suggested in past threads and bug reports: * Clear Firefox's cache (not sure this works)<br>Edit menu > Preferences > Advanced<br>On the Network mini-tab > Cached Web Content : "Clear Now"<br>''If you have a large hard drive, this might take a few minutes'' * "Forget about this site" - this will clear cache, history, bookmarks, and permissions for the site, and apparently also a saved certificate<br>Open History > Show All History, right-click an entry for the site > "Forget about this site" ''or'' <br>Type or paste about:permissions in the address bar and press Enter > select the site > click the "Forget about this site" button * Reset Firefox<br>See this article: [[Reset Firefox – easily fix most problems]].
egmgulshan 0 solutions 1 answers

You just need to adjust the time. And that's it.

You just need to adjust the time. And that's it.