X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

left-click on firefox icon in taskbar shows a list of all tabs. how to just open to last tab?

Posted

I use the tab grouping feature a lot. That means I have 100s of tabs open at any one time.

The problem: once one switch between tab groups, the Firefox icon on the taskbar changes to what looks like multiple echoes of the Firefox icon. I guess it is supposed to represent multiple tab groups.

Before Firefox 20 one could click on the Firefox icon on the taskbar, and Firefox would come up and show the last tab I have been working on.

Since Firefox 20 a left-click on the Firefox icon on the taskbar now shows a tab list of 28+ seemingly random tabs. Many of them just says "Mozilla Firefox" instead of the website represented by that tab (because the tab was not accessed recently).

To open Firefox to the last tab I have been working on is now a real chore. I now have to pick one of these 28+ tabs (which is 99% of the time the wrong tab), then switch to the correct tab group, and then find the tab I have been working on. It typically takes 5-10 clicks to get back to where I was before I minimized Firefox, or before Firefox lost the focus. (In the past I could simply click on the Firefox icon on the taskbar, and Firefox restored where I last left off.)

How can I turn off the tab list that pops up when one left-click or hover the mouse over the Firefox icon on the taskbar? I would love to get the ability to minimize/restore Firefox back by clicking on the Firefox icon on the taskbar as it was in the past, not get a choice of random tabs.

Modified by Zero

Chosen solution

I think I figured it out. Under OPTIONS > OPTIONS > TABS, uncheck the box for "Show tab previews in the Windows taskbar" and then hit OK

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.8 r800
  • LogMeIn, Inc. Remote Access Components
  • GEPlugin
  • VLC media player Web Plugin 2.0.6
  • Mozilla plug-in enabling JavaScript access to game controllers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

I am on Firefox 22.0

Question owner

Once one changed between tab groups once, it is no longer possible to minimize/maximize Firefox by clicking on the Firefox icon on the taskbar. How can I restore that functionality?

Screenshot of a tab list attached.

Modified by Zero

Question owner

Okay, with a lack of replies here, here are some solutions I came up with:

  • Quit Firefox and restart it. It reduces the number of clicks to just two. It is even faster than wading through the list of tab groups and tabs to get back to the last tab I was working on.
  • Use Alt-Tab to switch between applications instead of clicking on the Firefox icon on the taskbar. I'll have to change my habits, as I'm used to clicking on the icon to toggle between applications, especially if one has many applications open. I typically have a dozen applications open at any time, and Alt-Tabbing through them all can be time-consuming.
  • I found nothing that seems related in the about:config screens, e.g. an option to turn off tab.list
  • Switch to Chrome.

Anyone got better ideas or solutions?

Modified by Zero

Question owner

For a moment there I thought the problem was fixed in Firefox 23. But the problem persists.

Modified by Zero

jcmozill 1 solutions 1 answers

Chosen Solution

I think I figured it out. Under OPTIONS > OPTIONS > TABS, uncheck the box for "Show tab previews in the Windows taskbar" and then hit OK

Question owner

Thank you jcmozill for your comment. For a moment there I got very excited. Alas, it did not work for me. The problem persists. See attached screenshot.

Just for the record, that option was already unchecked for me. For in case, I checked it and unchecked it, but it did not help.

Modified by Zero

Question owner

On second thought, after closing and re-opening Firefox, the problem is gone now. Thank you jcmozill! I'll monitor the behavior for a while to see if it permanently resolved the issue. I can only hope!

Question owner

After a few days of testing on different machines, I am now confident that jcmozill's solution does work. Thank you so much! Months of frustration is now finally resolved.