Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to fix layout.css.devPixelsPerPx=0.05 ? Too small...

  • 2 replies
  • 1 has this problem
  • 7350 views
  • Last reply by grasshopper

more options

Hi,

I messed up! I wanted to fix the resolution of the latest Mozilla update because I found it too big, so I typed about:config in the address bar, then searched for layout.css.devPixelsPerPix. It was set to -1.0, so I first set it to 1.0 then 0.05. The resolution became too small and now I can't read anything or reset its value to -1.0 Is there a way to reset FF to its default layout without having to open it? Please see picture ( 1 is the address bar, 2 is my homepage google.com as they appear now). http://i42.tinypic.com/zjcoqw.jpg

Modified by grasshopper

Chosen solution

Thank you cor-el for your input.

Somehow I managed to solve the resolution intuitively and fix the problem. It's now set to -0.55. I also Zoomed out the text from the View menu. FF Moz is more readable now.

I tried your first suggestion i.e. tweaking prefs.js opened via Notepad -- it doesn't get the changes even though I saved the file before closing it and then opened a new session of Moz.

Anyway, thank you.


WHAT I DID: Even though the writing was very small, I typed about:config in the address bar (see 1 in picture), then typed layout.css.devPixelsPerPix and double clicked just below the 4th column. A horrible looking window popped up which I intuitively understood was asking me to insert a string value. So I cancelled out what was written in the box, typed -1.0 and hit Enter. Voilà.

Read this answer in context 👍 1

All Replies (2)

more options

You can edit the prefs.js file in the Firefox profile folder with a plain text editor like Notepad and remove the line with the layout.css.devPixelsPerPx pref or change the value to 1.0

  • user_pref("layout.css.devPixelsPerPx", "1.0");
  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>\

The "Application Data" folder in XP/Win2K and the "AppData" folder in Windows Vista and Windows 7 and later versions are hidden folders.

Alternatively you can create a file user.js and place the above posted user_pref() line in the user.js file and start Firefox once to reset the pref.

After having done this and have restarted and closed Firefox you can remove the user.js file because otherwise you can't make changes to this pref that will last.

more options

Chosen Solution

Thank you cor-el for your input.

Somehow I managed to solve the resolution intuitively and fix the problem. It's now set to -0.55. I also Zoomed out the text from the View menu. FF Moz is more readable now.

I tried your first suggestion i.e. tweaking prefs.js opened via Notepad -- it doesn't get the changes even though I saved the file before closing it and then opened a new session of Moz.

Anyway, thank you.


WHAT I DID: Even though the writing was very small, I typed about:config in the address bar (see 1 in picture), then typed layout.css.devPixelsPerPix and double clicked just below the 4th column. A horrible looking window popped up which I intuitively understood was asking me to insert a string value. So I cancelled out what was written in the box, typed -1.0 and hit Enter. Voilà.

Modified by grasshopper