X
Tap here to go to the mobile version of the site.

Support Forum

Firefox not auto-filling passwords that it has saved?

Posted

This is a strange problem that I have only encountered on a few sites; it is consistently happening on a specific game website (quakelive.com).

Anyway, I have my password for my account saved. When I log in, though, the Firefox does not auto-fill the login or password fields. If I enter the login, it still does not auto-fill the password field. I know that Firefox knows the password, because if I enter the wrong one (as I frequently do), I get a pop-up with something like "Would you like to update the saved password on...?" Well, no, Mr. Firefox, I wouldn't like to update it, but I *would* like you to fill it in if you know it (which you do).

I've checked and double-checked all of the basics in the other articles; I am fairly confident that all of my password and security settings are correct. I rarely have problems on other sites, though I do recall it happening elsewhere before (quakelive seems to be the primary culprit here, and it may be a specific issue with that site). I can always go into the password manager and find it, but that sort of defeats the purpose.

Any ideas?

This is a strange problem that I have only encountered on a few sites; it is consistently happening on a specific game website (quakelive.com). Anyway, I have my password for my account saved. When I log in, though, the Firefox does not auto-fill the login or password fields. If I enter the login, it still does not auto-fill the password field. I know that Firefox knows the password, because if I enter the wrong one (as I frequently do), I get a pop-up with something like "Would you like to update the saved password on...?" Well, no, Mr. Firefox, I wouldn't like to update it, but I *would* like you to fill it in if you know it (which you do). I've checked and double-checked all of the basics in the other articles; I am fairly confident that all of my password and security settings are correct. I rarely have problems on other sites, though I do recall it happening elsewhere before (quakelive seems to be the primary culprit here, and it may be a specific issue with that site). I can always go into the password manager and find it, but that sort of defeats the purpose. Any ideas?

Chosen solution

I believe this is caused by the website.. some websites might purposely make sure that you cannot use autofill, this is usually for security reasons or anti-spam measures.

Read this answer in context 7

Additional System Details

Installed Plug-ins

  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • Unity Player 4.1.2f1
  • 5.1.20125.0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • QUAKE LIVE
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

JacobAreford 3 solutions 13 answers

Chosen Solution

I believe this is caused by the website.. some websites might purposely make sure that you cannot use autofill, this is usually for security reasons or anti-spam measures.

I believe this is caused by the website.. some websites might purposely make sure that you cannot use autofill, this is usually for security reasons or anti-spam measures.
cor-el
  • Top 10 Contributor
  • Moderator
17568 solutions 158903 answers

Make sure that you do not run Firefox in (permanent) Private Browsing mode (Never Remember History).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"
Make sure that you do not run Firefox in (permanent) Private Browsing mode (Never Remember History). *https://support.mozilla.org/kb/Private+Browsing *Tools > Options > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use private browsing mode"

Question owner

While frustrating, I think that the problem is limited to that one specific website. It is definitely annoying that Firefox knows the password but won't enter it, but I can deal with it I imagine. It would be nice to know what about the site actually prevents the feature from working.

cor-el: My privacy options were set correctly and Firefox remembers passwords for most sites that I frequently use. I marked your comment as helpful since it is probably a good thing for others to check first if they were to come across this page.

While frustrating, I think that the problem is limited to that one specific website. It is definitely annoying that Firefox knows the password but won't enter it, but I can deal with it I imagine. It would be nice to know what about the site actually prevents the feature from working. cor-el: My privacy options were set correctly and Firefox remembers passwords for most sites that I frequently use. I marked your comment as helpful since it is probably a good thing for others to check first if they were to come across this page.

Modified by agp1

cor-el
  • Top 10 Contributor
  • Moderator
17568 solutions 158903 answers

This web page isn't using autocomplete=off, so normally Firefox would fill the name and password.

You can check in the Password Manager if you have multiple names saved from the domain because that will prevent Firefox from filling the name automatically.

  • Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords"
This web page isn't using autocomplete=off, so normally Firefox would fill the name and password. You can check in the Password Manager if you have multiple names saved from the domain because that will prevent Firefox from filling the name automatically. *Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords"

Question owner

If you're interested in getting to the root of it, I'll keep feeding you information.

I only have one log in name stored for the site. Some other places where I have multiple logins stored, the password will be entered once I enter the login. That doesn't happen on any of the quakelive.com prompt screens. It doesn't automatically fill in anything on the page.

If you're interested in getting to the root of it, I'll keep feeding you information. I only have one log in name stored for the site. Some other places where I have multiple logins stored, the password will be entered once I enter the login. That doesn't happen on any of the quakelive.com prompt screens. It doesn't automatically fill in anything on the page.
cor-el
  • Top 10 Contributor
  • Moderator
17568 solutions 158903 answers

There isn't a drop-down list opening as well if you double-click an empty name field or press the Down key after entering the name field?

You can try to remove the current entry in the Password Manager and see if saving a new name and password works (the site may have changed the names of the input fields).

There isn't a drop-down list opening as well if you double-click an empty name field or press the Down key after entering the name field? You can try to remove the current entry in the Password Manager and see if saving a new name and password works (the site may have changed the names of the input fields).
techtive 0 solutions 4 answers

In my case none of my saved passwords or user IDs are auto filled. It is as though there is a flag I need to set. i am talking about bnking, email, even Firefox suport.

In my case none of my saved passwords or user IDs are auto filled. It is as though there is a flag I need to set. i am talking about bnking, email, even Firefox suport.
cor-el
  • Top 10 Contributor
  • Moderator
17568 solutions 158903 answers

There are a few reasons that I know of that can cause this.
The already mentioned PB mode and having more than one name and password saved and having the signon.autofillForms pref set to false on the about:config page.
Extensions can also be doing this.

There are a few reasons that I know of that can cause this.<br /> The already mentioned PB mode and having more than one name and password saved and having the <b>signon.autofillForms</b> pref set to false on the <b>about:config</b> page.<br /> Extensions can also be doing this.
Mel-11 0 solutions 1 answers

I'm having the same problem. It's only for a couple of sites. The rest seem to be ok (including this one!)

How can you tell if the website is not allowing autocomplete?

I'm having the same problem. It's only for a couple of sites. The rest seem to be ok (including this one!) How can you tell if the website is not allowing autocomplete?
JacobAreford 3 solutions 13 answers

Here is the login form part of that page's source:


'

<a onclick="quakelive.TrackEvent(quakelive.path, 'Click Register')" href="#!register"> <form id="loginform" action="https://secure.quakelive.com/user/login" method="post" name="loginform">

<--div id="login_form">

<--input class="goButton" type="submit" name="submit" value="">

<--div class="cl">

<--div id="login_email_box">

<--div class="login_text">Email:

<--div class="login_input_box inactive">

<--input id="in_email" type="text" tabindex="101" value="" name="email">

<--/div>

<--/div>'
<--div class="fourpxv">

<--div id="login_div"> <--a onclick="quakelive.TrackEvent(quakelive.path, 'Click Register')" href="#!register"> <--form id="loginform" action="https://secure.quakelive.com/user/login" method="post" name="loginform">

<--div id="login_form">

<--input class="goButton" type="submit" name="submit" value=""> <--div class="cl"></div>

<--div id="login_email_box">

<--div class="login_text">Email:</div>

<--div class="login_input_box inactive">

<--/div>

<--/div>

Here is the login form part of that page's source: ''''<div class="fr mainLogoRight"> <div class="fourpxv"></div> <div id="login_div"> <a onclick="quakelive.TrackEvent(quakelive.path, 'Click Register')" href="#!register"> <form id="loginform" action="https://secure.quakelive.com/user/login" method="post" name="loginform"> <--div id="login_form"> <--input class="goButton" type="submit" name="submit" value=""> <--div class="cl"></div> <--div id="login_email_box"> <--div class="login_text">Email:</div> <--div class="login_input_box inactive"> <--input id="in_email" type="text" tabindex="101" value="" name="email"> <--/div> <--/div>''''<div class="fr mainLogoRight"> <--div class="fourpxv"></div> <--div id="login_div"> <--a onclick="quakelive.TrackEvent(quakelive.path, 'Click Register')" href="#!register"> <--form id="loginform" action="https://secure.quakelive.com/user/login" method="post" name="loginform"> <--div id="login_form"> <--input class="goButton" type="submit" name="submit" value=""> <--div class="cl"></div> <--div id="login_email_box"> <--div class="login_text">Email:</div> <--div class="login_input_box inactive"> <i--nput id="in_email" type="text" tabindex="101" value="" name="email"> <--/div> <--/div>''

Modified by JacobAreford

techtive 0 solutions 4 answers

With webmail and other sites I would expect to have more than one sign in and would also expect Firefox to cope with this. The comment about config has gone over my head. I don't see any such link in the Options or Help menus. Is there a future plan to improve the login feature?

With webmail and other sites I would expect to have more than one sign in and would also expect Firefox to cope with this. The comment about config has gone over my head. I don't see any such link in the Options or Help menus. Is there a future plan to improve the login feature?

Modified by techtive

techtive 0 solutions 4 answers

Is this pointing to a error in the Firefox setup? I dont think we users have access to the page's source.

Is this pointing to a error in the Firefox setup? I dont think we users have access to the page's source.
subo.dh 0 solutions 1 answers

it's also not working in ubi.com, vodafone.in embarassing

it's also not working in ubi.com, vodafone.in embarassing
dvdsteve 0 solutions 6 answers

I have the same problem and a work-around that is a pain but works for me. I use the save passwords facility and when I want to say, login in to one of my Yahoo accounts, I used to simply type the first character of my Yahoo account name and FF would either show a dropdown list of all of my accounts starting with that character or, if only one account exists starting with the typed character, FF shows just that one in the dropdown list. When I click on the selected account name, FF auto-fills the password box. Since updating to FF V25 this functionality appears compromised, on first use after starting FF it may work but then on the next use, nothing happens when I type the first character of the account name. TO MAKE IT WORK AGAIN, I click on Tools, select Options and ensure that the Security tab is visible (where I can see 'Remember Passwords for Sites' is ticked), then I click on OK (WITHOUT DOING ANYTHING ELSE) then it works correctly in giving the dropdown list of account names and auto-completing the password when I select an account name. I do the above procedure every time FF doesn't display the dropdown of account names and it fixes the problem - I don't do anything on the Options window other than click OK ! I would have thought that FF developers could emulate the process I use and determine why FF needs me to do it. Regards, Steve 8th November 2013.

I have the same problem and a work-around that is a pain but works for me. I use the save passwords facility and when I want to say, login in to one of my Yahoo accounts, I used to simply type the first character of my Yahoo account name and FF would either show a dropdown list of all of my accounts starting with that character or, if only one account exists starting with the typed character, FF shows just that one in the dropdown list. When I click on the selected account name, FF auto-fills the password box. Since updating to FF V25 this functionality appears compromised, on first use after starting FF it may work but then on the next use, nothing happens when I type the first character of the account name. TO MAKE IT WORK AGAIN, I click on Tools, select Options and ensure that the Security tab is visible (where I can see 'Remember Passwords for Sites' is ticked), then I click on OK (WITHOUT DOING ANYTHING ELSE) then it works correctly in giving the dropdown list of account names and auto-completing the password when I select an account name. I do the above procedure every time FF doesn't display the dropdown of account names and it fixes the problem - I don't do anything on the Options window other than click OK ! I would have thought that FF developers could emulate the process I use and determine why FF needs me to do it. Regards, Steve 8th November 2013.
Motasem 1 solutions 19 answers

thanks u this fixes the problem <3 but i wonder how it was turn to false !!!

thanks u this fixes the problem <3 but i wonder how it was turn to false !!!
cor-el
  • Top 10 Contributor
  • Moderator
17568 solutions 158903 answers

Did you try to click elsewhere on the page or in the user interface to move the focus temporarily out of the input field and then click again in the input field?

Did you try to click elsewhere on the page or in the user interface to move the focus temporarily out of the input field and then click again in the input field?
dvdsteve 0 solutions 6 answers

I've tried clicking somewhere on the Yahoo sign-in page that has no effect other than to shift focus out of the user-ID area, on clicking back in the use-ID box, still no auto-complete works. If I click on Tools, Options, Cancel and then click in the user-ID box (which still has first character of my user-ID in it), auto-complete suggestions are displayed correctly. If I then clear the user-ID box and then type in the first character, auto-complete once again does not work. If I then click on Tools,Options and Cancel, it works again. So, I'm no further in solving this - for me it's only on the Yahoo sign-in page, my other 20 or so sign-in pages work ok all of the time. Regards, Steve.

I've tried clicking somewhere on the Yahoo sign-in page that has no effect other than to shift focus out of the user-ID area, on clicking back in the use-ID box, still no auto-complete works. If I click on Tools, Options, Cancel and then click in the user-ID box (which still has first character of my user-ID in it), auto-complete suggestions are displayed correctly. If I then clear the user-ID box and then type in the first character, auto-complete once again does not work. If I then click on Tools,Options and Cancel, it works again. So, I'm no further in solving this - for me it's only on the Yahoo sign-in page, my other 20 or so sign-in pages work ok all of the time. Regards, Steve.
Bertram_Moshier 0 solutions 24 answers

I'm having this problem with Google and Yahoo. (To insure we're talking about the same issue:

1) The username and password are in the Firefox Saved Password list 2) Google & Yahoo remember the username, but doesn't display / insert the password into the password field.)

I understand some sites might not like the saved password feature, but its my browser in the comfort of my own home. Thus I would like it to display / insert the password in the password field. How do I do this?

(BTW, I'm on Firefox 19, as I love the "Tab Utilities" add-on I hope someday it will support higher Firefox levels.


(IDEA: Have an add-on that puts the password into the clip board so I could just paste the password into the field manually!!)

I'm having this problem with Google and Yahoo. (To insure we're talking about the same issue: 1) The username and password are in the Firefox Saved Password list 2) Google & Yahoo remember the username, but doesn't display / insert the password into the password field.) I understand some sites might not like the saved password feature, but its my browser in the comfort of my own home. Thus I would like it to display / insert the password in the password field. How do I do this? (BTW, I'm on Firefox 19, as I love the "Tab Utilities" add-on I hope someday it will support higher Firefox levels. (IDEA: Have an add-on that puts the password into the clip board so I could just paste the password into the field manually!!)
cor-el
  • Top 10 Contributor
  • Moderator
17568 solutions 158903 answers

Helpful Reply

You can copy the name and the password to the clip board via the Firefox Password Manager.

  • Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords"
You can copy the name and the password to the clip board via the Firefox Password Manager. *Tools > Options > Security: Passwords: "Saved Passwords" > "Show Passwords"
dvdsteve 0 solutions 6 answers

Helpful Reply

Hi, not quite the same problem - if I view the saved site/user names and saved passwords (Tools / Options / Security tab / Saved Passwords / click Show passwords), I can see the 20 or so login names and corresponding passwords i.e. FF has previously offered to save a login name and associated password and I have told it to do so. The main problem now is that when I start to sign into Yahoo using one of my several user names, I would normally have typed in the initial character and FF would display a drop down list of the user names saved for the Yahoo site that begin with that character, be it a drop down list of just one or several. I would then click on the required user name and FF would put it in the user name field and the associated password into the password field (obscured with blobs). I would then hit Enter and be signed in. Currently, when I type in the initial character of my user name for Yahoo, FF does nothing. I have to 'persuade' FF to work correctly by typing in the first character of user name, clicking on Tools / Options / Cancel (works equally well if I click on Help / About Firefox /Close but NOT simply clicking somewhere outside of the user name field), and then put the cursor back into user name and click after which FF displays the correct name in the drop down list and when I select it, FF auto completes with the correct password. Takes a couple of seconds to do and ages to describe. A maybe related issue is that if I use a new Yahoo user name and password and press Enter, FF doesn't ask if I would like to save them. FF works correctly in displaying and auto completing names and password for other sites e.g. eBay and also correctly asks if I'd like to save any new user name / password. I'm aware that user name or password may be saved to the clipboard from the Saved Passwords window which could be useful if my work around of Tools / Options / Cancel did not get around the main problem. Regards, Steve.

Hi, not quite the same problem - if I view the saved site/user names and saved passwords (Tools / Options / Security tab / Saved Passwords / click Show passwords), I can see the 20 or so login names and corresponding passwords i.e. FF has previously offered to save a login name and associated password and I have told it to do so. The main problem now is that when I start to sign into Yahoo using one of my several user names, I would normally have typed in the initial character and FF would display a drop down list of the user names saved for the Yahoo site that begin with that character, be it a drop down list of just one or several. I would then click on the required user name and FF would put it in the user name field and the associated password into the password field (obscured with blobs). I would then hit Enter and be signed in. Currently, when I type in the initial character of my user name for Yahoo, FF does nothing. I have to 'persuade' FF to work correctly by typing in the first character of user name, clicking on Tools / Options / Cancel (works equally well if I click on Help / About Firefox /Close but NOT simply clicking somewhere outside of the user name field), and then put the cursor back into user name and click after which FF displays the correct name in the drop down list and when I select it, FF auto completes with the correct password. Takes a couple of seconds to do and ages to describe. A maybe related issue is that if I use a new Yahoo user name and password and press Enter, FF doesn't ask if I would like to save them. FF works correctly in displaying and auto completing names and password for other sites e.g. eBay and also correctly asks if I'd like to save any new user name / password. I'm aware that user name or password may be saved to the clipboard from the Saved Passwords window which could be useful if my work around of Tools / Options / Cancel did not get around the main problem. Regards, Steve.