Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 21 and 22 freezes computer

  • 40 replies
  • 639 have this problem
  • Last reply by jscher2000

more options

Comment from a forum moderator

This thread at present one time had over 200 metoo votes and nearly 7.5k 24k views. So no one is saying there is not a real problem needing addressing.

Some of you may be interested in my (very long explanation) post lower down in this thread link or the short but sharp LINK ~J99
2nd edits updated figures and links ~J99

I have the problem that lately Firefox keeps freezing/hanging my computer, making it totally unresponsive, the only fix is a hard reboot. The freeze often occurs just moments after I start the browser and go to a website, which site I visit does not seem to matter. Sometimes it has seemed about to freeze, lagging the cursor, but then catching up and making it.

I've just tried using IE instead, and I have no freezes. But I would very much like to fix this problem and get back to using Firefox.

I updated Firefox from version 21 to the most current 22, no difference. I've also tried updating Flash Player and when that did nothing I disabled all plugins, nothing as well. I've run a full anti-virus scan, so it's likely not a virus. I've also tried reinstalling my Graphic Card drivers, with no result.

The computer is my HTPC and is thusly connected to a 46" TV. I run with 150% DPI scaling in Windows 7 to be able to see text better. Since it's my HTPC I don't use the computer every day, so the most recent driver change I've done was updating my Graphic Card drivers, but if it's connect I can't say since reinstalling the driver again did nothing.

Specs: OS: Windows 7 64-bit Barebone: Shuttle FZ68 CPU: Intel i3 2100 3.10 GHz RAM: 8GB DDR3 GPU: EVGA GeForce GTX 460 768MB

Modified by John99

All Replies (20)

more options


Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Hello, FYI

  I try to start firefox (22) in safe mode and the freezing problem is still here.
  The browser freeze when after call to multipart/data form. It seems to be released after a timeout (aprox 30s -1 min).

With aurora 21.0.a2 the problem does not occur, as for other browsers.

Modified by +glop

more options

Seems like this bug (still unsolved): If you have the same problem, consider voting up that bug.

Comment by a forum moderator. I have put a line through some of the above. That bug and some related bugs are resolved i.e.the known issues seem to have been fixed. There is now no point in voting in those bugs. ~J99

Modified by John99

more options


Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

Ok, I followed your instructions and it made no difference. Thank you for the suggestion. Judging from the comments on the Bugzilla board, this is a very specific bug that is reproducible by many users. It may require a code change and update rather than fiddling on the users' end. Or perhaps there is a bug in the most recent Java version? Firefox runs on Java, yes?

more options

Hi NerdyTechie, I think there might be two different problems being discussed in this thread:

(1) Original issue that Firefox freezes Windows after starting the browser;

(2) Second issue that when you resume Windows from "sleep", that Firefox 21 is unresponsive for a long period of time (but other applications are not affected).

Which problem do you have?

For what it's worth, Firefox does not run on Java and you do not need the Java plugin for most sites.

Modified by jscher2000

more options

Hi Aethyr, could you also undertake these prophylactic steps that address the most common issues with the Flash player plugin. I'm sure you've seen some of it before, but just in case:

(1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, [as noted in a previous post] un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe:

(3) Disable protected mode (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

more options

Thanks for the prompt reply. I should have included the bug report I was talking about. It's this one: If the computer falls asleep with Firefox open, then upon awakening, has a problem refreshing the UI. Clicking the systray a couple of times forces a single refresh but the problem continues. I can quit Firefox normally, choose close all tabs, and when I reopen Firefox I can choose to restore the prior session and everything works fine. This is definitely related to something that is happening when the computer either falls asleep or wakes from sleep.

more options


Your problem is off topic for this thread. Please start a new thread or join a discussion about Firefox being unresponsive after resuming from "sleep".

more options

Disabling graphics hardware acceleration; Seems to be the solution to my problem, Thanks.

Modified by +glop

more options

OOps - my bad. I read so many threads that I thought this was another one of them. I'll stick to bugzilla thread then. Thanks for the heads-up.

more options

To the original poster with the problem, i had the same issue just tonight 7/9 and fixed it.

The problem was my computer asked me to update my Adobe Flash Player. I did so but it didn't install saying 'action list not found'. I am on Windows 7 btw. Then when I tried to run FF 22, it would just hang and I would need to kill my computer and turn it back on. I tried my other browsers such as Chrome and IE and same thing, when it tried to load a page, whole computer froze and i had to turn off turn on the computer to get it back up.

I uninstalled FF and then used IE to download Flash Player. I got the same error with the 'action list not found' but directed me to a troubleshooting page. I did a search on 'actionlist not found' error, and it had a direct download link to flash thru IE. I did that, installed the newest version of Flash and it didnt give me the actionlist error.

Then I used Chrome, opened the browser, went to a page, then it froze on me again, but this time I let it run, and some window popped up for split second so I didnt know what it said, but then the webpage unfroze and everything was back to normal. I then redownloaded FF and it has been working without the freezing problem ever since.

I hope this helps.

more options

Not too sure your solution is likely to work for everyone.

It may be noted that FlashPlayer is separate on Firefox IE & Chrome. It is totally different software on IE Firefox & Chrome. I am not sure however if some of the installers may be able to update Firefox & IE at the same time. The Flash Player for Chrome is integrated with Chrome and will update separately.

(As an aside IIRC it may actually be possible to run the Chrome plugin in Firefox under linux, but it that is obviously not supported and is not something I have ever tried)

more options

I've had this problem too, have been keeping flash and flash player up to date. I've disabled the 'use hardware acceleration where possible' option and will notify if this seems to fix the problem. Using Firefox 22.0 Windows 7 Professional (64bit)

Modified by Tikaro

more options

Recently I had been having this problem also. I tried disabling all add-ons and still I had this issue. Finally I disabled the "Java Deployment Toolkit" plugin and that appears to have solved my problem. Previously I wasn't able to go 20 minutes before a lockup and now I haven't had one in several hours.

As an added bonus that plugin is no to be vulnerable so I also increased the security of my system!

more options

I am running Windows 7 and have experienced Firefox 22 hanging after wakeup as well. I found that if I click a tab on the hung page I get no response other than the titlebar changes to the title of the page associated with that tab. But if I click a menu item like TOOLS after I click the tab the page refreshes with the page of the last tab I clicked. None of the links work on the page. The menu items drop down, the submenus are active but clicking on one does nothing

more options

Hi page1, the problem of Firefox taking an excessively long time to wake up from sleep should be fixed in Firefox 23 (coming August 6th). If you want to try Firefox 23 now, you can install it from the beta page here:

Before doing that, you might want to make a backup of your personal settings folder (AKA your Firefox profile folder) just in case something goes wrong. This article has some tips on that: Back up and restore information in Firefox profiles.

more options

Recent Firefox freeze my computer's manage (windows explorer) frequently. When it happens, the taskbar locked with busy cursor, you can not access it anymore, start button, running tasks etc all locked. I can bring up the task process explorer (a better version of task manager) by press CTRL+ALT+DEL and can kill all the live processes except firefox. When it locked the windows Explorer, FireFox can not be killed. I even can not kill the Explorer.

Some time the explorer is not frozen, but the problem came from logout, whenever I try to shutdown the machine, it hangs on there forever, and again it is firefox locked on background and obviously windows can not shut it down.

The aggressive updates/upgradings of FF are not good. It simple broken what was working and introduced more problems. I do not think aggressive upgrading will bring more users, actually it is killing Firefox cause upgrading causes more problems than the features added in.

FF has plenty of features already, and most of user even do not uses half of them. So why FF is trying to add more features by broken it? Stability is much more important.

more options

Hi wgm192, does this problem occur when you interact with Windows to upload, save, or download files? I don't want to torment you with having to restart over and over, but if you can find a pattern to what Firefox is doing when it locks up, that would be helpful in tracking down the cause of it.

Meanwhile, it might be helpful to run Firefox in its Safe Mode. The disadvantage is that your extensions are disabled. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Or, if Firefox not running, hold down the Shift key when starting it to call up the Safe Mode dialog.

more options

Hi jscher2000,

Recently, I did download and upload files quite often.

But I noticed the previous version had problem of hang up on FlashPlayer, it looks different from current case, it locked up whole screen with CPU usage running high for about 5 seconds (or longer), then pop up a prompt windows saying that the flashplayer plug-in crashed. When that happened, Windows also could not be log off and be shutdown, and the FireFox process also could not be killed even windows comes back to 'alive' .

After upgraded to latest version, it doesn't lock whole screen anymore , nor will it show the flashplayer crashing window. When Firefox had problem and stuck in background running, I even do not notice that, because all running program still running well except the explorer task bar area, When I move mouse to task-bar and see the busy running cursor , then I know something happened..

If I noticed something new, I'll send it to you.


OS : Vista FF version: 23.0.1 CPU : core 2 duo. ..

  1. 1
  2. 2