X
Tap here to go to the mobile version of the site.

Support Forum

All text displaying too large, Ctrl+0 doesn't fix

Posted

Turned on Firefox this afternoon to find all text rendering about 30% too big. Icons in tabs and on bookmark bar are too big, as well. If I press Ctrl+- twice, then it looks normal, but Ctrl+0 sets everything to abnormally large again. Gmail in particular looks wrong no matter what I set the zoom to, as if the UI is too big but the text is too small.

I have no idea what's going on. Restarting Firefox multiple times didn't help. Disabling every addon and plugin didn't help.

Turned on Firefox this afternoon to find all text rendering about 30% too big. Icons in tabs and on bookmark bar are too big, as well. If I press Ctrl+- twice, then it looks normal, but Ctrl+0 sets everything to abnormally large again. Gmail in particular looks wrong no matter what I set the zoom to, as if the UI is too big but the text is too small. I have no idea what's going on. Restarting Firefox multiple times didn't help. Disabling every addon and plugin didn't help.

Chosen solution

Can you use Ctrl++ (full page zoom) to increase the size on Gmail? I'm sure that on at least a few sites you might need to do that, depending on your screen's pixel size.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.1.3.13728
  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • Google Update
  • Unity Player 4.1.2f1
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • 5.1.20125.0
  • Amazon MP3 Downloader Plugin 1.0.17
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Zeon PDF Plugin For Mozilla
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Add-on Compatibility Reporter 2.0.1 (compatibility@addons.mozilla.org)
  • FoxClocks 3.1.26 ({d37dc5d0-431d-44e5-8c91-49419370caa1})
  • Lazarus: Form Recovery 2.3 (lazarus@interclue.com)
  • LJlogin 2.2.1 ({ad4ee9e5-49c7-4589-acf3-db9fa76a95c9})
  • Rikaichan 2.07 ({0AA9101C-D3C1-4129-A9B7-D778C6A17F82})
  • Rikaichan Japanese-English Dictionary File 2.01.110527 (rikaichan-jpen@polarcloud.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Tumblr Savior 0.4.8 (jid1-W5guVoyeUR0uBg@jetpack)
  • abcTajpu "a b c type-oo" 1.8.3 ({15a7ef52-8a77-426e-9e17-e21af257d7c8}) (Inactive)
  • Comment Snob 4 (youtube-comment-snob@efinke.com) (Inactive)
  • Download YouTube Videos as MP4 1.5.18 ({b9bfaf1c-a63f-47cd-8b9a-29526ced9060}) (Inactive)
  • HerpDerp 1.2 (jid0-Iix25kwA6rvhf6Tw5M2NpHRlXvo@jetpack) (Inactive)
  • Japanese-English Dictionary for rikaichan 1.10 ({6D898772-AD34-4c16-86BB-9DE787A5DEA0}) (Inactive)
  • Memory Fox 7.4 ({E173B749-DB5B-4fd2-BA0E-94ECEA0CA55B}) (Inactive)
  • YoYo Games InstantPlay 1.1.0.20 (yyginstantplay@yoyogames.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 560M
  • adapterDescription2:
  • adapterDeviceID: 0x1251
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 3071
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 5-15-2012
  • driverDate2:
  • driverVersion: 8.17.13.142
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 560M )
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: http://www.netvibes.com/
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.tabs.autoHide: True
  • browser.tabs.onTop: False
  • browser.tabs.warnOnOpen: False
  • dom.disable_open_during_load: False
  • dom.max_chrome_script_run_time: 0
  • dom.max_script_run_time: 1800
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.checkCompatibility: False
  • extensions.checkCompatibility.10.0: False
  • extensions.checkCompatibility.10.0a: False
  • extensions.checkCompatibility.11.0: False
  • extensions.checkCompatibility.11.0a: False
  • extensions.checkCompatibility.12.0: False
  • extensions.checkCompatibility.12.0a: False
  • extensions.checkCompatibility.3.6: False
  • extensions.checkCompatibility.3.6b: False
  • extensions.checkCompatibility.3.6p: False
  • extensions.checkCompatibility.3.6pre: False
  • extensions.checkCompatibility.3.7a: False
  • extensions.checkCompatibility.4.0: False
  • extensions.checkCompatibility.4.0b: False
  • extensions.checkCompatibility.4.0p: False
  • extensions.checkCompatibility.4.0pre: False
  • extensions.checkCompatibility.4.2: False
  • extensions.checkCompatibility.4.2a: False
  • extensions.checkCompatibility.4.2b: False
  • extensions.checkCompatibility.4.2p: False
  • extensions.checkCompatibility.4.2pre: False
  • extensions.checkCompatibility.5.0: False
  • extensions.checkCompatibility.5.0a: False
  • extensions.checkCompatibility.5.0b: False
  • extensions.checkCompatibility.5.0p: False
  • extensions.checkCompatibility.5.0pre: False
  • extensions.checkCompatibility.6.0: False
  • extensions.checkCompatibility.6.0a: False
  • extensions.checkCompatibility.7.0: False
  • extensions.checkCompatibility.7.0a: False
  • extensions.checkCompatibility.8.0: False
  • extensions.checkCompatibility.8.0a: False
  • extensions.checkCompatibility.9.0: False
  • extensions.checkCompatibility.9.0a: False
  • extensions.checkCompatibility.nightly: False
  • extensions.lastAppVersion: 22.0
  • font.size.variable.x-western: 12
  • general.useragent.extra.microsoftdotnet: (.NET CLR 3.5.30729)
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://search.conduit.com/ResultsExt.aspx?ctid=CT3289847&SearchSource=2&CUI=UN34913451029396173&UM=2&q=
  • network.cookie.prefsMigrated: True
  • network.protocol-handler.warn-external.dnupdate: False
  • places.database.lastMaintenance: 1372810927
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1322105362
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.flash: 2
  • plugin.state.java: 2
  • plugin.state.npamazonmp3downloaderplugin: 2
  • plugin.state.npauthz: 2
  • plugin.state.npgoogletalk: 2
  • plugin.state.npgoogleupdate: 2
  • plugin.state.npgtpo3dautoplugin: 2
  • plugin.state.npnv3dv: 2
  • plugin.state.npnv3dvstreaming: 2
  • plugin.state.npo1d: 2
  • plugin.state.nppdf: 2
  • plugin.state.npspwrap: 2
  • plugin.state.npunity3d: 2
  • plugin.state.npwlpg: 2
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.csp.enable: False
  • security.OCSP.enabled: 0
  • security.warn_viewing_mixed: False
  • security.warn_viewing_mixed.show_once: False
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1368541000

Misc

  • User JS: Yes
  • Accessibility: No
kobe 441 solutions 5048 answers

Helpful Reply

Hello,

Firefox on Windows is now following display scaling options which may render text larger on high resolution displays. You can adjust your screen resolution. To modify it do the following:

  • Type about:config into the Firefox address bar and tap on the Enter key.
  • If the warning This might void your warranty appears, click I'll be careful, I promise.
  • Search for layout.css.devPixelsPerPx

Fx22layout.css.devPixelsPerPx

  • Double-click on layout.css.devPixelsPerPx to modify its value. The default is -1.0 in Firefox 22 and above. Change it to 1.0 to make it work like in previous Firefox versions.

If necessary, further adjust the value in 0.1 or 0.05 steps. Use values between 1.0 and about 0.5 to reduce elements in size. Use values greater than 1.0 to increase size. For example, a value of 1.25 will increase font size to 125% to accommodate the default DPI setting in Windows 8. Double check the value that you enter. Setting a too small value will make everything disappear and a too large value will blow things up.

If web pages still need to be adjusted then you can look at the Default FullZoom Level or NoSquint extension.

To adjust the font size for the user interface, you can use the Theme Font & Size Changer extension.

Did this fix your problems? Please report back to us!

Thank you.

Hello, Firefox on Windows is now following display scaling options which may render text larger on high resolution displays. You can adjust your screen resolution. To modify it do the following: * Type '''about:config''' into the Firefox address bar and tap on the Enter key. * If the warning '''This might void your warranty''' appears, click '''I'll be careful, I promise'''. * Search for '''layout.css.devPixelsPerPx''' [[Image:Fx22layout.css.devPixelsPerPx]] * Double-click on layout.css.devPixelsPerPx to modify its value. The default is -1.0 in Firefox 22 and above. Change it to '''1.0''' to make it work like in previous Firefox versions. If necessary, further adjust the value in 0.1 or 0.05 steps. Use values between 1.0 and about 0.5 to reduce elements in size. Use values greater than 1.0 to increase size. For example, a value of 1.25 will increase font size to 125% to accommodate the default DPI setting in Windows 8. '''Double check the value that you enter.''' Setting a too small value will make everything disappear and a too large value will blow things up. If web pages still need to be adjusted then you can look at the [https://addons.mozilla.org/firefox/addon/default-fullzoom-level/ Default FullZoom Level] or [https://addons.mozilla.org/firefox/addon/nosquint/ NoSquint] extension. To adjust the font size for the user interface, you can use the [https://addons.mozilla.org/firefox/addon/theme-font-size-changer/ Theme Font & Size Changer] extension. Did this fix your problems? Please report back to us! Thank you.

Question owner

Yes, this fixed the problem in general, but it's not quite the same. I've uploaded a screenshot of what Gmail looks like now - the text there is about half as big as before, all other websites appear normal, and the text on menus and tab labels is too small. If I increase the size, then it just skews balance the other way - menus look approximately normal, websites appear too large, Gmail still looks wrong at every zoom level.

Is this Gmail thing unrelated to Firefox somehow?

Yes, this fixed the problem in general, but it's not quite the same. I've uploaded a screenshot of what Gmail looks like now - the text there is about half as big as before, all other websites appear normal, and the text on menus and tab labels is too small. If I increase the size, then it just skews balance the other way - menus look approximately normal, websites appear too large, Gmail still looks wrong at every zoom level. Is this Gmail thing unrelated to Firefox somehow?

Question owner

Update, it looks like Theme Font & Size Changer fixed the menus, but not Gmail. Looks like my problem is down to a single website.

Update, it looks like Theme Font & Size Changer fixed the menus, but not Gmail. Looks like my problem is down to a single website.
kobe 441 solutions 5048 answers

Does it display big on all google.com or news.google.com etc. google sites.

Does it display big on all google.com or news.google.com etc. google sites.

Question owner

Those look normal. The only site where the layout looks wrong, as far as I can tell, is my Gmail inbox.

Those look normal. The only site where the layout looks wrong, as far as I can tell, is my Gmail inbox.
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"
Clear the cache and the cookies from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Question owner

Cleared cache, deleted all google-related cookies, Problem persists.

Cleared cache, deleted all google-related cookies, Problem persists.
jscher2000
  • Top 10 Contributor
8773 solutions 71729 answers

Chosen Solution

Can you use Ctrl++ (full page zoom) to increase the size on Gmail? I'm sure that on at least a few sites you might need to do that, depending on your screen's pixel size.

Can you use Ctrl++ (full page zoom) to increase the size on Gmail? I'm sure that on at least a few sites you might need to do that, depending on your screen's pixel size.

Question owner

I guess it looks fine if I ++ the size back up now. Problem resolved.

I guess it looks fine if I ++ the size back up now. Problem resolved.

Question owner

I guess it looks fine if I ++ the size back up now. Problem resolved.

I guess it looks fine if I ++ the size back up now. Problem resolved.
kobe 441 solutions 5048 answers

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

'''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.''
jlford001 0 solutions 7 answers

If this is a new feature for Firefox, they should remove it... many sites no longer 'fit' into a browser window as the increased zoom forces a horizontal scroll bar.

View the differences in Firefox and Chrome here: http://tinyurl.com/q64gmpd

(Note, have cleared the cache - has not helped, have no new add-ons, and do not use a special theme.)

If this is a new feature for Firefox, they should remove it... many sites no longer 'fit' into a browser window as the increased zoom forces a horizontal scroll bar. View the differences in Firefox and Chrome here: http://tinyurl.com/q64gmpd (Note, have cleared the cache - has not helped, have no new add-ons, and do not use a special theme.)
kobe 441 solutions 5048 answers

hello jlford001,

have you followed the instructions as displayed here.

hello jlford001, have you followed the instructions as displayed here. * https://support.mozilla.org/en-US/questions/963975
jlford001 0 solutions 7 answers

Yes, read that, but don't want to change my system to support a browser.

Yes, read that, but don't want to change my system to support a browser.
kobe 441 solutions 5048 answers

Yes you are changing Firefox settings not system settings.

Yes you are changing Firefox settings not system settings.

Helpful Reply

I'll be honest - after another hour of wrestling with settings and addons to try and get everything to look right, I just transferred my settings over to Chrome and started using that.

I'll be honest - after another hour of wrestling with settings and addons to try and get everything to look right, I just transferred my settings over to Chrome and started using that.
dallwitz 0 solutions 4 answers

Safe mode made no difference for me. Changing layout.css.devPixelsPerPx to 1 did fix the text size in Web pages, but made the menus too small.

The problem is shown by the simple test file

   (html)(body)abc(/body)(/html)

(I've substituted parentheses for angle brackets.)

The text size in IE and Opera is smaller, as shown in the attached image. Perhaps a long-standing problem has been fixed in Firefox, and we should report the apparent bugs in IE and Opera.

Safe mode made no difference for me. Changing layout.css.devPixelsPerPx to 1 did fix the text size in Web pages, but made the menus too small. The problem is shown by the simple test file (html)(body)abc(/body)(/html) (I've substituted parentheses for angle brackets.) The text size in IE and Opera is smaller, as shown in the attached image. Perhaps a long-standing problem has been fixed in Firefox, and we should report the apparent bugs in IE and Opera.
jscher2000
  • Top 10 Contributor
8773 solutions 71729 answers

Hi dallwitz, because one setting governs both the chrome area (menu, toolbars, tabs) and the content area, it's hard to optimize them simultaneously.

If you prefer to set the scaling to 1.0 (size content like Firefox 21), you can use the Theme Font & Size Changer extension to enlarge the text in the chrome area.

After installing the extension and restarting Firefox, click the new "A" icon at the right end of the navigation toolbar and change the font size from Normal to 15 (if your Windows zoom is 125%).

Hi dallwitz, because one setting governs both the chrome area (menu, toolbars, tabs) and the content area, it's hard to optimize them simultaneously. If you prefer to set the scaling to 1.0 (size content like Firefox 21), you can use the [https://addons.mozilla.org/en-us/firefox/addon/theme-font-size-changer/ Theme Font & Size Changer] extension to enlarge the text in the chrome area. After installing the extension and restarting Firefox, click the new "A" icon at the right end of the navigation toolbar and change the font size from Normal to 15 (if your Windows zoom is 125%).
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers

You can look at the Default FullZoom Level or NoScript extension if web pages need to be adjusted after changing the layout.css.devPixelsPerPx pref.

You can look at the Default FullZoom Level or NoScript extension if web pages need to be adjusted after changing the layout.css.devPixelsPerPx pref. *Default FullZoom Level: https://addons.mozilla.org/firefox/addon/default-fullzoom-level/ *NoSquint: https://addons.mozilla.org/firefox/addon/nosquint/
dallwitz 0 solutions 4 answers

Thanks, jscher2000. But why should it be necessary to add an extension to get the default text size that has apparently been accepted in most, if not all, browsers for many years? It's difficult enough for Web-page designers to get the same appearance in different browsers without deliberate inconsistencies like this.

I'll wait a while before adding the extension, to see whether it gets changed back. Is it worth reporting it as a bug, or has it already been reported as such?

Thanks, jscher2000. But why should it be necessary to add an extension to get the default text size that has apparently been accepted in most, if not all, browsers for many years? It's difficult enough for Web-page designers to get the same appearance in different browsers without <i>deliberate</i> inconsistencies like this. I'll wait a while before adding the extension, to see whether it gets changed back. Is it worth reporting it as a bug, or has it already been reported as such?