X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

How to change Firefox's default zoom level

Posted

UPDATE! This question is not marked as answered, as the issue is a new 'feature' of Firefox 22, and if you read all the comments you'd see that. Clearly, with the large volume of 'new' answers coming in saying the same thing over and over, people aren't, so I'll say it here: THERE IS NO NEED TO ANSWER THIS QUESTION ANY MORE.

I recently asked about my UI being big and fuzzy, and managed to get that fixed in the about:config, but websites are still big.

For some reason, the default zoom (ctrl+0) is at 120%.

I tried the FullZoom and NoSquint addons, but both had one issue. They messed up the top level image view (which for me works with the old default image style addon) and made the unzoomed image a bit bigger than my screen, and the magnifying glass icon which should appear with a + or - in it when I mouse over the image is just a regular mouse pointer instead.

How can I reset the default zoom to be 100% (or preferably about 80% because even 100 seems to be overcompensating for my high dpi screen) without an addon messing up my default image view?


Further details. If I disable the 'old default image style' addon, the top level image view works fine with the NoSquint or FullZoom addons.

UPDATE! This question is not marked as answered, as the issue is a new 'feature' of Firefox 22, and if you read all the comments you'd see that. Clearly, with the large volume of 'new' answers coming in saying the same thing over and over, people aren't, so I'll say it here: THERE IS NO NEED TO ANSWER THIS QUESTION ANY MORE. I recently asked about my UI being big and fuzzy, and managed to get that fixed in the about:config, but websites are still big. For some reason, the default zoom (ctrl+0) is at 120%. I tried the FullZoom and NoSquint addons, but both had one issue. They messed up the top level image view (which for me works with the old default image style addon) and made the unzoomed image a bit bigger than my screen, and the magnifying glass icon which should appear with a + or - in it when I mouse over the image is just a regular mouse pointer instead. How can I reset the default zoom to be 100% (or preferably about 80% because even 100 seems to be overcompensating for my high dpi screen) without an addon messing up my default image view? --------------------------------------- Further details. If I disable the 'old default image style' addon, the top level image view works fine with the NoSquint or FullZoom addons.

Modified by EstragonHelmer

Chosen solution

hello, firefox 22 is now respecting the pixel density you've set on a system level in the windows control panel > appearance > display. more information about that is available at http://windows.microsoft.com/en-us/windows7/make-the-text-on-your-screen-larger-or-smaller

if you want to set the text size/pixel density in firefox different from that of your system's settings like it was handled in prior versions, enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named layout.css.devPixelsPerPx. double-click it and change its value to 1.0 (or any other zoom factor that fits your purpose; -1.0 is the default value and will adhere to the system settings).

Read this answer in context 14

Additional System Details

Installed Plug-ins

  • npsitesafety
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-GB/

Extensions

  • Old Default Image Style 2.2.1 (olddefaultimagestyle@dagger2-addons.mozilla.org)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 1.1 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • AVG Security Toolbar 15.3.0.11 (avg@toolbar) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16433
  • driverDate: 3-8-2013
  • driverDate2:
  • driverVersion: 9.17.10.3062
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.restore_on_demand: False
  • browser.startup.homepage: http://www.google.co.uk/ig
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 22.0
  • font.internaluseonly.changed: False
  • gfx.direct3d.last_used_feature_level_idx: 0
  • mousewheel.withcontrolkey.action: 3
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1372798210
  • places.history.expiration.transient_current_max_pages: 104326
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0

Misc

  • User JS: No
  • Accessibility: Yes
philipp
  • Top 10 Contributor
  • Moderator
3082 solutions 14317 answers

Chosen Solution

hello, firefox 22 is now respecting the pixel density you've set on a system level in the windows control panel > appearance > display. more information about that is available at http://windows.microsoft.com/en-us/windows7/make-the-text-on-your-screen-larger-or-smaller

if you want to set the text size/pixel density in firefox different from that of your system's settings like it was handled in prior versions, enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named layout.css.devPixelsPerPx. double-click it and change its value to 1.0 (or any other zoom factor that fits your purpose; -1.0 is the default value and will adhere to the system settings).

hello, firefox 22 is now respecting the pixel density you've set on a system level in the windows control panel > appearance > display. more information about that is available at http://windows.microsoft.com/en-us/windows7/make-the-text-on-your-screen-larger-or-smaller if you want to set the text size/pixel density in firefox different from that of your system's settings like it was handled in prior versions, enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''layout.css.devPixelsPerPx'''. double-click it and change its value to '''1.0''' (or any other zoom factor that fits your purpose; -1.0 is the default value and will adhere to the system settings).

Question owner

The layout.css.devPixelsPerPx. does not affect the zoom level on websites, it only worked on the UI. This was the thing I meant when I said the about:config.

I haven't tried changing the Windows setting, but as far as possible, I'd like to avoid it, as it may make menus and other OS elements more dificult to use.

The layout.css.devPixelsPerPx. does not affect the zoom level on websites, it only worked on the UI. This was the thing I meant when I said the about:config. I haven't tried changing the Windows setting, but as far as possible, I'd like to avoid it, as it may make menus and other OS elements more dificult to use.
asafisk 0 solutions 1 answers

I also have a high dpi screen and am not happy with this update in v.22. As a web developer, I absolutely love Firefox otherwise.

In my experience, I can use layout.css.devPixelsPerPx = 1.0 to fix the zoom issue for websites but now I can't read the UI text because it's so small.

Surely the default zoom (no zoom) should render a 200px image as 200px.

It would make sense to be able to control the zoom of the UI independently from the zoom of the webpage.

Yes I could change the font size setting in Windows but if I do that everything else goes tiny.

Please Firefox devs, fix it so that 200px means 200px by default and allow the user to zoom in and out if they want to. I believe this is what most of us would expect.

I also have a high dpi screen and am not happy with this update in v.22. As a web developer, I absolutely love Firefox otherwise. In my experience, I can use ''layout.css.devPixelsPerPx = 1.0'' to fix the zoom issue for websites but now I can't read the UI text because it's so small. '''Surely the default zoom (no zoom) should render a 200px image as 200px.''' It would make sense to be able to control the zoom of the UI independently from the zoom of the webpage. Yes I could change the font size setting in Windows but if I do that everything else goes tiny. Please Firefox devs, fix it so that 200px means 200px by default and allow the user to zoom in and out if they want to. I believe this is what most of us would expect.

Question owner

Yes, the addon causing issues wasn't NoSqint or FullZoom, it was the Old Default Image View, used WITH NoSquint or FullZoom.

I fixed it by turning of old image view, but I really hate the new top level image with the dark background and the centred page, which is why I could do with all these addons working together. For now, I'll have to get used to the new image view as I'd rather keep FullZoom.

Yes, the addon causing issues wasn't NoSqint or FullZoom, it was the Old Default Image View, used WITH NoSquint or FullZoom. I fixed it by turning of old image view, but I really hate the new top level image with the dark background and the centred page, which is why I could do with all these addons working together. For now, I'll have to get used to the new image view as I'd rather keep FullZoom.
philipp
  • Top 10 Contributor
  • Moderator
3082 solutions 14317 answers

Hello asafisk, first adjust the layout.css.devPixelsPerPx preference that fits the zoom factor for the UI.

If web pages still need to be adjusted then you can look at the Default FullZoom Level or NoSquint extension to set a general zoom level for websites.

Thank you.

Hello asafisk, first adjust the ''layout.css.devPixelsPerPx'' preference that fits the zoom factor for the UI. If web pages still need to be adjusted then you can look at the [https://addons.mozilla.org/firefox/addon/default-fullzoom-level/ Default FullZoom Level] or [https://addons.mozilla.org/firefox/addon/nosquint/ NoSquint] extension to set a general zoom level for websites. Thank you.
ad_verbum 1 solutions 9 answers

Helpful Reply

After instalation newest FF version (22) all pages are rendered with bigger font size than with previous FF (21) version. It is very annoying as at every page I'm visiting I need manually adjust ("Ctrl" -) proper font size.

I found this information: "firefox 22 is now respecting the pixel density you've set on a system level in the windows control panel > appearance > display."

I don't understand why it was done. I have bigger than default (120%) pixel density because I want to have bigger fonts in UI, but only in UI, not in the web content. I fully agree with asafisk words: "Please Firefox devs, fix it so that 200px means 200px by default and allow the user to zoom in and out if they want to. I believe this is what most of us would expect."

Changing property "layout.css.devPixelsPerPx" to 1.0 isn't solution as I don't want to change FF UI font size but web content font size!

I'm asking how may I get web pages looking correctly with FF22?

After instalation newest FF version (22) all pages are rendered with bigger font size than with previous FF (21) version. It is very annoying as at every page I'm visiting I need manually adjust ("Ctrl" -) proper font size. I found this information: ''"firefox 22 is now respecting the pixel density you've set on a system level in the windows control panel > appearance > display."'' I don't understand why it was done. '''I have bigger than default (120%) pixel density because I want to have bigger fonts in UI, but only in UI, not in the web content.''' I fully agree with asafisk words: ''"Please Firefox devs, fix it so that 200px means 200px by default and allow the user to zoom in and out if they want to. I believe this is what most of us would expect."'' Changing property "layout.css.devPixelsPerPx" to 1.0 '''isn't solution''' as I don't want to change FF UI font size but web content font size! I'm asking how may I get web pages looking correctly with FF22?

Modified by ad_verbum

vkapyrina 0 solutions 1 answers

Helpful Reply

Have the same issue after updating to v.22. It´s awful! I can´t zoom out every page. It is useless. Please solve this issue as fast as possible. I am developer and it´s impossible to work with Firefox now. I love this browser but this update messed it up!

Have the same issue after updating to v.22. It´s awful! I can´t zoom out every page. It is useless. Please solve this issue as fast as possible. I am developer and it´s impossible to work with Firefox now. I love this browser but this update messed it up!
Echo00 0 solutions 1 answers

What a stupid thing to do! Do they think we were unhappy with the way previous versions rendered text?

I have temporarily solved the problem by reverting to FF 21. I also changed my options NOT to update automatically. If they don't get this stupid change reversed, I may be using FF 21 for the rest of my life.

What a stupid thing to do! Do they think we were unhappy with the way previous versions rendered text? I have temporarily solved the problem by reverting to FF 21. I also changed my options NOT to update automatically. If they don't get this stupid change reversed, I may be using FF 21 for the rest of my life.
MishGEA 0 solutions 1 answers

Totally agree this was an asinine thing to do. I struggled with this for hours and it is exceptionally annoying (at best) to have Firefox autoadjust like it does.

Everything is no blurry and my own website looks awful. Going back to 21

Totally agree this was an asinine thing to do. I struggled with this for hours and it is exceptionally annoying (at best) to have Firefox autoadjust like it does. Everything is no blurry and my own website looks awful. Going back to 21
John99
  • Top 25 Contributor
  • Moderator
731 solutions 10029 answers

I think a lot of us would agree that Firefox could have handled this better. It was after all a deliberate change to Firefox. (Intended to give better support for HiDpi screens supported by modern Operating Sytems) I also think a lot of users would agree that being able to zoom content and the User Interface (Chrome) separately from an easily accessible menu option would be good idea.

All we do on this forum is have users trying to help other users with problems. We do not discuss development issues and decisions here, and you can not expect developer attention by posting here.

If you wish to make a short comment please use

If enough uses complain maybe at least the message that you are unhappy with the change will be noted, possibly then someone will even consider making an improvement.

Not sure if there is any development forum where such comments would be considered on topic but you can look through the listing:

By all means also add me-too votes in this thread or vote on helpful answers, but actually posting comments is rather pointless, unless it is a new workaround that has not already been mentioned.


Useful links:


P.S.

I think a lot of us would agree that Firefox could have handled this better. It was after all a deliberate change to Firefox. (Intended to give better support for HiDpi screens supported by modern Operating Sytems) I also think a lot of users would agree that being able to zoom content and the User Interface (Chrome) separately from an easily accessible menu option would be good idea. All we do on this forum is have users trying to help other users with problems. We do not discuss development issues and decisions here, and you can not expect developer attention by posting here. '''If you wish to make a short comment please use''' * https://input.mozilla.org/en-US/feedback If enough uses complain maybe at least the message that you are unhappy with the change will be noted, possibly then someone will even consider making an improvement. Not sure if there is any development forum where such comments would be considered on topic but you can look through the listing: * http://www.mozilla.org/about/forums/#general-development By all means also add me-too votes in this thread or vote on helpful answers, but actually posting comments is rather pointless, unless it is a new workaround that has not already been mentioned. --------------------- Useful links: * ''philipp'' has already posted this link about Windows font sizes and resolution<br />http://windows.microsoft.com/en-us/windows7/make-the-text-on-your-screen-larger-or-smaller * and an article written describing a workaround is <br /> [[Webpages are large and blurry after updating Firefox - how to fix]] * a standard answer that may have slightly different solution is here <br/>[[Forum Response - Zoom feature on Firefox 22]] *with standard information about zooming here: <br /> [[Font size and zoom - increase the size of web pages]] <br>Obviously it also allows you to decrease the sizes * the no squint add on that can work wonders for customising sizes on individual websites and is helpful if you had a mismatch between the menus size, graphics and the text of a webpage <br /> https://addons.mozilla.org/en-US/firefox/addon/nosquint/ * A last resort option or for those wanting even more control of how things display is to use Grease Monkey scripts ** https://en.wikipedia.org/wiki/Greasemonkey ** https://addons.mozilla.org/en-US/firefox/addon/greasemonkey/ ---- P.S. * this add-on also may help as a relativly painless solution to the font and text size problems after upgrading to Firefox 22<br /> https://addons.mozilla.org/en-us/firefox/addon/theme-font-size-changer/

Modified by John99

John99
  • Top 25 Contributor
  • Moderator
731 solutions 10029 answers

MishGEA,

Totally agree this was an asinine thing to do. I struggled with this for hours and it is exceptionally annoying (at best) to have Firefox autoadjust like it does. 

Everything is no blurry and my own website looks awful. Going back to 21

I do sympathise but It is unwise to use an unsupported version of Firefox.It is insecure and increases risk to your personal data and to your System.

May I suggest a better alternative may be to follow the instructions given in some of the links above. In particular please note that using about:config

and changing the preference layout.css.devPixelsPerPx value from -1.0 to 1.0 may be the major change between Firfox 21and 22 that is causing a problem and can be reversed.


To modify it do the following:

  • Type about:config into the Firefox address bar and tap on the Enter key.
  • If the warning This might void your warranty appears, click I'll be careful, I promise.
  • Search for layout.css.devPixelsPerPx

Fx22layout.css.devPixelsPerPx

  • Double-click on layout.css.devPixelsPerPx to modify its value. The default is -1.0 in Firefox 22 and above. Change it to 1.0 to make it work like in previous Firefox versions.

There are further tweaks possible but that is the main change.

MishGEA, ''Totally agree this was an asinine thing to do. I struggled with this for hours and it is exceptionally annoying (at best) to have Firefox autoadjust like it does. <br/><br/>Everything is no blurry and my own website looks awful. Going back to 21'' -------- I do sympathise but It is unwise to use an unsupported version of Firefox.It is insecure and increases risk to your personal data and to your System. *[[Install an older version of Firefox]] May I suggest a better alternative may be to follow the instructions given in some of the links above. In particular please note that using about:config * http://kb.mozillazine.org/About:config and changing the preference ''layout.css.devPixelsPerPx'' value from -1.0 to 1.0 may be the major change between Firfox 21and 22 that is causing a problem and can be reversed. ---------- To modify it do the following: * Type '''about:config''' into the Firefox address bar and tap on the Enter key. * If the warning '''This might void your warranty''' appears, click '''I'll be careful, I promise'''. * Search for '''layout.css.devPixelsPerPx''' [[Image:Fx22layout.css.devPixelsPerPx]] * Double-click on layout.css.devPixelsPerPx to modify its value. The default is -1.0 in Firefox 22 and above. Change it to '''1.0''' to make it work like in previous Firefox versions. There are further tweaks possible but that is the main change.
John99
  • Top 25 Contributor
  • Moderator
731 solutions 10029 answers

I forgot to mention this is also an add-o that can help those having problems with blurry fonts and wrong size text after upgrading to Firefox 22

I forgot to mention this is also an add-o that can help those having problems with blurry fonts and wrong size text after upgrading to Firefox 22 * https://addons.mozilla.org/en-us/firefox/addon/theme-font-size-changer/
mackynyxz86 0 solutions 1 answers

Hi when my firefox updated to ver22 it seems that the webpages are zoom when i click ctr + 0 which is the default of all pages it seems very zoom why is this happening to ff?? to all the ff dev pls fix this its so annoying

Hi when my firefox updated to ver22 it seems that the webpages are zoom when i click ctr + 0 which is the default of all pages it seems very zoom why is this happening to ff?? to all the ff dev pls fix this its so annoying
John99
  • Top 25 Contributor
  • Moderator
731 solutions 10029 answers

EVERYONE,

If you have a problem with zoom and large text in Windows please read this thread and the linked articles. If that does not solve your problems please start your own thread using /questions/new

You will not receive developer attention posting in this forum. All you are doing is posting in a user help forum where users help other users. If you wish to have a comment logged please use


EXPLANATION

mackynyxz86,
As I understand it the problem stems from the need for Firefox to work on very many device types and a large range of displays of differing sizes and a wide range of screen resolutions.

In particular some newer Operating Systems now support very high Dot Per Inch settings. Deliberate changes to Firefox to help users of these very high resolution screens is unfortunately affecting many users. It is perhaps a change that could have been implemented better.

If you need to zoom a particular site Firefox should remember the settings and so you should be ok when next revisiting that site.

If you are having other problems with small icons large text or blurry fonts please refer to this help article


LOCKING

The guidelines suggest not posting questions in someone else's thread and the Original Poster obviously considers the matter solved and closed so I will now lock this thread.

EVERYONE, If you have a problem with zoom and large text in Windows please read this thread and the linked articles. If that does not solve your problems please start your own thread using [/questions/new] You will not receive developer attention posting in this forum. All you are doing is posting in a user help forum where users help other users. If you wish to have a comment logged please use * https://input.mozilla.org/en-US/feedback ---------------- EXPLANATION mackynyxz86, <br/> As I understand it the problem stems from the need for Firefox to work on very many device types and a large range of displays of differing sizes and a wide range of screen resolutions. In particular some newer Operating Systems now support very high Dot Per Inch settings. Deliberate changes to Firefox to help users of these very high resolution screens is unfortunately affecting many users. It is perhaps a change that could have been implemented better. If you need to zoom a particular site Firefox should remember the settings and so you should be ok when next revisiting that site. If you are having other problems with small icons large text or blurry fonts please refer to this help article * [[Webpages are large and blurry after updating Firefox - how to fix]] *and for general information [[Font size and zoom - increase the size of web pages]] * and Windows Settings on Display sizes http://windows.microsoft.com/en-us/windows7/make-the-text-on-your-screen-larger-or-smaller * possibly this add-on may help with some problems <br /> https://addons.mozilla.org/en-US/firefox/addon/nosquint/ --------- LOCKING The [[Forum rules and guidelines|guidelines]] suggest not posting questions in someone else's thread and the Original Poster obviously considers the matter solved and closed so I will now lock this thread.