X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Upgraded to FireFox 22. Very slow! Unprecedented in previous versions. HELP!

Posted

I've been using Firefox as my default browser for at least 8 years (after switching over from Netscape Navigator). I've never had any problems before, and I love Firefox! Per your info., I've assumed that FF automatically updates to the latest version (it's always been set in my Preferences to do that). But after I got up to Version 10.0, it apparently stopped doing that! When I would check the version, it would say "You are on the update release version" (paraphrase) and then the "checking for updates" circle would just spin.

Three days ago (June 28, 2013), I tried to go to what I assumed was a trusted site (Obama's Organizing for Action) (from a link on an e-mail notice), and I got a notice that FF considered this an untrusted site(?) The next day (June 29, 2013), I tried to reach another trusted site (via Google), the California Lifeline site (phone company), and I got the same "untrusted site" notice(!)

At this point, I decided to see if my FF was up to date. I checked info. on your site and found out that the latest version was 22.0! (Why wasn't it updated for all the versions after 10.0?!) So I downloaded the latest version. When I opened the new version, FF was terribly slow!! It takes forever to load websites or to switch between sites, or to do just about anything! THIS HAS NEVER HAPPENED BEFORE! I've read many articles on what could be wrong and how to potentially fix it, but I'd rather start here! Please help as soon as possible! Thanks much in advance!

Additional System Details

Installed Plug-ins

  • npsitesafety
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.1.3.13728
  • Shockwave Flash 11.7 r700
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • McAfee MSS+ NPAPI Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20125.0
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • iTunes Detector Plug-in
  • Zeon PDF Plugin For Mozilla
  • ActiveTouch General Plugin Container Version 105
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • AVG Security Toolbar 15.3.0.11 (avg@toolbar)
  • Move Media Player 1.0.0.07103010 (moveplayer@movenetworks.com)
  • PDF Converter 7.1 1.0 (nuance@pdf7)
  • Status-4-Evar 2013.02.16.23 (status4evar@caligonstudios.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Microsoft .NET Framework Assistant 1.2.1 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Mobile Intel(R) 965 Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2a02
  • adapterDeviceID2:
  • adapterDrivers: igdumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'7.15.10.1666']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 4-23-2007
  • driverDate2:
  • driverVersion: 7.14.10.1263
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'7.15.10.1666']
  • numTotalWindows: 2
  • webglRendererMessage: [u'tryNewerDriver', u'7.15.10.1666']
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 829440
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: http://www.guardian.co.uk/
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.tabs.onTop: False
  • extensions.lastAppVersion: 22.0
  • font.internaluseonly.changed: True
  • general.useragent.extra.microsoftdotnet: (.NET CLR 3.5.30729)
  • gfx.blacklist.suggested-driver-version: 7.15.10.1666
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1372653809
  • places.history.expiration.transient_current_max_pages: 53421
  • places.history.expiration.transient_optimal_database_size: 85472050
  • places.last_vacuum: 1302969088
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 0
  • plugin.state.npdeployjava: 0
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.donottrackheader.enabled: True
  • privacy.item.cookies: True
  • privacy.item.offlineApps: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1370636681

Misc

  • User JS: No
  • Accessibility: No
Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Question owner

I unchecked Hardware Acceleration. That didn't help; still extremely slow.

I started in Safe Mode with Extensions disabled. That didn't help.

I switched to the Default theme. That didn't help.

I tried manually disabling all Extensions. That didn't help.

I tried all the ways to upgrade my graphics driver, but could not figure out how to do it. (Also, the instructions list a lot of potential problems, so I hesitate to do that without further input from you.)

Do you think I should try uninstalling and reinstalling? I definitely want to keep all my Bookmarks! Will they be retained unless I specify not to retain them? (VERY IMPORTANT TO ME!)

Question owner

Also, after I did the Extension disabling, the "Progress Bar" at the bottom of the page, which tells you how fast pages are loading and when they are done loading, disappeared (?) Also, the text at the left-hand side of the bottom of the page that charts what things are loading, disappeared as well. After I re-enabled all the Extensions, these two elements did not reappear (after restarting).

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

A clean reinstall will not delete bookmarks, addons etc.

Modified by Waka_Flocka_Flame

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

hello, such issues can also be caused by a firewall/security software which doesn't properly recognize & therefore blocks or slows down new firefox versions: Fix problems connecting to websites after updating Firefox

Question owner

So, do you recommend I try that? (Uninstalling and reinstalling.)

Modified by inanna

Question owner

RE: Firewall security software. I don't have a firewall installed. I use AVG anti-virus.

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

firewall/security software includes AVG.

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

And yes, a clean reinstall is suggested.

Question owner

Can you post instructions on how to fix and firewall/security potential problem here? (FF is SO SLOW that going to other pages takes ages!) Arrghh! Taking my whole day! :'(

Question owner

Shall I try the clean reinstall BEFORE dealing with the firewall/security issue?

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

hello, this is explained in the link in my posting above. in essence remove all rules regarding firefox (& plugin-container.exe) from your security program and let it detect the new browser version again...

Question owner

O.K.! I did an uninstall and clean reinstall, and my FF is now much faster!

I wonder if I had somehow picked up some bugs or corruption in my original FF? For example, I had never seen the "progress bar" before (that I mentioned above) before downloading Firefox 22 for the first time. And there was also a mysterious "download arrow" next to it. My clean install of Firefox 22 does not have either of these...

Would be interested in your thoughts. Somewhere in the FF Support pages, I saw a reference to the possibility of downloading a "Fake Firefox." Do these exist?

Phillip, thank you for your suggestion re: firewall issues. If I have more problems with speed, I will check that out as well. (It still doesn't load major news sites as fast as before.)

Thanks to both of you for your prompt advice! This was a huge problem for the last couple of days, and I REALLY appreciate getting some help with it!

Modified by inanna

FSzanto 0 solutions 1 answers

I found my problem was due to the proxy setting - under Tools-Options-Advanced-Connection. Somehow this got set to "Use system proxy settings". I changed it to No Proxy, and now Firefox loads in a flash - before it would hang for 30+ seconds.