X
Tap here to go to the mobile version of the site.

Support Forum

Saved username and passwords no longer works on Yahoo Mail

Posted

Ever since Yahoo changed their login screen a few days ago the username and password fill has not worked correctly for me. I deleted the old entry and tried to reenter it but it would not show up on firefox. I had to use a booklet to get rid of the autocomplete=false tags in order for login manager to ask to save the password. However it does not fill it in when I try to relogin.

I really enjoy this feature since I use a long Yahoo password and Firefox stores them better then most other browsers.

This is the booklet I used. javascript:(function(){var%20c=0;function%20R(w){try{var%20a,df,dfe,i,j,x,y,r=1;df=w.document.forms;for(i=0;x=df[i];++i){dfe=x.elements;if(a=x.onsubmit){a=""}if(a=x.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}for(j=0;y=dfe[j];++j){if(a=y.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}}}}catch(E){r=0}return%20r}R(self);var%20i,x;for(i=0;x=frames[i];++i)R(x);if(c){alert("Found:%20"+c)}})();

Ever since Yahoo changed their login screen a few days ago the username and password fill has not worked correctly for me. I deleted the old entry and tried to reenter it but it would not show up on firefox. I had to use a booklet to get rid of the autocomplete=false tags in order for login manager to ask to save the password. However it does not fill it in when I try to relogin. I really enjoy this feature since I use a long Yahoo password and Firefox stores them better then most other browsers. This is the booklet I used. javascript:(function(){var%20c=0;function%20R(w){try{var%20a,df,dfe,i,j,x,y,r=1;df=w.document.forms;for(i=0;x=df[i];++i){dfe=x.elements;if(a=x.onsubmit){a=""}if(a=x.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}for(j=0;y=dfe[j];++j){if(a=y.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}}}}catch(E){r=0}return%20r}R(self);var%20i,x;for(i=0;x=frames[i];++i)R(x);if(c){alert("Found:%20"+c)}})();

Chosen solution

A few days after my original post, I typed in my username and the password appeared. This is different from the usual behavior where both the username and the password was inputted... which is fine on my home computer. This was using that little scriptlet to make sure Firefox actually asked to save it.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Google Update
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.1.3.13728
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Unity Player 4.0.1f2
  • VLC media player Web Plugin 2.0.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

jude23 0 solutions 24 answers

Hi Jscher2000, I logged out, went to security and removed my saved Yahoo passwords, did the IEQ fix (after i hit enter, I put in my password and logged in). But if I then open a new window, I still have to re-enter my password.

Maybe I'm just a hopeless case! Maybe time to wait and see if the next version of Firefox fixes this. Or time to consider switching to gmail (which i've never much liked) Either way, I really appreciate all the help I've gotten here.

Hi Jscher2000, I logged out, went to security and removed my saved Yahoo passwords, did the IEQ fix (after i hit enter, I put in my password and logged in). But if I then open a new window, I still have to re-enter my password. Maybe I'm just a hopeless case! Maybe time to wait and see if the next version of Firefox fixes this. Or time to consider switching to gmail (which i've never much liked) Either way, I really appreciate all the help I've gotten here.
jscher2000
  • Top 10 Contributor
8690 solutions 71037 answers

Hi jude23, during the login, did Firefox drop down the little dialog allowing you to save your password for Yahoo?

If it did, and you allowed it, then there must be some other problem different from the other posters, something that is making Yahoo suspicious of your browser for some reason.

If the problem is particular to separate windows -- i.e., if you set your tab options to divert new windows to new tabs in the same window then it works -- perhaps one or both of the windows are "private" windows? I think starting in Firefox 20 with the introduction of per-window-private-browsing those windows might not be able to share the same Yahoo! session, but I haven't experimented with it.

Hi jude23, during the login, did Firefox drop down the little dialog allowing you to save your password for Yahoo? If it did, and you allowed it, then there must be some other problem different from the other posters, something that is making Yahoo suspicious of your browser for some reason. If the problem is particular to separate windows -- i.e., if you set your tab options to divert new windows to new tabs in the same window then it works -- perhaps one or both of the windows are "private" windows? I think starting in Firefox 20 with the introduction of per-window-private-browsing those windows might not be able to share the same Yahoo! session, but I haven't experimented with it.
jude23 0 solutions 24 answers

Jscher2000, I can see that the new password is saved because I previously deleted it from the list of saved passwords, and it is back again.

I shouldn't have said that about separate windows--because while I have to re-enter the password if I open a new window, I also have to re-enter if I simply return to Yahoo on the same window. Besides, none of my windows are private because passwords for all other sites are remembered just fine.

Gosh, there must be other folks out there with this problem!

Jscher2000, I can see that the new password is saved because I previously deleted it from the list of saved passwords, and it is back again. I shouldn't have said that about separate windows--because while I have to re-enter the password if I open a new window, I also have to re-enter if I simply return to Yahoo on the same window. Besides, none of my windows are private because passwords for all other sites are remembered just fine. Gosh, there must be other folks out there with this problem!
jscher2000
  • Top 10 Contributor
8690 solutions 71037 answers

Hi jude23, I had forgotten that you said it works correctly in Firefox's Safe Mode -- way back two pages ago. I think the next thing to investigate is whether any of your extensions might be blocking one or more of your Yahoo cookies, or filtering other information expected by the Yahoo server, or blocking content from Yahoo-related servers. Anything related to privacy or ad/content blocking would be worth a close look.

Hi jude23, I had forgotten that you said it works correctly in Firefox's Safe Mode -- way back two pages ago. I think the next thing to investigate is whether any of your extensions might be blocking one or more of your Yahoo cookies, or filtering other information expected by the Yahoo server, or blocking content from Yahoo-related servers. Anything related to privacy or ad/content blocking would be worth a close look.
jude23 0 solutions 24 answers

Jscher2000, turning off all my extensions and add-ons is another thing I did before coming here. And that didn't work. The only thing I can think is that I didn't do a restart after disabling them, but I don't think that should have made a difference(?)

Jscher2000, turning off all my extensions and add-ons is another thing I did before coming here. And that didn't work. The only thing I can think is that I didn't do a restart after disabling them, but I don't think that should have made a difference(?)
jscher2000
  • Top 10 Contributor
8690 solutions 71037 answers

Hi jude23, when you disable an extension, if Firefox needs to be restarted in order for that to take effect, a link will appear above the extension to restart with a single click. Anyway, it's easy enough to visit the extensions list and see their status.

Hi jude23, when you disable an extension, if Firefox needs to be restarted in order for that to take effect, a link will appear above the extension to restart with a single click. Anyway, it's easy enough to visit the extensions list and see their status.
jude23 0 solutions 24 answers

Jscher2000, yeah, so extensions seems to yet another dead end for me...

Jscher2000, yeah, so extensions seems to yet another dead end for me...
sherylsr 0 solutions 15 answers

Bless your heart! Have you considered just doing a clean reinstall of Firefox and starting over? Then doing the "Inspect Element" thing? Worked for me.

Bless your heart! Have you considered just doing a clean reinstall of Firefox and starting over? Then doing the "Inspect Element" thing? Worked for me.
jude23 0 solutions 24 answers

sherylsr, oh I thought you reported earlier that the reinstall did not work, it only was fixed when you did the IE(Q). But you're suggesting the combination might be what did it? Well, yeah, I'm at the desperate stage (!) might as well try anything. I'll set aside time this weekend...

sherylsr, oh I thought you reported earlier that the reinstall did not work, it only was fixed when you did the IE(Q). But you're suggesting the combination might be what did it? Well, yeah, I'm at the desperate stage (!) might as well try anything. I'll set aside time this weekend...
sherylsr 0 solutions 15 answers

I'm wondering if a clean reinstall in addition to the "Inspect Element" would work. Sounds like you've been doing a lot of tweaking here and there trying to get this bug fixed. That's why I'm wondering if starting over, so to speak, would help. Did for me. Because I did a lot of messing around beforehand with Preferences etc before I found this discussion. Now have my life back! :-)

I'm wondering if a clean reinstall in addition to the "Inspect Element" would work. Sounds like you've been doing a lot of tweaking here and there trying to get this bug fixed. That's why I'm wondering if starting over, so to speak, would help. Did for me. Because I did a lot of messing around beforehand with Preferences etc before I found this discussion. Now have my life back! :-)
sherylsr 0 solutions 15 answers

[Fingers CROSSED!]

[Fingers CROSSED!]

Chosen Solution

A few days after my original post, I typed in my username and the password appeared. This is different from the usual behavior where both the username and the password was inputted... which is fine on my home computer. This was using that little scriptlet to make sure Firefox actually asked to save it.

A few days after my original post, I typed in my username and the password appeared. This is different from the usual behavior where both the username and the password was inputted... which is fine on my home computer. This was using that little scriptlet to make sure Firefox actually asked to save it.
cor-el
  • Top 10 Contributor
  • Moderator
17470 solutions 157890 answers

In Firefox Safe mode these changes are effective:

  • all extensions are disabled
  • the default theme is used (no persona)
  • userChrome.css and userContent.css are ignored
  • the default toolbar layout is used (localstore-safe.rdf)
  • the Javascript JIT compiler is disabled
  • hardware acceleration is disabled
  • plugins are not affected
  • preferences are not affected

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

In Firefox Safe mode these changes are effective: *all extensions are disabled *the default theme is used (no persona) *userChrome.css and userContent.css are ignored *the default toolbar layout is used (localstore-safe.rdf) *the Javascript JIT compiler is disabled *hardware acceleration is disabled *plugins are not affected *preferences are not affected *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- Create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
jude23 0 solutions 24 answers

Well, everyone, back to say that I did a total reinstall of Firefox, and then did the IE(Q) fix, and .... problem is still here! :-(

Well, everyone, back to say that I did a total reinstall of Firefox, and then did the IE(Q) fix, and .... problem is still here! :-(
jscher2000
  • Top 10 Contributor
8690 solutions 71037 answers

Hi jude23, since the posts are spread out over a couple pages now, I'll summarize the troubleshooting so far, and please correct as needed:

  • Firefox stored your Yahoo login successfully and Firefox will log you in the first time (so the Inspect Element trick isn't needed at this point)
  • In normal mode, Yahoo keeps asking you to confirm your password when you navigate to a new page, or even if you reload the same page
  • Deleting Yahoo cookies didn't resolve it
  • Renaming cookies.sqlite didn't resolve it
  • In Safe Mode, you can navigate normally on Yahoo
  • Disabling extensions does not resolve the issue
  • Setting No Proxy in connection settings does not resolve the issue

It seems to me that for some reason Yahoo is not trusting your connection. Usually this would be due to cookie issues or changing IP address issues, or an extension, but you've ruled all of those out. And other browsers are not affected.

You mentioned running Windows on a Mac. Are you having this problem in the native Mac version of Firefox or in the Windows version?


One of the other change made by Safe Mode is disabling the use of hardware acceleration for graphics. While it is hard to see what this could possibly have to do with this problem, you may want to try it anyway.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

(MAC) Firefox menu > Preferences > Advanced
(WIN) orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available". Then exit and restart Firefox.

Hi jude23, since the posts are spread out over a couple pages now, I'll summarize the troubleshooting so far, and please correct as needed: * Firefox stored your Yahoo login successfully and Firefox will log you in the first time (so the Inspect Element trick isn't needed at this point) * In normal mode, Yahoo keeps asking you to confirm your password when you navigate to a new page, or even if you reload the same page * Deleting Yahoo cookies didn't resolve it * Renaming cookies.sqlite didn't resolve it * In Safe Mode, you ''can'' navigate normally on Yahoo * Disabling extensions does not resolve the issue * Setting No Proxy in connection settings does not resolve the issue It seems to me that for some reason Yahoo is not trusting your connection. Usually this would be due to cookie issues or changing IP address issues, or an extension, but you've ruled all of those out. And other browsers are not affected. ''You mentioned running Windows on a Mac.'' Are you having this problem in the native Mac version of Firefox or in the Windows version? ---- One of the other change made by Safe Mode is disabling the use of hardware acceleration for graphics. While it is hard to see what this could possibly have to do with this problem, you may want to try it anyway. You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). (MAC) Firefox menu > Preferences > Advanced<br> (WIN) orange Firefox button (or Tools menu) > Options > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available". Then exit and restart Firefox.
jude23 0 solutions 24 answers

Hi Jscher2000

Thank you for still considering this! Yes, your summary is correct. And I just tried unchecking the acceleration, with no effect.

I run Windows via bootcamp, but can't tell you the last time I even went to the Mac side. I have used Yahoo mail on Firefox for 10+ years with no problem, and on this computer for over a year, with no problem till about a month ago. I'm trying to think what coincided with the start of the issue, but nothing comes to mind. Possibly there was an update around that time?

thanks again!

Hi Jscher2000 Thank you for still considering this! Yes, your summary is correct. And I just tried unchecking the acceleration, with no effect. I run Windows via bootcamp, but can't tell you the last time I even went to the Mac side. I have used Yahoo mail on Firefox for 10+ years with no problem, and on this computer for over a year, with no problem till about a month ago. I'm trying to think what coincided with the start of the issue, but nothing comes to mind. Possibly there was an update around that time? thanks again!
cor-el
  • Top 10 Contributor
  • Moderator
17470 solutions 157890 answers

Did you try to reset all preferences?

Rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default value.

Did you try to reset all preferences? Rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default value. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences

Modified by cor-el

Mari123 0 solutions 3 answers

Thanks for everyone's response. I have tried most - if no all - of these suggestions. However, the reality is that this is a Yahoo problem - not a Firefox one. Yahoo, have simply swtiched off the ability to save usernames and passwords (like banks do) on the browser. They have done this without informing their customers. The silly thing is that Yahoo Customer Service Team have no idea about it - they are totally in the dark (or clueless). I have been in email communication with them for the past two weeks and they still have no idea about the issue. Clearly some boffin(s) in a glass room thought that making this change was 'good' but didn't think about the users. I suspect they just want it to go away. The are being totally dismissive of their customers. All I can say is hello gmail and/or outlook.

Thanks for everyone's response. I have tried most - if no all - of these suggestions. However, the reality is that this is a Yahoo problem - not a Firefox one. Yahoo, have simply swtiched off the ability to save usernames and passwords (like banks do) on the browser. They have done this without informing their customers. The silly thing is that Yahoo Customer Service Team have no idea about it - they are totally in the dark (or clueless). I have been in email communication with them for the past two weeks and they still have no idea about the issue. Clearly some boffin(s) in a glass room thought that making this change was 'good' but didn't think about the users. I suspect they just want it to go away. The are being totally dismissive of their customers. All I can say is hello gmail and/or outlook.
jude23 0 solutions 24 answers

Thanks, cor-el, for the suggestion about preferences. I haven't had a chance to look into that. But I was under the impression that my preferences were all reset when I did a complete reinstall of Firefox.

Mari123, glad to hear you had some conversations with Yahoo. I got nowhere with them, either.

I wanted to say, too, that this issue is wonkier than just Yahoo turning off the ability to save usernames and passwords. In my case at least, my username remains saved, and I don't think Yahoo has actually signed me out in weeks(!) At the same time, the password is forgotten, but (probably since reinstalling Firefox), now when I open the browser to my homepage, which is set to Yahoo mail, I do NOT need to enter my password. And I can refresh that page okay. BUT if I click on the bookmark to my email page or if I open another window (tab), it wants a password again. Bottom line, this is not a straightforward issue.

Thanks, cor-el, for the suggestion about preferences. I haven't had a chance to look into that. But I was under the impression that my preferences were all reset when I did a complete reinstall of Firefox. Mari123, glad to hear you had some conversations with Yahoo. I got nowhere with them, either. I wanted to say, too, that this issue is wonkier than just Yahoo turning off the ability to save usernames and passwords. In my case at least, my username remains saved, and I don't think Yahoo has actually signed me out in weeks(!) At the same time, the password is forgotten, but (probably since reinstalling Firefox), now when I open the browser to my homepage, which is set to Yahoo mail, I do NOT need to enter my password. And I can refresh that page okay. BUT if I click on the bookmark to my email page or if I open another window (tab), it wants a password again. Bottom line, this is not a straightforward issue.
jude23 0 solutions 24 answers

Hi guys, Hi cor-el, Jscher, and everybody!

I SOLVED it!!!!!! (and by myself, no less :-) )

Guess what, by chance, while looking for something else, I saw that SSL was checked. [i.e., "Make your Yahoo! Mail more secure with SSL (i.e. preventing others from accessing your account at Internet cafes)] I unchecked it, presto, problem solved. Holy smokes!! I think this is the 60th post on this thread. No one is probably reading anymore...

What is weird though, is why this problem started a few weeks ago. It's not like I went in and checked SSL.

Anyway, I'm just glad to have an answer. And hope by posting it here that it helps someone else down the line.

And again thank you to everyone who went way beyond the 'call of duty' to over helpful suggestions!

Hi guys, Hi cor-el, Jscher, and everybody! I SOLVED it!!!!!! (and by myself, no less :-) ) Guess what, by chance, while looking for something else, I saw that SSL was checked. [i.e., "Make your Yahoo! Mail more secure with SSL (i.e. preventing others from accessing your account at Internet cafes)] I unchecked it, presto, problem solved. Holy smokes!! I think this is the 60th post on this thread. No one is probably reading anymore... What is weird though, is why this problem started a few weeks ago. It's not like I went in and checked SSL. Anyway, I'm just glad to have an answer. And hope by posting it here that it helps someone else down the line. And again thank you to everyone who went way beyond the 'call of duty' to over helpful suggestions!