X
Tap here to go to the mobile version of the site.

Support Forum

Saved username and passwords no longer works on Yahoo Mail

Posted

Ever since Yahoo changed their login screen a few days ago the username and password fill has not worked correctly for me. I deleted the old entry and tried to reenter it but it would not show up on firefox. I had to use a booklet to get rid of the autocomplete=false tags in order for login manager to ask to save the password. However it does not fill it in when I try to relogin.

I really enjoy this feature since I use a long Yahoo password and Firefox stores them better then most other browsers.

This is the booklet I used. javascript:(function(){var%20c=0;function%20R(w){try{var%20a,df,dfe,i,j,x,y,r=1;df=w.document.forms;for(i=0;x=df[i];++i){dfe=x.elements;if(a=x.onsubmit){a=""}if(a=x.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}for(j=0;y=dfe[j];++j){if(a=y.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}}}}catch(E){r=0}return%20r}R(self);var%20i,x;for(i=0;x=frames[i];++i)R(x);if(c){alert("Found:%20"+c)}})();

Ever since Yahoo changed their login screen a few days ago the username and password fill has not worked correctly for me. I deleted the old entry and tried to reenter it but it would not show up on firefox. I had to use a booklet to get rid of the autocomplete=false tags in order for login manager to ask to save the password. However it does not fill it in when I try to relogin. I really enjoy this feature since I use a long Yahoo password and Firefox stores them better then most other browsers. This is the booklet I used. javascript:(function(){var%20c=0;function%20R(w){try{var%20a,df,dfe,i,j,x,y,r=1;df=w.document.forms;for(i=0;x=df[i];++i){dfe=x.elements;if(a=x.onsubmit){a=""}if(a=x.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}for(j=0;y=dfe[j];++j){if(a=y.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}}}}catch(E){r=0}return%20r}R(self);var%20i,x;for(i=0;x=frames[i];++i)R(x);if(c){alert("Found:%20"+c)}})();

Chosen solution

A few days after my original post, I typed in my username and the password appeared. This is different from the usual behavior where both the username and the password was inputted... which is fine on my home computer. This was using that little scriptlet to make sure Firefox actually asked to save it.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Google Update
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.1.3.13728
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Unity Player 4.0.1f2
  • VLC media player Web Plugin 2.0.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

sherylsr 0 solutions 15 answers

So I just now uninstalled-reinstalled Firefox. Same problem. It does seem to be with Yahoo. Because I reentered my username-password here, and Firefox asked to remember it just fine.

So I just now uninstalled-reinstalled Firefox. Same problem. It does seem to be with Yahoo. Because I reentered my username-password here, and Firefox asked to remember it just fine.
jude23 0 solutions 24 answers

Sherylsr, thanks, that saves me trying the reinstall

However, I don't think the issue is Yahoo because when I tried Internet Explorer (which I hate and refuse to use, except in this case to test), there is no problem recalling the password. Have you tried IE?

Sherylsr, thanks, that saves me trying the reinstall However, I don't think the issue is Yahoo because when I tried Internet Explorer (which I hate and refuse to use, except in this case to test), there is no problem recalling the password. Have you tried IE?
jscher2000
  • Top 10 Contributor
8763 solutions 71700 answers

Helpful Reply

Hi diverjer, I can understand being nervous about bookmarklets with incomprehensible code.

What the bookmarklet does is switch autocomplete="off" to autocomplete="on" for the username and password fields. Firefox will NOT offer to save a password if autocomplete="off".

Since you only need to do this once to get Firefox to offer to save the password, you could try doing it manually using the Inspect feature.

Right-click the username field and choose Inspect Element (Q). This will call up a pane (or optionally a separate window) where you can view and edit the HTML tag which creates the username field. There you can edit the autocomplete="off" to autocomplete="on" by double-clicking off and typing on and then pressing Enter. I have attached a screen shot.

Then when you log in, Firefox should offer to save your login.

Note: This is addressed to triggering Firefox to save the login. It isn't a solution for Firefox failing to log you in after successfully saving your username and password.

Hi diverjer, I can understand being nervous about bookmarklets with incomprehensible code. What the bookmarklet does is switch autocomplete="off" to autocomplete="on" for the username and password fields. Firefox will NOT offer to save a password if autocomplete="off". Since you only need to do this once to get Firefox to offer to save the password, you could try doing it manually using the Inspect feature. Right-click the username field and choose Inspect Element (Q). This will call up a pane (or optionally a separate window) where you can view and edit the HTML tag which creates the username field. There you can edit the autocomplete="off" to autocomplete="on" by double-clicking off and typing on and then pressing Enter. I have attached a screen shot. Then when you log in, Firefox should offer to save your login. ''Note: This is addressed to triggering Firefox to save the login. It isn't a solution for Firefox failing to log you in after successfully saving your username and password.''

Modified by jscher2000

sherylsr 0 solutions 15 answers

No, haven't tried Explorer. I use Firefox and Safari. I'm a Mac gal. If that makes any difference.

No, haven't tried Explorer. I use Firefox and Safari. I'm a Mac gal. If that makes any difference.
jude23 0 solutions 24 answers

Does the problem occur on Safari? Might be worth trying IE. I'm running Windows on a Mac, so I guess we have all our bases covered :)

Does the problem occur on Safari? Might be worth trying IE. I'm running Windows on a Mac, so I guess we have all our bases covered :)
Jer 1 solutions 34 answers

jscher2000- Thank You that worked like a champ. Since I have written a bit of HTML I felt comfortable making that change. Once I did go to Tools Web Inspector, but I didn't hit enter, anyway I think that is what I did a week or so ago. Anyway, what you told me worked- Thanks.

jscher2000- Thank You that worked like a champ. Since I have written a bit of HTML I felt comfortable making that change. Once I did go to Tools Web Inspector, but I didn't hit enter, anyway I think that is what I did a week or so ago. Anyway, what you told me worked- Thanks.
cor-el
  • Top 10 Contributor
  • Moderator
17530 solutions 158511 answers

Yahoo uses autocomplete=off and that makes Firefox not asking to store that name and password, but will also cause Firefox not to fill the name. You should get a drop-down list if you double click the empty user name (e-mail) field or type the first letter(s) and press the cursor Down key.

Yahoo uses autocomplete=off and that makes Firefox not asking to store that name and password, but will also cause Firefox not to fill the name. You should get a drop-down list if you double click the empty user name (e-mail) field or type the first letter(s) and press the cursor Down key.
sherylsr 0 solutions 15 answers

Yes, same in Safari.

Yes, same in Safari.
sherylsr 0 solutions 15 answers

Ok, can you give the instructions in a bit more layman's terms? What should I do in Firefox? I've done a LITTLE html code but I have to be told what to write/where. If it's too much trouble, that's ok.

Ok, can you give the instructions in a bit more layman's terms? What should I do in Firefox? I've done a LITTLE html code but I have to be told what to write/where. If it's too much trouble, that's ok.
sherylsr 0 solutions 15 answers

AMAZING! I figured it out from your screen shot and instructions. IT WORKS AGAIN! AWESOME! THANK YOU!!!

AMAZING! I figured it out from your screen shot and instructions. IT WORKS AGAIN! AWESOME! THANK YOU!!!
sherylsr 0 solutions 15 answers

If you have a second Yahoo account, then you have to repeat the same steps for another user/password.

If you have a second Yahoo account, then you have to repeat the same steps for another user/password.
jude23 0 solutions 24 answers

Jscher2000, Well, I'm not as html savvy. The screen shot is helpful, but not enough for me to figure it out. Can you give a bit more coaching? Here is what I see on IE(Q) --

<input id="passwd" type="password" value="" autocomplete="off" autocorrect="off" placeholder="Password" aria-required="true" tabindex="2" maxlength="64" name="passwd"></input>

Can you show me what it should look like? And how I execute the change?

thanks!!

Jscher2000, Well, I'm not as html savvy. The screen shot is helpful, but not enough for me to figure it out. Can you give a bit more coaching? Here is what I see on IE(Q) -- <p id="username"> … </p><input id="passwd" type="password" value="" autocomplete="off" autocorrect="off" placeholder="Password" aria-required="true" tabindex="2" maxlength="64" name="passwd"></input> Can you show me what it should look like? And how I execute the change? thanks!!
jscher2000
  • Top 10 Contributor
8763 solutions 71700 answers

Hi jude23, it's the autocomplete="off" part, that needs to be changed to autocomplete="on". If you double-click the word off, it becomes editable and you can type on and then press Enter to complete the edit. Firefox will move autocomplete="on" to the end of the tag (as in the lower part of the screenshot). Then repeat for the password, which is the line right below the username. Then you're done with the inspector and you can finishing logging in.

Hi jude23, it's the '''autocomplete="off"''' part, that needs to be changed to autocomplete="on". If you double-click the word off, it becomes editable and you can type on and then press Enter to complete the edit. Firefox will move autocomplete="on" to the end of the tag (as in the lower part of the screenshot). Then repeat for the password, which is the line right below the username. Then you're done with the inspector and you can finishing logging in.
jude23 0 solutions 24 answers

Jscher2000, Thanks in advance for your patience... I can double click off (there are two of them) and press enter and see the "on" moved to the end, as you say. However, when I reopen the IE(Q) window they have both reverted to off. And I still don't have the password saved.

Btw, the only issue is with the password; the ID is remembered and in fact I never get logged out. It is just this incessant requesting of password re-entry.

Jscher2000, Thanks in advance for your patience... I can double click off (there are two of them) and press enter and see the "on" moved to the end, as you say. However, when I reopen the IE(Q) window they have both reverted to off. And I still don't have the password saved. Btw, the only issue is with the password; the ID is remembered and in fact I never get logged out. It is just this incessant requesting of password re-entry.
cor-el
  • Top 10 Contributor
  • Moderator
17530 solutions 158511 answers

Note that you can also run the JavaScript code via the command line in the Web Console.
That only works if the %20 are unescaped to space characters (" ").
The script that you posted doesn't give a feedback alert because it shows the number of input fields that have autocomplete=on, so you need to run the script a second time (use Cursor up on the command line) to see the result.

javascript:(function(){var c=0;function R(w){try{var a,df,dfe,i,j,x,y,r=1;df=w.document.forms;for(i=0;x=df[i];++i){dfe=x.elements;if(a=x.onsubmit){a=""}if(a=x.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}for(j=0;y=dfe[j];++j){if(a=y.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}}}}catch(E){r=0}return r}R(self);var i,x;for(i=0;x=frames[i];++i)R(x);if(c){alert("Found: "+c)}})();
Note that you can also run the JavaScript code via the command line in the Web Console.<br /> That only works if the %20 are unescaped to space characters (" ").<br /> The script that you posted doesn't give a feedback alert because it shows the number of input fields that have autocomplete=on, so you need to run the script a second time (use Cursor up on the command line) to see the result. <pre><nowiki>javascript:(function(){var c=0;function R(w){try{var a,df,dfe,i,j,x,y,r=1;df=w.document.forms;for(i=0;x=df[i];++i){dfe=x.elements;if(a=x.onsubmit){a=""}if(a=x.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}for(j=0;y=dfe[j];++j){if(a=y.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}}}}catch(E){r=0}return r}R(self);var i,x;for(i=0;x=frames[i];++i)R(x);if(c){alert("Found: "+c)}})();</nowiki></pre>
jscher2000
  • Top 10 Contributor
8763 solutions 71700 answers

Hi jude23, that could be a different issue.

In the past, it was observed that Yahoo! requires frequent re-logins if you have a proxy set. Could you check here:

(WIN) orange Firefox button (or Tools menu) > Options > Advanced
(MAC) Firefox menu > Preferences > Advanced

On the "Network" mini-tab, click the "Settings" button and try the "No Proxy" setting. This usually cures the repeated login problem.

Any luck?

Hi jude23, that could be a different issue. In the past, it was observed that Yahoo! requires frequent re-logins if you have a proxy set. Could you check here: (WIN) orange Firefox button (or Tools menu) > Options > Advanced<br> (MAC) Firefox menu > Preferences > Advanced On the "Network" mini-tab, click the "Settings" button and try the "No Proxy" setting. This usually cures the repeated login problem. Any luck?
jude23 0 solutions 24 answers

Jscher2000, the "no proxy" setting was one of the first potential fixes I found online and tried. But no dice.

The fact that the IE(Q) solution worked for sherylsr suggests it should work for me. But why does it keep flipping back to off?? I double click on "off", hit enter, see the "on" move to the end. What then?

I haven't a clue what cor-el is saying about JavaScript code.

Jscher2000, the "no proxy" setting was one of the first potential fixes I found online and tried. But no dice. The fact that the IE(Q) solution worked for sherylsr suggests it should work for me. But why does it keep flipping back to off?? I double click on "off", hit enter, see the "on" move to the end. What then? I haven't a clue what cor-el is saying about JavaScript code.
sherylsr 0 solutions 15 answers

Did you turn it "on" in the two places?

Did you turn it "on" in the two places?
jude23 0 solutions 24 answers

I tried everything! I tried both "on's" When that didn't seem to stick I tried only one.

I tried everything! I tried both "on's" When that didn't seem to stick I tried only one.
jscher2000
  • Top 10 Contributor
8763 solutions 71700 answers

Hi jude23, the edit only affects the page in your browser at the moment, but that should be long enough to log in. The only purpose of the edit is to remove the barrier to Firefox prompting you to save your login.

Since you saved your login before, you might need to log out and delete the old information first before editing the form and logging in again.

You can check for and clear the old login here:

(WIN) orange Firefox button (or Tools menu) > Options > Security > "Saved Passwords"
(MAC) Firefox menu > Preferences > Security > "Saved Passwords"

Does that make any difference?

Hi jude23, the edit only affects the page in your browser at the moment, but that should be long enough to log in. The only purpose of the edit is to remove the barrier to Firefox prompting you to save your login. Since you saved your login before, you might need to log out and delete the old information first before editing the form and logging in again. You can check for and clear the old login here: (WIN) orange Firefox button (or Tools menu) > Options > Security > "Saved Passwords"<br> (MAC) Firefox menu > Preferences > Security > "Saved Passwords" Does that make any difference?