X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox ignores Windows 8's compatability setting for high dpi screens.

Posted

I recently tried the Windows 8.1 Preview, but then reset my machine to Windows 8 again.

Before this, the first time I installed Firefox, it ran at a low resolution, so all the toolbars and content appeared huge and blurry. I fixed this with the Windows 8 compatibility setting disable display scaling on high DPI settings"

After resetting the machine, and installing Firefox again, it was back to being blurry, so I changed the compatibility setting again, but this time, nothing happened. Even with the setting on, Firefox ignores it. Every other program with this setting works fine, and Firefox worked fine the last time around.

I was advised in the Windows support forums to ask the question here.

Chosen solution

It is best to adjust the layout.css.devPixelsPerPx pref to get the icon size in the user interface correct.

If web pages needs to be adjusted after changing this pref then you can look at the Default FullZoom Level or NoSquint extension.

Use this extension to adjust the font size for the user interface:

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • npsitesafety
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.7 r700

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • Old Default Image Style 2.2.1 (olddefaultimagestyle@dagger2-addons.mozilla.org)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 1.1 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • AVG Security Toolbar 15.3.0.11 (avg@toolbar) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16433
  • driverDate: 3-8-2013
  • driverDate2:
  • driverVersion: 9.17.10.3062
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.restore_on_demand: False
  • browser.startup.homepage: http://www.google.co.uk/ig
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 22.0
  • font.default.x-western: sans-serif
  • font.internaluseonly.changed: True
  • font.name.serif.x-western: Arial
  • font.size.variable.x-western: 14
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1372536743
  • places.history.expiration.transient_current_max_pages: 104326
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.nppdf: 0
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1372500529

Misc

  • User JS: No
  • Accessibility: Yes
iamjayakumars
  • Top 10 Contributor
412 solutions 4875 answers

You can modify the layout.css.devPixelsPerPx and increase or decrease the value in 0.1 or 0.05 steps to adjust the size of fonts and other elements in Firefox.

  • The layout.css.devPixelsPerPx pref is a String value parsed to a float and allows to fine tune the dimensions of all elements (user interface and web pages) more precisely (resolution 0.1 or 0.05).
  • Change the default value -1 to 1 to make it work like in previous Firefox versions (100%)

Start with a value of 1 and adjust this value with 0.1 steps or 0.05 for finer adjustments.

  • Use values between 1.0 and about 0.5 to reduce elements in size (do NOT go all the way to 0.05!)
  • Use values greater than 1.0 to magnify and make elements larger (percentage divided by DPI, % / DPI).
  • http://kb.mozillazine.org/about:config

If web pages needs to be adjusted after changing this pref then you can look at the Default FullZoom Level or NoSquint extension.

Use this extension to adjust the font size for the user interface:

Question owner

I read this elsewhere, and tried it, but it is of no help to me.

The value it was at before I changed it was -1 for some reason, but anything under 0 had no effect. Anything above 0 made the entire browser ridiculously tiny.

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

try setting the preference to 1.0...

Question owner

Again, it just goes too small. When I set it to anything between 0.0 and 1.0 it goes super small and just gets slightly bigger with each 0.1 added, but never reaches its original size.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Chosen Solution

It is best to adjust the layout.css.devPixelsPerPx pref to get the icon size in the user interface correct.

If web pages needs to be adjusted after changing this pref then you can look at the Default FullZoom Level or NoSquint extension.

Use this extension to adjust the font size for the user interface:

Question owner

I have since found out why. The new installation is actually a new version of Firefox, and this is a new 'feature' which it turns out quite a lot of people are complaining about. I'm going to wheather through it and just wait for Mozilla to issue a patch for it.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

This is not a new feature.

The only change is that the value of the layout.css.devPixelsPerPx pref has been changed from 1 to -1 to make Firefox use the Windows DPI system settings. This pref has been around for quite a few years (2009).

Question owner

Then why did this not happen on my previous install on the same machine?

Question owner

Actually, found the setting needed on the forum where I saw everyone complaining about it.

The new '-1' is equivelant to a default of '1.25', setting the value to this fixed it all, and the dpi of websites, which any value between 0 and 1 did not change.