X
Tap here to go to the mobile version of the site.

Support Forum

Facebook not working on latest firefox

Posted

I have been using firefox for 3 years already and up until now there is a problem with facebook on firefox. I tried using other web-browsers and facebook works perfectly. I already reset it to factory settings, restart firefox, restart pc, restart router, clear cache and nothing works. I even disabled the addons. Sometimes facebook works, when it works it says redirecting... in the facebook tab and it didn't show that up when facebook didn't work. Screenshot of facebook : http://i.imgur.com/ZQgmsdX.jpg

Thanks in advance.

I have been using firefox for 3 years already and up until now there is a problem with facebook on firefox. I tried using other web-browsers and facebook works perfectly. I already reset it to factory settings, restart firefox, restart pc, restart router, clear cache and nothing works. I even disabled the addons. Sometimes facebook works, when it works it says redirecting... in the facebook tab and it didn't show that up when facebook didn't work. Screenshot of facebook : http://i.imgur.com/ZQgmsdX.jpg Thanks in advance.

Chosen solution

I just solved this problem, the problem is with http facebook doesn't work on firefox so it is required to use https so the link becomes https://facebook.com . The links on other web browser which uses http://facebook.com just fine. It seems this is a weird firefox bug.

Read this answer in context 22

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.7 r700
  • VLC media player Web Plugin 2.0.6
  • Google Update
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Uplay PC Plugin
  • 0.3
  • The plugin allows you to have a better experience with Microsoft Lync
  • 5.1.20125.0
  • iTunes Detector Plug-in
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Unity Player 3.5.2f2
  • Pando Web Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.7 (adblockpopups@jessehakanen.net)
  • leethax.net extension 2013.06.11 (leethax@leethax.net)
  • Speed Dial 0.9.6.15 ({64161300-e22b-11db-8314-0800200c9a66})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • FastAccess Web Login 1.37 (fassoxpcom@sensiblevision.com) (Inactive)
  • IDM CC 7.3.43 (mozilla_cc@internetdownloadmanager.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 3000
  • adapterDescription2: NVIDIA GeForce GT 525M
  • adapterDeviceID: 0x0126
  • adapterDeviceID2: 0x0df5
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2047
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 3-19-2012
  • driverDate2: 5-12-2013
  • driverVersion: 8.15.10.2696
  • driverVersion2: 9.18.13.2018
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: chrome://speeddial/content/speeddial.xul
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 22.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.blocklisted.npviewpoint: True
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
kobe 441 solutions 5048 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.
Chandan_Baba 35 solutions 369 answers

Hi.... it seems to have that you have install either any extension file or any vulnerable add on with conflicts the browser to directing the facebook . so , check it at first and then try to uninstall or disable it. you can check by opening the browser in safe mode...!! hope ,you get your solution. please ,make a post when you have figure out the solution . thanks.

Hi.... it seems to have that you have install either any extension file or any vulnerable add on with conflicts the browser to directing the facebook . so , check it at first and then try to uninstall or disable it. you can check by opening the browser in safe mode...!! hope ,you get your solution. please ,make a post when you have figure out the solution . thanks.

Chosen Solution

I just solved this problem, the problem is with http facebook doesn't work on firefox so it is required to use https so the link becomes https://facebook.com . The links on other web browser which uses http://facebook.com just fine. It seems this is a weird firefox bug.

I just solved this problem, the problem is with '''http''' facebook doesn't work on firefox so it is required to use '''https''' so the link becomes https://facebook.com . The links on other web browser which uses http://facebook.com just fine. It seems this is a weird firefox bug.

Modified by BrandonZ201

Halofromsue 1 solutions 47 answers

I have had a problem since 7/15/2013

When I log onto FB using Firefox, I cant see the "ticker box" on the right side. When I log onto FB using IE, I can see it. Not sure whats going on there, but FB recently updated and after that update, I have this problem.

Anyone got any ideas??

Thanks

I have had a problem since 7/15/2013 When I log onto FB using Firefox, I cant see the "ticker box" on the right side. When I log onto FB using IE, I can see it. Not sure whats going on there, but FB recently updated and after that update, I have this problem. Anyone got any ideas?? Thanks
plano1mom 0 solutions 1 answers

Helpful Reply

Facebook isn't working correctly with Firefox. The first thing I noticed since I did the update, is that you cannot Comment on a Post in Facebook, you can't seen older posts, and that's just the beginning. I "did" try opening Firefox in Safe Mode without Add-ons and still the same!

Facebook isn't working correctly with Firefox. The first thing I noticed since I did the update, is that you cannot Comment on a Post in Facebook, you can't seen older posts, and that's just the beginning. I "did" try opening Firefox in Safe Mode without Add-ons and still the same!
SherMK 0 solutions 1 answers

Same problem here. I can access FB on IE and Safari just fine. Shouldn't be having to do anything "special" to use Firefox browser. Please fix guys! (this became a problem after updating to Firefox 23.0.1)

Same problem here. I can access FB on IE and Safari just fine. Shouldn't be having to do anything "special" to use Firefox browser. Please fix guys! (this became a problem after updating to Firefox 23.0.1)

Modified by SherMK

jscher2000
  • Top 10 Contributor
8692 solutions 71049 answers

Hi SherMK, which pages are giving you problems?

(1) Games or other pages with embedded content: If the content area is blank and you see a "shield" icon to the left of the URL in the address bar, please see this article: Mixed content blocking in Firefox

(2) Pages with videos: please see the below Flash guidance.

(3) Other pages: please see the below general suggestion and describe the symptoms in more detail.


When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?


This is some standard guidance that addresses the most common Flash issues. I'm sure you've seen some of it before, but just in case:

(1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Hi SherMK, which pages are giving you problems? (1) Games or other pages with embedded content: If the content area is blank and you see a "shield" icon to the left of the URL in the address bar, please see this article: [[How does content that isn't secure affect my safety?]] (2) Pages with videos: please see the below Flash guidance. (3) Other pages: please see the below general suggestion and describe the symptoms in more detail. ---- When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Bypass Firefox's Cache Use Ctrl+Shift+r to reload the page fresh from the server. Alternately, you also can clear Firefox's cache completely using: orange Firefox button (or Tools menu) > Options > Advanced On the Network mini-tab > Cached Web Content : "Clear Now" If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click and choose View Page Info > Security > "View Cookies" * Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page. Does that help? ---- This is some standard guidance that addresses the most common Flash issues. I'm sure you've seen some of it before, but just in case: (1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them. (2) Disable hardware graphics acceleration in Firefox and in Flash (A) In Firefox, un-check the box here and restart: orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available" (B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues (3) Disable protected mode (Windows Vista/7/8) See this support article from Adobe under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?]
mike429 0 solutions 1 answers

This worked for me:

After testing with various plug-ins disabled, I discovered that the culprit for me was NoScript 2.6.7.1. Disabling NoScript allowed the FB site to function normally.

Now here's the weird part: With NoScript re-enabled, FB works if I FORBID JavaScript, but the site fails if I ALLOW JavaScript. With scripts forbidden, FB displays a warning banner telling me that I'll get a "better experience" by enabling JavaScript, but I can at least see the content on the page rather than almost nothing.

This worked for me: After testing with various plug-ins disabled, I discovered that the culprit for me was NoScript 2.6.7.1. Disabling NoScript allowed the FB site to function normally. Now here's the weird part: With NoScript re-enabled, FB works if I FORBID JavaScript, but the site fails if I ALLOW JavaScript. With scripts forbidden, FB displays a warning banner telling me that I'll get a "better experience" by enabling JavaScript, but I can at least see the content on the page rather than almost nothing.
3kper3924m 0 solutions 2 answers

Helpful Reply

The "culprit" for me here was Adblock. After disabling like 5 add-ons (the fifth being Adblock), FB worked fine and didn't have all the weird display/inability to comment/etc. problems anymore.

I re-enabled Adblock and just disabled it for FB only using the icon to the far right of the address bar at the top - the red "stop-sign" icon.

The "culprit" for me here was Adblock. After disabling like 5 add-ons (the fifth being Adblock), FB worked fine and didn't have all the weird display/inability to comment/etc. problems anymore. I re-enabled Adblock and just disabled it '''for FB only''' using the icon to the far right of the address bar at the top - the red "stop-sign" icon.

Modified by 3kper3924m

phoenixs5 0 solutions 1 answers

I have been having this problem now for 2 days, tried re-installing, reseting, clearing cache and nothing works. opens fine in Chrome and IE just wont let me play most of my games

Secure Connection Failed

An error occurred during a connection to www.facebook.com. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.

I have contacted Shaw in surrey BC and they say its a firefox problem and there is nothing they can do. What do I do next?

Thanks for any and all help

I have been having this problem now for 2 days, tried re-installing, reseting, clearing cache and nothing works. opens fine in Chrome and IE just wont let me play most of my games Secure Connection Failed An error occurred during a connection to www.facebook.com. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long) The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site. I have contacted Shaw in surrey BC and they say its a firefox problem and there is nothing they can do. What do I do next? Thanks for any and all help
jscher2000
  • Top 10 Contributor
8692 solutions 71049 answers

Hi phoenixs5, that should have cleared up during the past hour, according to the last posts in this thread: Suddenly, *only with Firefox* all computers in the house show (Error code: ssl_error_rx_record_too_long) when trying to access any Google product.

Hi phoenixs5, that should have cleared up during the past hour, according to the last posts in this thread: [https://support.mozilla.org/en-US/questions/976504?page=6 Suddenly, *only with Firefox* all computers in the house show (Error code: ssl_error_rx_record_too_long) when trying to access any Google product.]