X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to disable system DPI detection on FireFox 22

Posted

Hello. I have problem with new FireFox 22. It now gives zoom (DPI) from operating system (Windows 7) - 125%. How to disable that (without changing Windows 7 to 100%)? I want to see normal websites and FireFox, like it was in FireFox 21.

Modified by Amaj

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.7 r700
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • GFACE Plugin
  • VLC media player Web Plugin 2.0.6
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 5.1.20125.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

netrix 0 solutions 2 answers

Is there some conditional CSS code for Mozilla to disable this functionality? Horror scenario for web developers going through all the old websites that are suddenly 'broken'.

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

You can try adjusting the following setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) If layout.css.devPixelsPerPx has been customized from its default value of -1.0, right-click it and choose Reset to assess whether the default value works for you.

If not...

(4) Double-click layout.css.devPixelsPerPx and change its value to 1.0 for smaller fonts, or a larger ratio for larger fonts. For example, 1.25 corresponds to 125% font size in Windows display settings. You may need to switch back and forth to other windows/tabs to see how it's affecting them.

Can you find a good size?

Is there an inconsistency between the menu/toolbar/tab area ("chrome") and the web pages ("content")?

More info in this thread: How do I set the default font size to a lower value?

Mr T 0 solutions 3 answers

I have set up DPI 110% in Windows 7. In Firefox 22 have blurry images on all pages. Only manually set layout.css.devPixelsPerPx on 1 restores the old appearance of the page.

MIkeyLV 1 solutions 6 answers

Not sure why the decision was made to map to Windows settings, but the upgrade from FF21 to FF22 has also changed and locked my Windows 7 Active Toolbar font settings. They are now big and bold. While I can change the color, I cannot change the font, font size, or unbold (stays bold regardless of "B" being highlighted or not).

Not sure if anyone else has this issue, but it just made my Windows ugly.

See the image. Color is changed, but the font isn't a size 6 and it's also bold when shouldn't be.

Pat 3 solutions 26 answers

Users that upgraded to Firefox version 22 (Windows) this week may have noticed that some web pages appear to be larger. The reason is that Firefox v22 has changed and now honors Windows display scaling options. This may render text to appear magnified on high resolution displays especially if you set your text scaling to Larger Text 125%.

Here's the fix to go back to a normal size:

In your Tools:Options (CTRL+o), select the Content tab and set your default font to Arial 16.

Type about:config into the address bar and agree to the changes you will make to your browser configurations. Type layout.css.devPixelsPerPx into the search bar and write down the current Value likely set to -1.0. Double click the value and change Value to 1.0. The Firefox UI (everything you see) will change immediately. Leave that tab open and go look at web pages.

The display text should now be close to Internet Explorer displaying the same page (with no HTML sizes set). If you still want it smaller, try 0.9 not 0.5 - this will be too tiny to read if you want to change it back. If you want it bigger, try 1.1 and up.

If your menu text, icons, and tab labels are now too small you can use an addon to change the default zoom for web pages (Default FullZoom Level, NoSquint) or an addon (Theme Font & Size Changer) to adjust the font size for the user interface. See related article by post by [https://support.mozilla.org/en-US/use.../287|Cor-el] Cor-el - How do I set the default font size to a lower value? [https://support.mozilla.org/en-US/que.../959621]

Unfortunately there are now 3 things affecting size in Firefox: Windows display text-size setting, Firefox "config" setting for display size, and Firefox's mangled setting for UI text size for menubars, menus and tabs that doesn't seem to honour the config setting and certainly not the Windows settings.

Modified by Pat

Pat 3 solutions 26 answers

I agree this is inconvenient and most people won't know what to do. Frankly honouring people's Windows text size settings should have been made years ago.

Since my Windows settings are Large text (maybe 125%) I set the config value to 1.1 so everything including toolbars is larger, then installed addon NoSquint to set 100% for web pages. It allows me to reduce this page to 95% because it is too large for some reason.

Haterade 0 solutions 11 answers

Helpful Reply

So by default, Windows 7 is set to 125%, which looks to zoom in about 2x what FF 21 and all other standard browsers do. I am assuming those that had issues with sizing would have either had their defaults increased / decreased accordingly.

When users of our products write in we will take the easiest route and instruct users to either downgrade to FF 21 or to use Chrome, which I would expect many support channels will take.

I have always been a big supporter of FF, open web and Mozilla but adjusting the default zoom for a browser at version 22 of a product, even for someone at my technical level is extremely frustrating. I want to hit ctrl+0 and be taken to my normal zoom, not 2x, and by normal zoom I mean that which all other browsers reset too including FF21.

Some changes, even those that should have been made years ago, even if they are the "right" one, cannot be made this late in a product cycle. Resetting the "norm" is a good way to lose the existing customer base of FF.

Anyways, felt that this was a big enough issue for me to at least create an account and chime in. With what FF does with the feedback is up to them.

Pat 3 solutions 26 answers

The Windows default text size is 100%. Some people with high-resolution screens set a larger text size. It's possible that if you have never changed your Windows or Firefox default settings for text size, you may not notice the change. If the details about changing the entire firefox screen doesn't quite help, Try an addon for controlling zoom: NoSquint, Default FullZoom Level.

Haterade 0 solutions 11 answers

Default set-up for both my Windows 7 Lenovo laptops have default settings of the display set to 125% with (default) beside the setting.

Anyways, so far with my laptops FF is batting 100% with messing up the zoom by default.

MIkeyLV 1 solutions 6 answers

Mine is at 1.2. At 1.1 the print and new page icon are too big.

What a friggin disaster. All it will take is some news organization that feel victim to this to do a news story on it and it'll be fixed.

natong 0 solutions 9 answers

v22

Full page zoom: from the View menu and via keyboard shortcuts, the new zooming feature lets you zoom in and out of entire pages, scaling the layout, text and images, or optionally only the text size. Your settings will be remembered whenever you return to the site.

Full page zoom default value = System DPI (eg. 125%)

and It didn't really remember per site setting.

To solve the problem -> use no squint addon and set default value to 75%

Modified by natong

JMJimmy 0 solutions 11 answers

Helpful Reply

I can't believe this is how they chose to implement display scaling - such a horrible horrible idea.

layout.css.devPixelsPerPx also does not restore it properly. It will restore websites to their original sizes, however, it also has the unwanted side effect of changing the tab/menu text to the original instead of following the system scaling for those items. This will require changing the default styles for those items to restore them properly.

Absolute nightmare.

natong 0 solutions 9 answers

layout.css.devPixelsPerPx scale down everythings including menu, toolbar, statusbar, etc.

slicky 0 solutions 5 answers

I actually like v22's new DPI scaling since my resolution is 1920x1080 and it makes the text easier to see. The only problem is that it scales up images as well which makes them blurry. That seems like an amateur mistake that should have been caught early. And my memory use has doubled to 2+ GB though I suspect that might be an addon compatibility problem.

attentiondesign 0 solutions 4 answers

actually you need to set the nosquint default to 80% (not 75) to exactly counteract a 125% zooming effect. (0.8 x 1.25 = 1.00) But this still sucks.

painter73 1 solutions 5 answers

Yeah, this is quite annoying!! To say the least. I love my windows setting at 125% But not on my browser, this sucks. It at least 2x the size and constantly zooming it down for every site is so frustrating. Thanks for all the tips here guys/gals. I haven't tried them yet, but going to right now!!! And if FF is going to start using my windows settings at least have an option for sizing in the option menu for it.

painter73 1 solutions 5 answers

when I type ' layout.css.devPixelsPerPx' nothing is displayed for me :( Just blank.

Mr T 0 solutions 3 answers

type with no spaces

painter73 1 solutions 5 answers

I typed with no spaces and copy/pasted and still nothing.... I did get the 'NoSquint 2.1.9' and set it to 80% and it seems to do the trick. All though it doesn't control the tabs and bars, but I then added 'Theme Font&Size changer 7.2' and that does control all bars/fonts. and I managed to tweak everything back to normal (at least till the next update) :)