X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

when i try to log into my verizon e-mail acount i get a security message saying that "even though it is encrypted it may be read by a 3rd party" cant access act

Posted

as stated above when i try to access my Verizon e-mail account i get a security message stating..........."Although this page is encrypted, the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party. "i don't feel this is safe, Verizon tech support is telling me its a firefox issue. please advise me on how to resolve this issue

Chosen solution

Hi amansikarwar, currently there is no way to turn off this dialog. If you are using a particular site where you see it a lot, you could first try the usual steps of clearing cache and cookies (more below). If that doesn't work, what site is it? Perhaps there is a workaround.

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r (MAC: Command+Shift+r) to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

(WIN) orange Firefox button (or Tools menu) > Options > Advanced
(MAC) Firefox menu > Preferences > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • 5.1.20125.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

AliceWyman
  • Moderator
191 solutions 1969 answers

This is a very old issue, reported in bug 436200 (please don't add unnecessary comments to bug reports - see Bugzilla Etiquette).

This problem is really up to the individual website to fix. Here's a recent thread posted to Verizon's forum where you can add your comments:

AliceWyman
  • Moderator
191 solutions 1969 answers

P.S. This was recently posted by cor-el in another thread on this message:


You should contact the website and ask them to fix this and make sure that the complete procedure is done via only secure connections because otherwise it is not really secure against hackers. Firefox shows such warnings to make you aware of this.


ewill0089 0 solutions 1 answers

I have had the same problem which started today and contacted Verizon who told me that the problem is with Firefox because it does not happen in other browsers (IE, etc.) please advise as to the next things to do.

AliceWyman
  • Moderator
191 solutions 1969 answers

Helpful Reply

ewill0089,

The bug report I posted explains that Mozilla is warning users of a security vulnerability: data entered on a secure (https) page could be leaked when connecting to an insecure (http) page. This is copied from the bug report:


Daniel Veditz [:dveditz] 2008-08-15 16:12:51 PDT
Unlike the other errors which are really just telling people the way the internet works, this is considered a potential security problem. If the content of the page (or the account authentication used to load it) were important enough to secure with encryption then connecting to an insecure page could be leaking important information, cookies, or credentials. Or not (an offsite search box, for example), but there's no real way for the browser to know so it warns and gives users a chance to cancel the submit if the form contains private data.

If it helps at all, I have a Verizon email account which I normally access via POP in my SeaMonkey Mail program. I also use webmail occasionally, mainly to delete mail. If I use the Verizon webmail login page https://webmail.verizon.net/signin/ and sign in with my Verizon username and password, I also get the security message.

However, if I go to https://www22.verizon.com/foryourhome/MyAccount/ngen/upr/signin.aspx and sign in from there, I don't have the issue. I also don't have a problem if I sign in at http://mail.verizon.com so you could try using either of those links to access your Verizon webmail.

You can post a new comment to this Verizon forum thread (which I posted earlier) and include a link to this thread, if you like. Like I said before, Verizon needs to resolve the issue. Here is the last post in Verizon's thread, from today, which indicates that something changed at Verizon's end:


Re: Security warning appears when trying to log into e-mail 
06-19-2013 11:48 AM
I too am getting this message. Never had it before today. I am to sure what Verizon has changed but they changed something. I only get the message in Firebox which is strange. Please fix the problem it is very annoying.

Modified by AliceWyman

aebenk 0 solutions 7 answers

I have the same problem, starting with version 22.0 of Firefox. My internet provider is Comcast, not Verizon, and I get the warning when signing on to several https sites that require a userid and password.

Modified by aebenk

jscher2000
  • Top 10 Contributor
2380 solutions 21056 answers

Hi aebenk, this error occurs when a form is set up to be submitted insecurely. You should only rarely encounter this, and never when doing your initial login.

Is it possible you are getting a different error: a full warning page saying there is a problem with the site's security certificate? The more detail you can provide, the better.

aebenk 0 solutions 7 answers

Warning appears as follows:

Security Warning

Although this page is encrypted, the information you have entered is to be sent over as unencrypted connection and could easily to read by a third party.

Are you sure you want to continue sending this information?

Note: I just went through the exercise of accessing the same https web sites using Internet Explorer, and received no warning messages.

Modified by aebenk

jscher2000
  • Top 10 Contributor
2380 solutions 21056 answers

Hi aebenk, it's not clear to me why you do not get a warning in IE. Does IE submit to a secure page (HTTPS), or does it submit to an insecure page (HTTP) and simply not warn you?

aebenk 0 solutions 7 answers

I tested IE using the same https pages as when using Firefox. Incidentally, I have kept on this page (using Firefox) for the last several hours, wanting to see if I had any responses on this issue. I just sat back down, did a 'reload' to refresh the page, and the security warning popped up.

jscher2000
  • Top 10 Contributor
2380 solutions 21056 answers

Hi aebenk, I don't have a Comcast account to test.

Is that page you reloaded in Firefox an HTTP page or an HTTPS page? Note that Firefox may drop the http:// for HTTPS pages but always shows https:// for secure pages.

Is the same page in IE an HTTP or HTTPS page?

bchase 0 solutions 2 answers

Helpful Reply

Dear firefox: I am not going to contact every webpage that could possibly leak information when I transfer it over the internet. Please give me an option to turn this warning off. I DO NOT need you to baby sit me.

jscher2000
  • Top 10 Contributor
2380 solutions 21056 answers

Hi bchase, I understand you want to stop the warning, but as far as I know, there is not currently an option for that. You can give input more directly using

Help > Submit Feedback

This warning should be rare, but some sites have a design problem where it occurs regularly on that site. However, there might be a workaround for the site or sites you find most annoying. Do you want to share a URL or two and describe the steps to re-create the warning?

aebenk 0 solutions 7 answers

I now understand the circumstances under which I get the warning message. It occurs when I am on an https page but without the preceding lock icon. Instead of the lock, there is a little circle thing which indicates that the web site does not supply identity information. Without the identity info, there's no way of knowing for sure that the site is secure. In fact, this very page has that circle icon preceding https. Unfortunately, the message does not always occur, but when it does, it's always on a page as previously described.

Modified by aebenk

jscher2000
  • Top 10 Contributor
2380 solutions 21056 answers

Hi aebenk, thank you for that additional information.

The "globe" icon to the left of a URL indicates that the page contains some content that was retrieved over an HTTP connection; if everything is purely HTTPS then you should see the lock.

It's strange that you don't get the lock on this site; you should. (Just the gray one, not the green one.) I wonder whether an add-on is altering the pages somehow?

aebenk 0 solutions 7 answers

I disabled all extensions and add-ons and the problem disappeared. However, when I re-enabled all of these, the problem was still gone, so there must have been some interference that was cleared up when I did this "reset". It's unfortunate that I now can't isolate the issue any further, but at least I now have my gray and green locks where I should have them. There apparently is interference between two add-ons, maybe caused by the sequence of loading. At any rate, my problem is solved.

Modified by aebenk

amansikarwar 0 solutions 1 answers

I got same problem with firefox and all the browser works perfectly. problem is:"Although this page is encrypted, the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party." I want to disable this popup?

aebenk 0 solutions 7 answers

See my solution, above.

jscher2000
  • Top 10 Contributor
2380 solutions 21056 answers

Chosen Solution

Hi amansikarwar, currently there is no way to turn off this dialog. If you are using a particular site where you see it a lot, you could first try the usual steps of clearing cache and cookies (more below). If that doesn't work, what site is it? Perhaps there is a workaround.

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r (MAC: Command+Shift+r) to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

(WIN) orange Firefox button (or Tools menu) > Options > Advanced
(MAC) Firefox menu > Preferences > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

MaryKnoxville 0 solutions 1 answers

I have check all security measure you are mentioned in the post..I have almost clear my cookies and try reloading the page..But it doesn't helps me out..Is there any other alternatives for it? I am also go through Google drive management for the reference..