Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My bookmarks toolbar disappeared, and I cannot get it back.

  • 9 replies
  • 64 have this problem
  • 60192 views
  • Last reply by jscher2000

more options

I'm on OSX 10.6.8 and Firefox 21.0

The Bookmarks Toolbar is checked under View, but it does not show.

Chosen solution

Firefox's Reset feature creates a folder on your desktop with a name similar to Old Firefox Data. I recommend hanging on to that for a couple of weeks until you are sure you don't need any of your old settings or add-on data.

Read this answer in context 👍 6

All Replies (9)

more options

In case this is due to an extension or custom style rules, could you check whether the bar appears in Firefox's Safe Mode? More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?


Your toolbar customizations are stored in a data file that sometimes becomes corrupted. If you want to try to rule that out, here's the procedure:

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show in Finder" button

Switch back to Firefox and Exit

Pause while Firefox finishes its cleanup, then in your Finder window rename localstore.rdf to something like localstore.old

Restart Firefox. Hopefully your bars are back to normal.

Any luck?

more options

Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible.

  • Firefox menu button > Options
  • View > Toolbars (press F10 to display the menu bar)
  • Right-click empty toolbar area

Use Customize to open the Customize window and set which toolbar items to display.

  • check that "Bookmarks Toolbar items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the toolbar palette into the Customize window to the Bookmarks Toolbar
  • if missing items are in the toolbar palette then drag them back from the Customize window on the toolbar
  • if you do not see an item on a toolbar and in the toolbar palette then click the "Restore Default Set" button to restore the default toolbar setup
more options

I went to troubleshooting information and chose reset, and it worked---

thanks!

more options

i went to troubleshooting information and chose reset---and it worked---

thanks!

more options

Chosen Solution

Firefox's Reset feature creates a folder on your desktop with a name similar to Old Firefox Data. I recommend hanging on to that for a couple of weeks until you are sure you don't need any of your old settings or add-on data.

more options

I had the same problem and none of the solutions worked for me. In the end, I was able to make it appear again by dragging one tab out into a new window.

Then I realised that my bookmarks were slightly bigger than the space available to display them (this could have been the reason for the anomaly) , so I renamed some of them to shorter names. ie. "BBC Sport - Sport" to just "BBC Sport" etc etc.. Now it seems fine. :-)

Modified by nematoth

more options

My Bookmarks Toolbar disappeared after I downloaded the latest version of Firefox. I went to View > Toolbars > Customize and typed in bookmarks in "Add new toolbar" box. The bar with File, Edit, etc. grayed out. I closed the Yahoo page, reopened it, the File, Edit, etc. was functioning again, went into View > Toolbars. The check mark next to Bookmarks had disappeared. I rechecked it and the toolbar reappeared.

Did not really know what I was doing, but it worked. Hope it works for someone else too.

more options

My firefox status bar and tool bar are gone, totally. There is a "findsearch" page that comes up each time I try to start firefox. I cannot remove firefox from windows xp, either in the regular mode, or "safe" mode. In safe mode, a window appears that directs me to the Mozilla web page

more options

Hi jkohler2, could you first check that your Firefox is not stuck in full screen mode? The F11 key switches between full screen and normal views.

To turn on and off the display of individual menu bars and toolbars, you can either:

  • right-click a blank area of the tab bar
  • right-click the "+" button on the tab bar
  • View menu > Toolbars

Can you get the main Navigation Toolbar and Add-on Bar turned back on?