X
Tap here to go to the mobile version of the site.

Support Forum

Firefox just updated to V21 now I can't right click to "open in new window" only "new tab" or "new PRIVATE window"

Posted

Because I'm a bit of a dinosaur I don't use tabs, preferring to use new windows instead. Since the upgrade to V21, when I right click I don't get offered the option to open in a new window, only a new tab or a "private" window. How do I get back to choosing "non-private" windows ?

Because I'm a bit of a dinosaur I don't use tabs, preferring to use new windows instead. Since the upgrade to V21, when I right click I don't get offered the option to open in a new window, only a new tab or a "private" window. How do I get back to choosing "non-private" windows ?

Chosen solution

In Firefox 22.0 I also could not move a tab to a new window - I discovered I had to disable Tab Mix Plus v0.4.1.0 (also 0.4.1.1pre130731a) to get the context menu "Move to new Window" to show again. Also the Menu > File > New Window (ctrl+n) is showing again. Hope this helps someone. TMP is a pretty common addon.

As an aside I discovered that when TWiT.tv videos are playing in a tab, I now have a context menu in the page body with "Page Speed". How great to be able to play vidcasts at 1.5X.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • 5.0.61118.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.com/1/firefox/21.0/WINNT/en-GB/eu/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Funmoods.com 1.5.0 (ffxtlbr@funmoods.com) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon X1250
  • adapterDescription2:
  • adapterDeviceID: 0x791e
  • adapterDeviceID2:
  • adapterDrivers: ati2dvag
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 6-14-2007
  • driverDate2:
  • driverVersion: 8.390.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'10.6']
  • numTotalWindows: 4
  • webglRendererMessage: [u'tryNewerDriver', u'10.6']
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.link.open_newwindow: 2
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.search.update: False
  • browser.startup.homepage: http://www.helmsmanuk.co.uk/
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • browser.tabs.autoHide: True
  • browser.urlbar.autocomplete.enabled: False
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • font.internaluseonly.changed: False
  • gfx.blacklist.suggested-driver-version: 10.6
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1370947789
  • places.history.expiration.transient_current_max_pages: 73805
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • User JS: Yes
  • Accessibility: No
smo 38 solutions 498 answers

To open a new window, press Ctrl+N or (starting from the Firefox button at the top) select Firefox > New Tab > New Window.

Hope it helps.

To open a new window, press '''Ctrl+N''' or (starting from the Firefox button at the top) select '''''Firefox > New Tab > New Window.''''' Hope it helps.

Helpful Reply

Hi smo

Ctr+N does give me a new window but what I want to do (for example) is when google gives me the search results is to open each result in a new window but the only options are open in "new tab" or open in "new private window".

Hi smo Ctr+N does give me a new window but what I want to do (for example) is when google gives me the search results is to open each result in a new window but the only options are open in "new tab" or open in "new private window".
philipp
  • Top 25 Contributor
  • Moderator
5316 solutions 23478 answers

hello Videostar, actually the option to open a link in a new window should still be there in the context menu. can you try to replicate the behaviour when you launch firefox in safe mode once?

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

as an alternative you could also press the shift key while clicking on a link in order to open it in a new window...

hello Videostar, actually the option to open a link in a new window should still be there in the context menu. can you try to replicate the behaviour when you launch firefox in safe mode once? [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] as an alternative you could also press the shift key while clicking on a link in order to open it in a new window...

Question owner

I have 2 PCs both running Windows XP Pro, both with the latest V21 installed. One behaves perfectly but the other has this strange fault. If I click "file" at the top left I am offered 4 options (in the top box) on the good machine - new tab (Ctrl+T), new window (Ctrl+N), new private window (Ctrl+Shift+P) and open file. On the faulty machine there are only three options - new tab (Ctrl+T), new private window (Ctrl+N) and open file. Note that the Ctrl code for the private window is different on the faulty machine.

I have 2 PCs both running Windows XP Pro, both with the latest V21 installed. One behaves perfectly but the other has this strange fault. If I click "file" at the top left I am offered 4 options (in the top box) on the good machine - new tab (Ctrl+T), new window (Ctrl+N), new private window (Ctrl+Shift+P) and open file. On the faulty machine there are only three options - new tab (Ctrl+T), new private window (Ctrl+'''N''') and open file. Note that the Ctrl code for the private window is different on the faulty machine.
damientheo 0 solutions 1 answers

It is a TabMix Setting- Tols Tabmix Links TAb Uncheck Enable Single Window Mode at the bottom

was bugging the hec out of me too

It is a TabMix Setting- Tols Tabmix Links TAb Uncheck Enable Single Window Mode at the bottom was bugging the hec out of me too
cor-el
  • Top 10 Contributor
  • Moderator
17541 solutions 158616 answers

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"
Make sure that you do not run Firefox in (permanent) Private Browsing mode. *https://support.mozilla.org/kb/Private+Browsing *Tools > Options > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use private browsing mode"

Question owner

Thanks damientheo and cor-el. Between you the problem is solved. By trying both possibilities, I came to "tools - options - privacy - history". This was set to "never remember history". Changing it to "remember history" solved the problem. Apparently if "never" is selected, then Firefox runs in permanent private browsing mode (why ?). Thanks once again to everyone.

Thanks damientheo and cor-el. Between you the problem is solved. By trying both possibilities, I came to "tools - options - privacy - history". This was set to "never remember history". Changing it to "remember history" solved the problem. Apparently if "never" is selected, then Firefox runs in permanent private browsing mode (why ?). Thanks once again to everyone.
cor-el
  • Top 10 Contributor
  • Moderator
17541 solutions 158616 answers

Helpful Reply

That is how it works. Current Firefox version make you close and restart Firefox after toggling the History setting that changes Private Browsing mode. In permanent mode you can only open new PB mode windows.

Future Firefox versions will support Private Browsing per tab, this is already available as an extension.

The Firefox menu button gets purple or you get a purple PB mask on the menu bar or tab bar (Linux) if you are in a PB tab and all Private Browsing mode tabs get a dashed underlining unless you are in permanent PB mode.

That is how it works. Current Firefox version make you close and restart Firefox after toggling the History setting that changes Private Browsing mode. In permanent mode you can only open new PB mode windows. Future Firefox versions will support Private Browsing per tab, this is already available as an extension. *Private Tab: https://addons.mozilla.org/firefox/addon/private-tab/ The Firefox menu button gets purple or you get a purple PB mask on the menu bar or tab bar (Linux) if you are in a PB tab and all Private Browsing mode tabs get a dashed underlining unless you are in permanent PB mode.
Pat 3 solutions 26 answers

Chosen Solution

In Firefox 22.0 I also could not move a tab to a new window - I discovered I had to disable Tab Mix Plus v0.4.1.0 (also 0.4.1.1pre130731a) to get the context menu "Move to new Window" to show again. Also the Menu > File > New Window (ctrl+n) is showing again. Hope this helps someone. TMP is a pretty common addon.

As an aside I discovered that when TWiT.tv videos are playing in a tab, I now have a context menu in the page body with "Page Speed". How great to be able to play vidcasts at 1.5X.

In Firefox 22.0 I also could not move a tab to a new window - I discovered I had to disable Tab Mix Plus v0.4.1.0 (also 0.4.1.1pre130731a) to get the context menu "'''''Move to new Window'''''" to show again. Also the Menu > File > New Window (ctrl+n) is showing again. Hope this helps someone. TMP is a pretty common addon. As an aside I discovered that when TWiT.tv videos are playing in a tab, I now have a context menu in the page body with "Page Speed". How great to be able to play vidcasts at 1.5X.

Modified by Pat