Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox wont let me delete my history

  • 1 reply
  • 24 have this problem
  • 184 views
  • Last reply by cor-el

more options

I have tried going to the firefox tab > history > clear recent history but the option to clear history is greyed out and I can't click it. Similarly, when I go to the privacy options and try to make it where it clears my history upon exiting, that option is also greyed out. I have all my history from January, so not having anything to delete is not the problem. How can I fix this?

Chosen solution

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"
Read this answer in context 👍 3

All Replies (1)

more options

Chosen Solution

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"