X
Tap here to go to the mobile version of the site.

Support Forum

Why Yahoo Videos cannot be played in Firefox?

Posted

Error playing Yahoo videos Yahoo Video seriously struggles to load and give error every time I try to play. I have latest version of Adobe flash player installed and it works well for most of the other sites. So its a problem only related to Yahoo Videos site. Kindly do something on this. Thank you.

Error playing Yahoo videos Yahoo Video seriously struggles to load and give error every time I try to play. I have latest version of Adobe flash player installed and it works well for most of the other sites. So its a problem only related to Yahoo Videos site. Kindly do something on this. Thank you.

Additional System Details

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.44.28
  • Version 3.19.1.13088
  • Google Update
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • VLC media player Web Plugin 2.0.6
  • Shockwave Flash 11.3 r300
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • Foxit Reader Plug-In For Firefox and Netscape
  • 5.1.10411.0
  • 2.1
  • PlayStation(R)Network Downloader Check Plug-in
  • Picasa plugin
  • 2,5,3,1
  • DivX Web Player version 2.0.0.254
  • iTunes Detector Plug-in
  • Yahoo Application State Plugin version 1.0.0.7
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • Office Plugin for Netscape Navigator
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5282 solutions 23336 answers

hello, please Update Firefox to the latest release & also update your plugins and see if this can address the issue...

hello, please [[Update Firefox to the latest version]] & also [https://www.mozilla.org/en-US/plugincheck/ update your plugins] and see if this can address the issue...
rgviti 0 solutions 1 answers

Helpful Reply

I have the same problem and have tried all of firefox's suggestions. Works fine in internet explorer. firefox needs to fix.

I have the same problem and have tried all of firefox's suggestions. Works fine in internet explorer. firefox needs to fix.
josephrot 1 solutions 56 answers

Come on, Mozilla, the Yahoo video problem lies within Firefox. Many hundreds of Firefox users, perhaps thousands, can not play Yahoo.com videos in any of their Yahoo sections.

In our case, Firefox + Yahoo video problems started as far back as of version 19, but extends to the current version 23 we have installed on our Win 7 64bit Intel machines.

IE 10, Chrome and other browsers play the Yahoo videos correctly. We used to suspect that perhaps Yahoo wanted MS's Silverlight garbage installed,but it was tested and that was not the issue.

Yahoo Corporate has researched, and their corporate programmers feel strongly there's a problem in Firefox

PLEASE...Quit playing "around the mulberry bush" games and FIX FIREFOX.

P.S.: This grey message color is one of the most repulsive hard to read that I have ever seen in nearly 20 years. Someone IS playing a joke on us, right ?

Come on, Mozilla, the Yahoo video problem lies within Firefox. Many hundreds of Firefox users, perhaps thousands, can not play Yahoo.com videos in any of their Yahoo sections. In our case, Firefox + Yahoo video problems started as far back as of version 19, but extends to the current version 23 we have installed on our Win 7 64bit Intel machines. IE 10, Chrome and other browsers play the Yahoo videos correctly. We used to suspect that perhaps Yahoo wanted MS's Silverlight garbage installed,but it was tested and that was not the issue. '''Yahoo Corporate has researched, and their corporate programmers feel strongly there's a problem in Firefox''' '''''PLEASE...Quit playing "around the mulberry bush" games and FIX FIREFOX.''''' '''P.S.:''' This grey message color is one of the most repulsive hard to read that I have ever seen in nearly 20 years. Someone IS playing a joke on us, right ?

Modified by josephrot

philipp
  • Top 25 Contributor
  • Moderator
5282 solutions 23336 answers

can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here... [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]]

Question owner

None of the solutions given above have worked. It is problem in every system I have used. I have tried in multiple Firefox versions in OS like Windows XP, Windows 7 and linux - Ubuntu. But problem remains the same. All plugins are updated.

Let us know what can be done. Thank you in advance.

None of the solutions given above have worked. It is problem in every system I have used. I have tried in multiple Firefox versions in OS like Windows XP, Windows 7 and linux - Ubuntu. But problem remains the same. All plugins are updated. Let us know what can be done. Thank you in advance.
philipp
  • Top 25 Contributor
  • Moderator
5282 solutions 23336 answers

please provide the url of a page where you can observer this problem and also go to firefox > help > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum - this might give us a clue what is going on...

please provide the url of a page where you can observer this problem and also go to ''firefox > help > troubleshooting information'', copy the contents of that page and paste them here into a reply on the forum - this might give us a clue what is going on...
josephrot 1 solutions 56 answers

What does it take to convince Mozilla HQ that there's a problem IN FIREFOX ?

Of COURSE we, and hundreds of other long-time FF users and technical knowledgeable's, have tried re-starting FF in Safe Mode.

It does and has absolutely no effect on the problem.

Why in the world does Mozilla HQ think we complain about it continuously ?

Since the problem has existed for many months and through more than a few Firefox versions, it gives every evidence of being a major problem not easily solved via programming codes.

'''What does it take to convince Mozilla HQ that there's a problem IN FIREFOX ?''' '''Of COURSE we, and hundreds of other long-time FF users and technical knowledgeable's, have tried re-starting FF in Safe Mode. It does and has absolutely no effect on the problem. Why in the world does Mozilla HQ think we complain about it continuously ?''' '''Since the problem has existed for many months and through more than a few Firefox versions, it gives every evidence of being a major problem not easily solved via programming codes.'''

Modified by josephrot

Question owner

I am attaching the 2 screenshots.

One more thing, I am having proxy server with authentication for my internet connection. I guess these can help you for debugging.

Here is the troubleshooting information.


 Application Basics
       Name
       Firefox
       Version
       16.0.2
       User Agent
       Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0
       Profile Folder
         Show Folder
       Enabled Plugins
         about:plugins
       Build Configuration
         about:buildconfig
       Crash Reports
         about:crashes
       Memory Use
         about:memory
 Extensions
       Name
       Version
       Enabled
       ID
       Adblock Plus
       2.2.4
       true
       {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
       Download YouTube Videos as MP4
       1.5.18
       true
       {b9bfaf1c-a63f-47cd-8b9a-29526ced9060}
       DownThemAll!
       2.0.16
       true
       {DDC359D1-844A-42a7-9AA1-88A850A938A8}
       Easy YouTube Video Downloader
       6.8
       true
       {c0c9a2c7-2e5c-4447-bc53-97718bc91e1b}
       FastestFox
       5.1.8
       true
       smarterwiki@wikiatic.com
       QuickJava
       1.8.0
       true
       {E6C1199F-E687-42da-8C24-E7770CC3AE66}
       AVG Safe Search
       12.0.0.2222
       false
       {1E73965B-8B48-48be-9C8D-68B920ABC1C4}
       AVG Security Toolbar
       11.0.0.9
       false
       avg@toolbar
       Microsoft .NET Framework Assistant
       1.0
       false
       {20a82645-c095-46ed-80e3-08825760534b}
       Skype extension for Firefox
       3.3.0.3971
       false
       {B13721C7-F507-4982-B2E5-502A71474FED}
 Important Modified Preferences
     Name
     Value
       accessibility.typeaheadfind.flashBar
       0
       browser.cache.disk.capacity
       1048576
       browser.cache.disk.smart_size.first_run
       false
       browser.cache.disk.smart_size_cached_value
       225280
       browser.places.smartBookmarksVersion
       4
       browser.search.update
       false
       browser.sessionstore.restore_on_demand
       false
       browser.startup.homepage_override.buildID
       20121024073032
       browser.startup.homepage_override.mstone
       16.0.2
       extensions.lastAppVersion
       16.0.2
       network.cookie.prefsMigrated
       true
       places.database.lastMaintenance
       1376380402
       places.history.expiration.transient_current_max_pages
       4753
       privacy.sanitize.migrateFx3Prefs
       true
       security.warn_viewing_mixed
       false
 Graphics
       Adapter Description
       NVIDIA GeForce 8600 GT
       Vendor ID
       0x10de
       Device ID
       0x0402
       Adapter RAM
       Unknown
       Adapter Drivers
       nv4_disp
       Driver Version
       6.14.11.7116
       Driver Date
       1-3-2008
       WebGL Renderer
       Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.
       GPU Accelerated Windows
       0. Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.
 JavaScript
       Incremental GC
       1
 Accessibility
       Activated
       0
       Prevent Accessibility
       0
 Library Versions
       Expected minimum version
       Version in use
       NSPR
       4.9.2
       4.9.2
       NSS
       3.13.6.0 Basic ECC
       3.13.6.0 Basic ECC
       NSS Util
       3.13.6.0
       3.13.6.0
       NSS SSL
       3.13.6.0 Basic ECC
       3.13.6.0 Basic ECC
       NSS S/MIME
       3.13.6.0 Basic ECC
       3.13.6.0 Basic ECC
I am attaching the 2 screenshots. One more thing, I am having proxy server with authentication for my internet connection. I guess these can help you for debugging. Here is the troubleshooting information. Application Basics Name Firefox Version 16.0.2 User Agent Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0 Profile Folder Show Folder Enabled Plugins about:plugins Build Configuration about:buildconfig Crash Reports about:crashes Memory Use about:memory Extensions Name Version Enabled ID Adblock Plus 2.2.4 true {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} Download YouTube Videos as MP4 1.5.18 true {b9bfaf1c-a63f-47cd-8b9a-29526ced9060} DownThemAll! 2.0.16 true {DDC359D1-844A-42a7-9AA1-88A850A938A8} Easy YouTube Video Downloader 6.8 true {c0c9a2c7-2e5c-4447-bc53-97718bc91e1b} FastestFox 5.1.8 true smarterwiki@wikiatic.com QuickJava 1.8.0 true {E6C1199F-E687-42da-8C24-E7770CC3AE66} AVG Safe Search 12.0.0.2222 false {1E73965B-8B48-48be-9C8D-68B920ABC1C4} AVG Security Toolbar 11.0.0.9 false avg@toolbar Microsoft .NET Framework Assistant 1.0 false {20a82645-c095-46ed-80e3-08825760534b} Skype extension for Firefox 3.3.0.3971 false {B13721C7-F507-4982-B2E5-502A71474FED} Important Modified Preferences Name Value accessibility.typeaheadfind.flashBar 0 browser.cache.disk.capacity 1048576 browser.cache.disk.smart_size.first_run false browser.cache.disk.smart_size_cached_value 225280 browser.places.smartBookmarksVersion 4 browser.search.update false browser.sessionstore.restore_on_demand false browser.startup.homepage_override.buildID 20121024073032 browser.startup.homepage_override.mstone 16.0.2 extensions.lastAppVersion 16.0.2 network.cookie.prefsMigrated true places.database.lastMaintenance 1376380402 places.history.expiration.transient_current_max_pages 4753 privacy.sanitize.migrateFx3Prefs true security.warn_viewing_mixed false Graphics Adapter Description NVIDIA GeForce 8600 GT Vendor ID 0x10de Device ID 0x0402 Adapter RAM Unknown Adapter Drivers nv4_disp Driver Version 6.14.11.7116 Driver Date 1-3-2008 WebGL Renderer Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer. GPU Accelerated Windows 0. Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer. JavaScript Incremental GC 1 Accessibility Activated 0 Prevent Accessibility 0 Library Versions Expected minimum version Version in use NSPR 4.9.2 4.9.2 NSS 3.13.6.0 Basic ECC 3.13.6.0 Basic ECC NSS Util 3.13.6.0 3.13.6.0 NSS SSL 3.13.6.0 Basic ECC 3.13.6.0 Basic ECC NSS S/MIME 3.13.6.0 Basic ECC 3.13.6.0 Basic ECC
philipp
  • Top 25 Contributor
  • Moderator
5282 solutions 23336 answers

@josephrot, mozilla devlopers can only address issues which are reproducible or the cause of which is known.

when i open a random video on yahoo.com it plays fine, so i presume that it won't be a general issue but something in our configuration differs. that's why i've asked you for more information above... if you don't want to troubleshoot the issue and just leave feedback, then please use https://input.mozilla.org/feedback instead since the support forum isn't the right place for that.

@josephrot, mozilla devlopers can only address issues which are reproducible or the cause of which is known. when i open a random video on yahoo.com it plays fine, so i presume that it won't be a general issue but something in our configuration differs. that's why i've asked you for more information above... if you don't want to troubleshoot the issue and just leave feedback, then please use https://input.mozilla.org/feedback instead since the support forum isn't the right place for that.

Modified by philipp

josephrot 1 solutions 56 answers

Philipp, after many months of playing games....

We have sent Mozilla HQ and Yahoo Corporate programmers manifold examples of Yahoo video player pages...

Nothing has come of it back then, nor now, when the whole process was repeated.

In fact, the "quietness" that we notice coming back to us from Mozilla programming says volumes about this potential major problem.

That is, if it's seen in Yahoo user operations, let us hope it does not "spread" to other services and video playing needs. So far, in our extensive Internet "travels", it has not.

Philipp, after many months of playing games.... We have sent Mozilla HQ and Yahoo Corporate programmers manifold examples of Yahoo video player pages... Nothing has come of it back then, nor now, when the whole process was repeated. In fact, the "quietness" that we notice coming back to us from Mozilla programming says volumes about this potential major problem. '''That is, if it's seen in Yahoo user operations, let us hope it does not "spread" to other services and video playing needs. So far, in our extensive Internet "travels", it has not.'''
philipp
  • Top 25 Contributor
  • Moderator
5282 solutions 23336 answers

i have only found one bug about it (https://bugzilla.mozilla.org/show_bug.cgi?id=769952), and this was resolved as invalid because the affected user found out that a content-blocking addon was interfering.

so please make sure that ghostery, adblock and similar extensions are not playing a part in the problem - then you could file a new bug at bugzilla.mozilla.org to get the attention of developers (please supply as much technical information as possible about the issue and your configuration).

i have only found one bug about it ([https://bugzilla.mozilla.org/show_bug.cgi?id=769952]), and this was resolved as invalid because the affected user found out that a content-blocking addon was interfering. so please make sure that ghostery, adblock and similar extensions are not playing a part in the problem - then you could file a new bug at bugzilla.mozilla.org to get the attention of developers (please supply as much technical information as possible about the issue and your configuration).
josephrot 1 solutions 56 answers

When one runs Firefox with add-ons disabled -- safe mode -- that disables ALL add-ons, including any content-blockers operating on Firefox.

Again, safe mode still shows the same Yahoo video playing problems, as does manually disabling the very popular Ad-Blocker with or without Firefox being in safe-mode.

Joe

When one runs Firefox with add-ons disabled -- safe mode -- that disables ALL add-ons, including any content-blockers operating on Firefox. Again, safe mode still shows the same Yahoo video playing problems, as does manually disabling the very popular Ad-Blocker with or without Firefox being in safe-mode. Joe
philipp
  • Top 25 Contributor
  • Moderator
5282 solutions 23336 answers

what security program/firewall you're using?

what security program/firewall you're using?
josephrot 1 solutions 56 answers

Thanks for the reply and yet another testing possibility.

1. The problem also replicates in Windows 7 64bit, with latest Updates, and without the Updates, ditto in Win 7 32bit machines.

2. The problem has no relation to what profile we use. Have tested.

3. The problem has no relation to the anti-virus product in use. Have tested. Depending on machine, we use AVG 2013 or MS Essentials.

Again, over and over and over: Mozilla Firefox has a possibly major problem. If the problem is seen in Yahoo videos, that means it may well be a problem that will be seen on other sites.

This problem is NOT seen using other browsers on the same or different machines.

Joe R. / Knoxville, TN

Thanks for the reply and yet another testing possibility. 1. The problem also replicates in Windows 7 64bit, with latest Updates, and without the Updates, ditto in Win 7 32bit machines. 2. The problem has no relation to what profile we use. Have tested. 3. The problem has no relation to the anti-virus product in use. Have tested. Depending on machine, we use AVG 2013 or MS Essentials. '''Again, over and over and over:''' Mozilla Firefox has a possibly major problem. If the problem is seen in Yahoo videos, that means it may well be a problem that will be seen on other sites. '''This problem is NOT seen using other browsers on the same or different machines.''' Joe R. / Knoxville, TN
philipp
  • Top 25 Contributor
  • Moderator
5282 solutions 23336 answers

another thing you could test if it is working when you keep all other plugins except for Shockwave Flash 11.8, which is necessary to play the content, disabled in the addons manager (plugins stay active during safemode).

another thing you could test if it is working when you keep all other plugins except for Shockwave Flash 11.8, which is necessary to play the content, disabled in the addons manager (plugins stay active during safemode).
josephrot 1 solutions 56 answers

Please, Phillip...enough with insulting our intelligences.

<< another thing you could test if it is working when you keep all other plugins except for Shockwave Flash 11.8, which is necessary to play the content, disabled in the addons manager (plugins stay active during safemode). >>

That's patently obvious, isn't it ?

The problem is or will become serious, and has now been seen over the last four or five FF versions, and has NOT been identified nor solved yet.

Please, Phillip...enough with insulting our intelligences. << another thing you could test if it is working when you keep all other plugins except for Shockwave Flash 11.8, which is necessary to play the content, disabled in the addons manager (plugins stay active during safemode). >> That's patently obvious, isn't it ? The problem is or will become serious, and has now been seen over the last four or five FF versions, and has NOT been identified nor solved yet.
philipp
  • Top 25 Contributor
  • Moderator
5282 solutions 23336 answers

ok joseph, if you don't want to cooperate in a civilised way during a common troubleshooting procedure, then please file a bug report yourself at bugzilla.mozilla.org or leave feedback at https://input.mozilla.org/feedback since we won't be able to help you here in the support forum.

ok joseph, if you don't want to cooperate in a civilised way during a common troubleshooting procedure, then please file a bug report yourself at bugzilla.mozilla.org or leave feedback at https://input.mozilla.org/feedback since we won't be able to help you here in the support forum.

Helpful Reply

ok. There is no point in fighting amongst yourself.

Lets work together and see how we can together solve this.

Btw, I have also tried older versions of firefox and flash plugins. Combinations like Firefox 4, 10, 13, 15, 18. Flash plugins like 10.3, 11.2, 11.3, 11.4, 11.5, 11.7.

None seems to work.

Do not know why but I am suspecting the proxy server as the problem. Youtube works properly. So flash plugin should not be the problem.

Let us know if u need more info. Thank you in advance.

ok. There is no point in fighting amongst yourself. Lets work together and see how we can together solve this. Btw, I have also tried older versions of firefox and flash plugins. Combinations like Firefox 4, 10, 13, 15, 18. Flash plugins like 10.3, 11.2, 11.3, 11.4, 11.5, 11.7. None seems to work. Do not know why but I am suspecting the proxy server as the problem. Youtube works properly. So flash plugin should not be the problem. Let us know if u need more info. Thank you in advance.
josephrot 1 solutions 56 answers

Well, for those that run a proxy server, that's a possibility, but a very remote one.

However, one could presume that the vast majority of FF users do not run a proxy server setup, and that as part of what most would call "proper and usual" operations, a proxy server is not in use.

We very seldom if ever run a proxy server, although privacy online is seemingly becoming more of an issue.

The problem at hand -- essentially Yahoo video's NOT running, and calling a Yahoo "error" message that there's a problem, try again later -- occurs without any proxy whatsoever coming about.

Even if there was a proxy server in use, the Yahoo video should execute properly in the FF browser.

Joe

Well, for those that run a proxy server, that's a possibility, but a very remote one. However, one could presume that the vast majority of FF users do not run a proxy server setup, and that as part of what most would call "proper and usual" operations, a proxy server is not in use. We very seldom if ever run a proxy server, although privacy online is seemingly becoming more of an issue. The problem at hand -- essentially Yahoo video's NOT running, and calling a Yahoo "error" message that''' there's a problem, try again later''' -- occurs without any proxy whatsoever coming about. '''Even if there was a proxy server in use, the Yahoo video should execute properly in the FF browser.''' Joe

Modified by josephrot

josephrot 1 solutions 56 answers

Hmm, YouTube uses mostly SWF and FLV, running in the Flash wrapper, to operate.

Right click on the Yahoo video display, or delve into the page code using FF tools, and you will see that Yahoo does not appear to use Flash / SWF / FLV in any of the Yahoo videos seen so far.

NOTE: Here's a "Yahoo video" that is NOT Yahoo in nature!

It's actually a YouTube Flash video playing on the Yahoo page:

http://search.yahoo.com/search?cs=bz&p=Stevie%20Nicks%20&fr=fp-tts-130&fr2=ps&woeid=12774202

Again, all this is not of too much use to us all in troubleshooting this, as Yahoo video, SWF, FLV, YouTube, et al, all work fine in other browsers...

...and YouTube seems to display and play fine in FF browser.

Joe

Hmm, YouTube uses mostly SWF and FLV, running in the Flash wrapper, to operate. Right click on the Yahoo video display, or delve into the page code using FF tools, and you will see that Yahoo does not appear to use Flash / SWF / FLV in any of the Yahoo videos seen so far. '''NOTE: Here's a "Yahoo video" that is NOT Yahoo in nature! ''' It's actually a YouTube Flash video playing on the Yahoo page: '''http://search.yahoo.com/search?cs=bz&p=Stevie%20Nicks%20&fr=fp-tts-130&fr2=ps&woeid=12774202''' Again, all this is not of too much use to us all in troubleshooting this, as Yahoo video, SWF, FLV, YouTube, et al, all work fine in other browsers... ...and YouTube seems to display and play fine in FF browser. Joe

Modified by josephrot