X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Any way to ENABLE hardware acceleration AND fix Firefox display issues?

Posted

I must have hardware acceleration (specifically the Direct3D acceleration) enabled for a CAD program I'm running but, when enabled, Firefox 20.1 has display problems. Green rectangles appear in column patterns and, occasionally, there will be horizontal lines of "dots" that distort the screen display.

- Installing the latest drivers (6.14.13.783) for my graphics card (nvidia GeForce 7300 LE) did not fix the problem - Disabling hardware acceleration in Firefox does not fix the problem - Resetting Firefox does not solve the problem.

Is Firefox aware of any issues as described? Is this a previously reported issue and, if so, is there a fix? or an update coming to fix it?

Are there any other suggestions or setting changes I can try?

For my current project, I absolutely need hardware acceleration enabled AND for Firefox to display properly.

(pre) Thanks for info and/or assistance.

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Google Update
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • GEPlugin
  • 5.1.20125.0
  • Deposit Driver
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Rhapsody Player Engine Plugin

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • Skype Click to Call 6.9.0.12585 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 7300 LE
  • adapterDescription2:
  • adapterDeviceID: 0x01d1
  • adapterDeviceID2:
  • adapterDrivers: nv4_disp
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 1-31-2013
  • driverDate2:
  • driverVersion: 6.14.13.783
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 7300 LE)
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 80475
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Helpful Reply

Since the hardware acceleration checkbox was created, a second kind of acceleration was added to Firefox that may need to be disabled in about:config; the checkbox has not been extended to toggle both of them for you.

Regular preference (checkbox): gfx.direct2d.disabled (default=false)
Added preference (no checkbox): gfx.content.azure.enabled (default=true)

More info on the new preference in this thread: https://support.mozilla.org/questions/957459


If you haven't used about:config before, here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste gfx and pause while the list is filtered

(3) Double-click gfx.content.azure.enabled to toggle its value from true to false. As with the regular hardware acceleration preference, you might need to restart Firefox before this takes effect.

Modified by jscher2000