X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Cannot see "Portable Document Format" under Options > Applications ?

Posted

I was regularly using Foxit PDF reader plugin to view pdf files inside Firefox browser before the pdfjs plugin came through. After that I have disabled the pdfjs plugin (through about:config) and tried many ways to get back to viewing pdfs in the browser using the Foxit plugin but nothing works. I have reinstalled Firefox, reinstalled the Foxit pdf plugin.

When I go to Options > Options > Applications, I cannot see the "Portable Document Format" option on the left column. There is Adobe Acrobat Forms and XML and there is "Foxit Reader Document" (presumably PDF) and "Foxit Reader FDF Document" - I want to change those opening actions to Foxit inside Firefox, but there is no such option either - so Firefox can just download the file and then open in the external Foxit reader, but not inside it.

Any help to resolve this is appreciated. FF 21, Win 7.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Google Update
  • Google Talk Plugin Video Accelerator version:0.1.44.28
  • Version 3.19.1.13088
  • VLC media player Web Plugin 2.0.6
  • Foxit Reader Plug-In For Firefox and Netscape
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • DivX Plus Web Player version 2.2.2.14
  • 5.1.20125.0
  • Facebook Video Calling Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Windows Activation Technologies Plugin for Mozilla
  • DivX VOD Helper Plug-in
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • NPWLPG
  • Office Live Update v1.4

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

M_G_A 4 solutions 10 answers

Helpful Reply

Hello! You can't see the PDF under Options -> Applications because you disabled pdf.js in about:config (I think you set pdfjs.disabled to "true", right?) If you go again to about:config and set pdfjs.disabled to "false" you'll see the PDF option again! To change how you view it just click on the spinner on the right. If you have the Foxit PDF reader plugin installed you'll see that in the list of available applications. More information here: Disable built-in PDF viewer and use another viewer.

And please, don't use about:config to change your preferences, it can be dangerous: it's preferable to change them from Options. Hope it helps!

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

You can change the action for Portable Document Format (PDF) from Preview in Firefox to use the Adobe Reader or set to Always Ask in "Firefox > Options/Preferences > Applications".

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu.

See also:

Question owner

Thanks M_G_A for the good tip, after making pdfjs.disabled to false - I can now see the "Portable Document Format" option. But unfortunately in the actions for it I can only see "Adobe Acrobat(in Firefox)' or "Foxit Reader" as an external. Seems I cannot use Foxit currently to view it inside Firefox itself, even though the Above reader plugin is disabled in FF. I also deleted the Mimetypes.rdf from the profile folder. Now will try to uninstall Adobe, then lets see what happens.

Helpful Reply

After the above action, I uninstalled both Foxit and Adobe Reader. Then searched for old versions of Abobe reader plugins and deleted it. Installed Foxit. Then in Options > Options > Applications for PDF selected Open using Foxit in FF. Then I copied the npFoxitReaderPlugin.dll file from the Foxit/plugins folder to a new folder in Firefox directory and renamed that folder to "plugins". Now my pdfs open in FF in Foxit. yay !! finally !