Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I stop

  • 12 replies
  • 2 have this problem
  • 195 views
  • Last reply by cor-el

more options

Since I downloaded a new version of mozilla, every time I open firefox it opens a tab mozilla.org next to a tab with my home page. How do I stop firefox opening the tab with the mozilla.org page?

Chosen solution

The folder only contains one other folder named "default", which does not contain anything that looked like profiles settings. Anyway, thanks again and I'll close this by setting my problem as solved.

Read this answer in context 👍 0

All Replies (12)

more options

Hi leenstougie,

This article show You to Set what pages open when Firefox starts

https://support.mozilla.org/en-US/kb/How%20to%20set%20the%20home%20page#w_set-what-pages-open-when-firefox-starts

more options

Clicking "Restore to Default" doesnot show my homepage "Google" but "Mozilla Firefox Strat Page" as is shown on the picture from the Mozilla support tool. If I don't do anything else but click OK and start up mozilla again, then it opens again with two tabs: one mozilla.org and the other Mozilla Firefox Strat Page. The only thing I can do is then setting back my home page to google.com upon which I get, upon opening Mozilla again, the two tabs mozilla.org and google.com. So I can't get rid of this mozilla.org.

more options

Clicking "Restore to Default" doesnot show my homepage "Google" but "Mozilla Firefox Strat Page" as is shown on the picture. If I don't do anything but click OK and start up mozilla again, then it opens again with two tabs: one mozilla.org and the other Mozilla Firefox Strat Page. The only thing I can do is then setting back my home page to google.com upon which I get, upon opening Mozilla again, the two tabs mozilla.org and google.com. So I can't get rid of this mozilla.org.

more options

My strong guess is that, You have added Two Tabs in the When Firefox starts section. Please check the Screen shot. And ensure there is only one URL added.


In Your case it would be http://www.google.com/

more options

If you do not keep changes after a restart then see:

more options

My strong guess is that Mozilla has hacked its own system and urges the user to opne with its own Mozilla website, and that something really technical needs to be done to stop Mozilla doing this.

Anyway thanks a lot for you attention. I will set the problem as solved, becuase I don't think that anyone except for the Mozilla organisation in Mountani View can solve this problem

more options

You can rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

You can use this button to go to the Firefox profile folder:

more options

I answered that it helped me, and I thank you for your effort. I answered yes , so that my question will be closed. See above, my arguments, that I think it is a stupidity of Mozilla, whoch brings an enormous discrdit on their name this way. They start to behave even worse than Microsoft.

Clearly, my problem is not solved. I can't reach the profile.js file in the way indicated. I am of course a nitwit. Hopefully my systems manager knows how to stop Mozilla's bad behaviour.

more options

Which support article mentioned a profile.js file?

more options

In what way is the button (link) on the "Help > Troubleshooting Information" page not succeeding in bringing you to the Firefox profile folder?

  • C:\Documents and Settings\<user>\Application Data\Mozilla\Firefox\Profiles\<profile>\

The "Application Data" folder in XP/Win2K and the "AppData" folder in Windows Vista and later Windows 7+ versions are hidden folders.

more options

Chosen Solution

The folder only contains one other folder named "default", which does not contain anything that looked like profiles settings. Anyway, thanks again and I'll close this by setting my problem as solved.

more options

Windows hides some file extensions by default.
Among them are .html and .ini and .js and .txt, so you may only see a name without file extension (prefs instead of prefs.js). You can see the real file type if you open the Properties via the right-click context menu.